'guix substitute' crashes while running 'guix pull'

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxime Devos
  • Zelphir Kaltstahl
Owner
unassigned
Submitted by
Zelphir Kaltstahl
Severity
important
Merged with
Z
Z
Zelphir Kaltstahl wrote on 14 Apr 2021 01:45
guix pull bug
(address . bug-guix@gnu.org)
ba8ea228-6474-3c5a-16e9-ab845f77cb9d@posteo.de
Hi!

I am experiencing a bug when running `guix pull` again. Not sure, whether it is
the same as the previous one, or a different one. This is a different machine
than the previous bug report I sent in. Guix told me to please report it, so
here it goes:

~~~~
$ guix pull
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Authenticating channel 'guix', commits 9edb3f6 to 4dff6ec (84 new commits)...
Building from this channel:
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
compute-guix-derivation 1KiB 108KiB/s 00:00 [##################] 100.0%

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
curl-7.76.0 385KiB 514.2MiB/s 00:00 [##################] 100.0/

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
git-minimal-2.31.1 4.1MiB 5.8MiB/s 00:01 [##################] 100.0/

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
guile-avahi-0.4.0-1.6d43caf 54KiB 101.3MiB/s 00:00 [##################] 100.0%

guile-git-0.5.0 1.13GiB/s 00:00 | 551KiB transferred

Backtrace:
In guix/ui.scm:
2164:12 19 (run-guix-command _ . _)
In guix/scripts/substitute.scm:
652:2 18 (guix-substitute . _)
In unknown file:
17 (with-continuation-barrier #<procedure thunk ()>)
In ice-9/boot-9.scm:
1736:10 16 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
15 (apply-smob/0 #<thunk 7fda6a3dd2a0>)
In ice-9/boot-9.scm:
1736:10 14 (with-exception-handler _ _ #:unwind? _ # _)
1736:10 13 (with-exception-handler _ _ #:unwind? _ # _)
1731:15 12 (with-exception-handler #<procedure 7fda698e68d0 at ic?> ?)
In guix/scripts/substitute.scm:
701:17 11 (_)
410:7 10 (process-substitution _ "/gnu/store/62hfr56ipl706k17g0?" ?)
In ice-9/boot-9.scm:
1736:10 9 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/substitute.scm:
419:9 8 (_)
In ice-9/boot-9.scm:
1731:15 7 (with-exception-handler #<procedure 7fda68cffcc0 at ic?> ?)
1669:16 6 (raise-exception _ #:continuable? _)
1667:16 5 (raise-exception _ #:continuable? _)
1669:16 4 (raise-exception _ #:continuable? _)
Backtrace:
15 (primitive-load "/gnu/store/lfjklynfh3kwsx0iwfwcm71y4qf36ww3-compute-guix-derivation")
In ice-9/eval.scm:
155:9 14 (_ _)
159:9 13 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#<directory (guile-u?> ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
In ice-9/boot-9.scm:
152:2 12 (with-fluid* _ _ _)
152:2 11 (with-fluid* _ _ _)
In ./guix/store.scm:
2066:24 10 (run-with-store #<store-connection 256.99 7f1b193713c0> _ #:guile-for-build _ #:system _ #:target _)
1900:8 9 (_ _)
In ./guix/gexp.scm:
256:18 8 (_ _)
1137:2 7 (_ _)
1003:2 6 (_ _)
849:4 5 (_ _)
In ./guix/store.scm:
1948:12 4 (_ #<store-connection 256.99 7f1b193713c0>)
1362:5 3 (map/accumulate-builds #<store-connection 256.99 7f1b193713c0> _ _)
1373:15 2 (_ #<store-connection 256.99 7f1b193713c0> _ _)
719:11 1 (process-stderr #<store-connection 256.99 7f1b193713c0> _)
In ./guix/serialization.scm:
80:6 0 (read-int #<input-output: file 10>)

./guix/serialization.scm:80:6: In procedure read-int:
ERROR:
1. &nar-error:
file: #f
port: #<input-output: file 10>
guix pull: error: You found a bug: the program '/gnu/store/lfjklynfh3kwsx0iwfwcm71y4qf36ww3-compute-guix-derivation'
failed to compute the derivation for Guix (version: "4dff6ecde85eec473ab231cf75f51e98e8aca1e9"; system: "x86_64-linux";
host version: "7327295462fccae4ee3e9bf74962c82d3445fec8"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.
~~~~

This time I already know I can try `guix pull --no-substitutes`. This ran
without error:

~~~~
$ guix pull --no-substitutes
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Building from this channel:
building /gnu/store/292slsvr461pf4mmxp5pbn7izyrz6j7a-mkdir.drv...
building /gnu/store/nlfh939ppk5hjqlrg3qa2bggypwv5yga-guile-json-3.5.0.tar.gz.drv...
building /gnu/store/cz47v443jm6nbjsl0256wnj525d9bdxp-guile-lib-0.2.7.tar.gz.drv...
building /gnu/store/nb3vkf3xdpzmq332c1g9plw1fbyv5kqc-guile-json-3.5.0.drv...
building /gnu/store/9wsr9qwm40qcm7cxj4zwnn4jqsl28nfw-guile-lib-0.2.7.drv...
- 'check' phasebuild-log 23528 4096
html->shtml "&#X42" #:strict? 'unset)
==> (*TOP* "B")
;; Passed.

(html->shtml "&42;" #:strict? 'unset)
==> (*TOP* "&42;")
;; Passed.

(html->shtml "aaa&copy;bbb&amp;ccc&lt;ddd&&gt;eee&#42;fff&#1000;ggg&#x5a;hhh" #:strict? 'unset)
==> (*TOP* "aaa" (*ENTITY* "additional" "copy") "bbb&ccc<ddd&>eee*fff" (*ENTITY* "additional-char" "1000") "gggZhhh")
;; Passed.

(html->shtml "<IMG src=\"http://pics.ebay.com/aw/pics/listings/ebayLogo_38x16.gif\"border=0 width=\"38\" height=\"16\" HSPACE=5 VSPACE=0\" 2 /FONT " #:strict? 'unset)
==> (*TOP* (img (@ (src "http://pics.ebay.com/aw/pics/listings/ebayLogo_38x16.gif")(border "0") (width "38") (height "16") (hspace "5") (vspace "0"))) "2")
;; Passed.

(html->shtml "<aaa bbb=ccc\"ddd>eee" #:strict? 'unset)
==> (*TOP* (aaa (@ (bbb "ccc") (ddd)) "eee"))
;; Passed.

(html->shtml "<aaa bbb=ccc \"ddd>eee" #:strict? 'unset)
==> (*TOP* (aaa (@ (bbb "ccc") (ddd)) "eee"))
;; Passed.

(html->shtml "<HTML><Head><Title>My Title</Title></Head><Body BGColor=\"white\" Foo=42>This is a <B><I>bold-italic</B></I> test of </Erk>broken HTML.<br>Yes it is.</Body></HTML>" #:strict? 'unset)
==> (*TOP* (html (head (title "My Title")) (body (@ (bgcolor "white") (foo "42")) "This is a " (b (i "bold-italic")) " test of " "broken HTML." (br) "Yes it is.")))
;; Passed.

(html->shtml "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\"" #:strict? 'unset)
==> (*TOP* (*DECL* DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"))
;; Passed.

(html->shtml "<html xmlns=\"http://www.w3.org/1999/xhtml\"xml:lang=\"en\" lang=\"en\" " #:strict? 'unset)
==> (*TOP* (html (@ (xmlns "http://www.w3.org/1999/xhtml")(lang "en") (lang "en"))))
;; Passed.

(html->shtml "<html:html xmlns:html=\"http://www.w3.org/TR/REC-html40\" html:head html:title Frobnostication /html:title /html:head html:body html:p Moved to html:a href=\"http://frob.com\" here. /html:a /html:p /html:body /html:html " #:strict? 'unset)
==> (*TOP* (html (@ (xmlns:html "http://www.w3.org/TR/REC-html40"))(head (title "Frobnostication")) (body (p "Moved to " (a (@ (href "http://frob.com")) "here.")))))
;; Passed.

(html->shtml "<RESERVATION xmlns:HTML=\"http://www.w3.org/TR/REC-html40\" NAME HTML:CLASS=\"largeSansSerif\" Layman, A /NAME SEAT CLASS=\"Y\" HTML:CLASS=\"largeMonotype\" 33B /SEAT HTML:A HREF=\"/cgi-bin/ResStatus\" Check Status /HTML:A DEPARTURE 1997-05-24T07:55:00+1 /DEPARTURE /RESERVATION " #:strict? 'unset)
==> (*TOP* (reservation (@ (xmlns:HTML "http://www.w3.org/TR/REC-html40"))(name (@ (class "largeSansSerif")) "Layman, A") (seat (@ (class "Y") (class "largeMonotype")) "33B") (a (@ (href "/cgi-bin/ResStatus")) "Check Status") (departure "1997-05-24T07:55:00+1")))
;; Passed.

(html->shtml "<html><head><title></title><title>whatever</title></head><body><a href=\"url\">link</a><p align=center><ul compact style=\"aa\"><p>BLah<!-- comment <comment> --> <i> italic <b> bold <tt> ened </i> still &lt; bold </b></body><P> But not done yet..." #:strict? 'unset)
==> (*TOP* (html (head (title) (title "whatever")) (body (a (@ (href "url")) "link") (p (@ (align "center")) (ul (@ (compact) (style "aa")))) (p "BLah" (*COMMENT* " comment <comment> ") " " (i " italic " (b " bold " (tt " ened "))) " still < bold ")) (p " But not done yet...")))
;; Passed.

(html->shtml "<?xml version=\"1.0\" encoding=\"UTF-8\"?>" #:strict? 'unset)
==> (*TOP* (*PI* xml "version=\"1.0\" encoding=\"UTF-8\""))
;; Passed.

(html->shtml "<?php php_info(); ?>" #:strict? 'unset)
==> (*TOP* (*PI* php "php_info(); "))
;; Passed.

(html->shtml "<?php php_info(); ?" #:strict? 'unset)
==> (*TOP* (*PI* php "php_info(); ?"))
;; Passed.

(html->shtml "<?php php_info(); " #:strict? 'unset)
==> (*TOP* (*PI* php "php_info(); "))
;; Passed.

(html->shtml "<?foo bar ? baz > blort ?>" #:strict? 'unset)
==> (*TOP* (*PI* foo "bar ? baz > blort "))
;; Passed.

(html->shtml "<?foo b?>x" #:strict? 'unset)
==> (*TOP* (*PI* foo "b") "x")
;; Passed.

(html->shtml "<?foo ?>x" #:strict?@ build-log 23528 4090
'unset)
==> (*TOP* (*PI* foo "") "x")
;; Passed.

(html->shtml "<?foo ?>x" #:strict? 'unset)
==> (*TOP* (*PI* foo "") "x")
;; Passed.

(html->shtml "<?foo?>x" #:strict? 'unset)
==> (*TOP* (*PI* foo "") "x")
;; Passed.

(html->shtml "<?f?>x" #:strict? 'unset)
==> (*TOP* (*PI* f "") "x")
;; Passed.

(html->shtml "<??>x" #:strict? 'unset)
==> (*TOP* (*PI* #f "") "x")
;; Passed.

(html->shtml "<?>x" #:strict? 'unset)
==> (*TOP* (*PI* #f ">x"))
;; Passed.

(html->shtml "<foo bar=\"baz\">blort" #:strict? 'unset)
==> (*TOP* (foo (@ (bar "baz")) "blort"))
;; Passed.

(html->shtml "<foo bar='baz'>blort" #:strict? 'unset)
==> (*TOP* (foo (@ (bar "baz")) "blort"))
;; Passed.

(html->shtml "<foo bar=\"baz'>blort" #:strict? 'unset)
==> (*TOP* (foo (@ (bar "baz'>blort"))))
;; Passed.

(html->shtml "<foo bar='baz\">blort" #:strict? 'unset)
==> (*TOP* (foo (@ (bar "baz\">blort"))))
;; Passed.

(html->shtml "<p>A</p><script>line0 <\nline1\n<line2></script><p>B</p>" #:strict? 'unset)
==> (*TOP* (p "A") (script "line0 <\n" "line1\n" "<line2>") (p "B"))
;; Passed.

(html->shtml "<xmp>a<b>c</XMP>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<XMP>a<b>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<xmp>a<b>c</foo:xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<foo:xmp>a<b>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<foo:xmp>a<b>c</foo:xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<foo:xmp>a<b>c</bar:xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a<b>c") "d")
;; Passed.

(html->shtml "<xmp>a</b>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b>c") "d")
;; Passed.

(html->shtml "<xmp>a</b >c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b >c") "d")
;; Passed.

(html->shtml "<xmp>a</ b>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</ b>c") "d")
;; Passed.

(html->shtml "<xmp>a</ b >c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</ b >c") "d")
;; Passed.

(html->shtml "<xmp>a</b:x>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b:x>c") "d")
;; Passed.

(html->shtml "<xmp>a</b::x>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b::x>c") "d")
;; Passed.

(html->shtml "<xmp>a</b:::x>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b:::x>c") "d")
;; Passed.

(html->shtml "<xmp>a</b:>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b:>c") "d")
;; Passed.

(html->shtml "<xmp>a</b::>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</b::>c") "d")
;; Passed.

(html->shtml "<xmp>a</xmp:b>c</xmp>d" #:strict? 'unset)
==> (*TOP* (xmp "a</xmp:b>c") "d")
;; Passed.

(html->shtml "<P>real1</P>\n<XMP>\nalpha\n<P>fake</P>\nbravo\n</XMP \n<P>real2</P>" #:strict? 'unset)
==> (*TOP* (p "real1") "\n" (xmp "\n" "alpha\n" "<P>fake</P>\n" "bravo\n") (p "real2"))
;; Passed.

(html->shtml "<P>real1</P>\n<XMP>\nalpha\n<P>fake</P>\nbravo\n</XMP\n<P>real2</P>" #:strict? 'unset)
==> (*TOP* (p "real1") "\n" (xmp "\n" "alpha\n" "<P>fake</P>\n" "bravo\n") (p "real2"))
;; Passed.

(html->shtml "<xmp>a</xmp>x" #:strict? 'unset)
==> (*TOP* (xmp "a") "x")
;; Passed.

(html->shtml "<xmp>a\n</xmp>x" #:strict? 'unset)
==> (*TOP* (xmp "a\n") "x")
;; Passed.

(html->shtml "<xmp></xmp>x" #:strict? 'unset)
==> (*TOP* (xmp) "x")
;; Passed.

(html->shtml "<xmp>a</xmp" #:strict? 'unset)
==> (*TOP* (xmp "a"))
;; Passed.

(html->shtml "<xmp>a</xm" #:strict? 'unset)
==> (*TOP* (xmp "a</xm"))
;; Passed.

(html->shtml "<xmp>a</x" #:strict? 'unset)
==> (*TOP* (xmp "a</x"))
;; Passed.

(html->shtml "<xmp>a</" #:strict? 'unset)
==> (*TOP* (xmp "a</"))
;; Passed.

(html->shtml "<xmp>a<" #:strict? 'unset)
==> (*TOP* (xmp "a<"))
;; Passed.

(html->shtml "<xmp>a" #:strict? 'unset)
==> (*TOP* (xmp "a"))
;; Passed.

(html->shtml "<xmp>" #:strict? 'unset)
==> (*TOP* (xmp))
;; Passed.

(html->shtml "<xmp" #:strict? 'unset)
==> (*TOP* (xmp))
;; Passed.

(html->shtml "<xmp x=42 " #:strict? 'unset)
==> (*TOP* (xmp (@ (x "42"))))
;; Passed.

(html->shtml "<xmp x= " #:strict? 'unset)
==> (*TOP* (xmp (@ (x))))
;; Passed.

(html->shtml "<xmp x " #:@ build-log 23528 2197

Running test suite: main-suite ----------------------------------------

Running test suite: <test-xml-pragmatic>-suite ------------------------
Running test case: test-all

1 run, 0 failed
strict? 'unset)
==> (*TOP* (xmp (@ (x))))
;; Passed.

(html->shtml "<xmp x" #:strict? 'unset)
==> (*TOP* (xmp (@ (x))))
;; Passed.

(html->shtml "<script>xxx" #:strict? 'unset)
==> (*TOP* (script "xxx"))
;; Passed.

(html->shtml "<script/>xxx" #:strict? 'unset)
==> (*TOP* (script) "xxx")
;; Passed.

(shtml->html '(p))
==> "<p></p>"
;; Passed.

(shtml->html '(p "CONTENT"))
==> "<p>CONTENT</p>"
;; Passed.

(shtml->html '(br))
==> "<br />"
;; Passed.

(shtml->html '(br "CONTENT"))
==> "<br />"
;; Passed.

(shtml->html '(hr (@ (clear "all"))))
==> "<hr clear=\"all\" />"
;; Passed.

(shtml->html '(hr (@ (noshade))))
==> "<hr noshade />"
;; Passed.

(shtml->html '(hr (@ (noshade #t))))
==> "<hr noshade />"
;; Passed.

(shtml->html '(hr (@ (noshade "noshade"))))
==> "<hr noshade=\"noshade\" />"
;; Passed.

(shtml->html '(hr (@ (aaa "bbbccc"))))
==> "<hr aaa=\"bbbccc\" />"
;; Passed.

(shtml->html '(hr (@ (aaa "bbb'ccc"))))
==> "<hr aaa=\"bbb'ccc\" />"
;; Passed.

(shtml->html '(hr (@ (aaa "bbb\"ccc"))))
==> "<hr aaa='bbb\"ccc' />"
;; Passed.

(shtml->html '(hr (@ (aaa "bbb\"ccc'ddd"))))
==> "<hr aaa=\"bbb&quot;ccc'ddd\" />"
;; Passed.

(shtml->html '(*PI* xml "version=\"1.0\" encoding=\"UTF-8\""))
==> "<?xml version=\"1.0\" encoding=\"UTF-8\"?>"
;; Passed.

(shtml->html '(*DECL* DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"))
==> "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\""
;; Passed.

(html->shtml "<body><blockquote><p>foo</p>\n</blockquote></body>" #:strict? 'unset)
==> (*TOP* (body (blockquote (p "foo") "\n")))
;; Passed.

(html->shtml "<body><blockquote><p>foo</p>\n</blockquote></body>" #:strict? #f)
==> (*TOP* (body (blockquote) (p "foo") "\n"))
;; Passed.

(html->shtml "<body><blockquote><p>foo\n</blockquote></body>" #:strict? 'unset)
==> (*TOP* (body (blockquote (p "foo\n"))))
;; Passed.

*** All Tests PASSED *** Passed: 128 Failed: 0
building /gnu/store/2ik5jbfa39zcv2g01bw68j20p1myw55p-module-import-compiled.drv...
building /gnu/store/nwllis8b0mpdp1a8zr038bjlj34c9z8p-module-import-compiled.drv...
building /gnu/store/x6n0qj4y0vpgavdggvbf92fz3gnnv6s5-openssl-1.1.1k.tar.gz.drv...
building /gnu/store/hyihrq6brzrkvvpikm3zmslhhlvyx5xy-tar.drv...
building /gnu/store/s5b162lasqpw9g4p6567drrgf84izvr4-openssl-1.1.1k.tar.xz.drv...
building /gnu/store/046lwac3v42aw2ggvm7kgps143n4r768-xz.drv...
building /gnu/store/fcndbk0pxnj2hbjax45hd7n6nr9sjm4m-openssl-1.1.1k.drv...
building /gnu/store/ygfcgz0001m8f3lw8jdx70n0n8m6rqcq-zip30.tar.gz.drv...
applying 1 graft for /gnu/store/54zz5bh8zqjdjh5bp01z80484xizhaam-cyrus-sasl-2.1.27.drv ...
building /gnu/store/lam6h0qnr7bj7mr5hlix4glnf5f2wymk-zip-3.0.drv...
applying 2 grafts for /gnu/store/jcfn1b8gk2h6qzn0ibyy67hz00w0x5ma-openldap-2.4.57.drv ...
applying 3 grafts for /gnu/store/cdnrvbr03nhg8ly1msi65lz4m8k5l3cl-curl-7.76.0.drv ...
applying 2 grafts for /gnu/store/fpq3zjj3kxg4z8wk5508jif2kzc708qg-git-minimal-2.31.1.drv ...
building /gnu/store/akspxzq9iw5pn5ra4jlb1sp874p5wp0v-guix-1.2.0-20.2d73086-checkout.drv...
building /gnu/store/hzbh1nqi0hamj23aa5wv6r30p01mfjns-zziplib-0.13.72-checkout.drv...
building /gnu/store/5qbmii159jyxgfpv7a66wkaipnmszkyr-guix-daemon-1.2.0-20.2d73086.drv...
building /gnu/store/5kamvb2d69vbhq5qm3y7nlxxlmi64pmb-zziplib-0.13.72.drv...
22% [########################################################## ]ild-log 70451 479
/tmp/guix-build-zziplib-0.13.72.drv-0/source/zzip/fetch.h:232:41: warning: initialization makes integer from pointer without a cast [-Wint-conversion]
#define zzip_file_header_to_data(__p) ((zzip_byte_t*) \
^
/tmp/guix-build-zziplib-0.13.72.drv-0/source/zzip/mmapped.c:664:20: note: in expansion of macro ?zzip_file_header_to_data?
off_t offset = zzip_file_header_to_data(header);
^~~~~~~~~~~~~~~~~~~~~~~~
22% [########################################################## ]log 70451 209
/tmp/guix-build-zziplib-0.13.72.drv-0/source/zzip/mmapped.c:685:24: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
file->zlib.next_in = offset;
^
- 'install-license-files' phase
The following derivations will be built:
/gnu/store/5qkq8w45wlp2ir05w5g9hfrmj4p6aiiy-profile.drv
/gnu/store/gl94mrqwqdmz98l5fwk756xzrwhm9ha6-guix-4dff6ecde.drv
/gnu/store/al24h5p65c67jhszlj9596khybm7yrfd-guix-daemon.drv
/gnu/store/apzhnh46x94f5qghq7cdl4843dpzwiyq-guix-command.drv
/gnu/store/jwpzpnzlcn60inhqwpyy68cn8yhmgljy-guix-module-union.drv
/gnu/store/mvjz0n0pyrss7432qdz00kaakg4nhhd0-sqlite-3.32.3.drv
/gnu/store/k29xdkgfwn6qj3l7ni25981zk1mci4z0-sqlite-autoconf-3320300.tar.gz.drv
/gnu/store/cdqjf6fjvxrm57iqizsax9njsm65qhxm-guix-4dff6ecde-modules.drv
/gnu/store/0q748mp1n1rq1l2p5048q09j850wscn9-guix-config-modules.drv
/gnu/store/49jfcqbypab3h69gj739mqpvs1liccc4-guix-config.drv
/gnu/store/6k7lrx0xyhlnsh4l8b85mj1q5xi121j1-guix-config-source.drv
/gnu/store/9gyy
This message was truncated. Download the full message here.
Attachment: file
L
L
Ludovic Courtès wrote on 18 Apr 2021 12:20
control message for bug #47764
(address . control@debbugs.gnu.org)
871rb7nbb4.fsf@gnu.org
merge 47764 47782
quit
L
L
Ludovic Courtès wrote on 18 Apr 2021 12:20
(address . control@debbugs.gnu.org)
87zgxvlwqk.fsf@gnu.org
severity 47764 important
quit
L
L
Ludovic Courtès wrote on 18 Apr 2021 12:28
Re: bug#47764: guix pull bug
(name . Zelphir Kaltstahl)(address . zelphirkaltstahl@posteo.de)(address . 47764@debbugs.gnu.org)
87o8eblwee.fsf@gnu.org
Hi Zelphir,

Zelphir Kaltstahl <zelphirkaltstahl@posteo.de> skribis:

Toggle quote (88 lines)
> $ guix pull
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Authenticating channel 'guix', commits 9edb3f6 to 4dff6ec (84 new commits)...
> Building from this channel:
> guix https://git.savannah.gnu.org/git/guix.git 4dff6ec
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> downloading from https://ci.guix.gnu.org/nar/lzip/lfjklynfh3kwsx0iwfwcm71y4qf36ww3-compute-guix-derivation ...
> compute-guix-derivation 1KiB 108KiB/s 00:00 [##################] 100.0%
>
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> downloading from https://ci.guix.gnu.org/nar/lzip/1qd88064j2iicfnkxf5ylffmvisnsdlw-curl-7.76.0 ...
> curl-7.76.0 385KiB 514.2MiB/s 00:00 [##################] 100.0/
>
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> downloading from https://ci.guix.gnu.org/nar/lzip/531rwkb8m6yccq4l1mkrqxclrqwy0jj3-git-minimal-2.31.1 ...
> git-minimal-2.31.1 4.1MiB 5.8MiB/s 00:01 [##################] 100.0/
>
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> downloading from https://ci.guix.gnu.org/nar/lzip/kqmxkrw1kzq486ywgbjw74r6rz1cjnxl-guile-avahi-0.4.0-1.6d43caf ...
> guile-avahi-0.4.0-1.6d43caf 54KiB 101.3MiB/s 00:00 [##################] 100.0%
>
> downloading from https://ci.guix.gnu.org/nar/lzip/h3mqirjnv5q7qyfkpswyvxhcarsz6is7-guile-git-0.5.0 ...
> guile-git-0.5.0 1.13GiB/s 00:00 | 551KiB transferred
>
> Backtrace:
> In guix/ui.scm:
> 2164:12 19 (run-guix-command _ . _)
> In guix/scripts/substitute.scm:
> 652:2 18 (guix-substitute . _)
> In unknown file:
> 17 (with-continuation-barrier #<procedure thunk ()>)
> In ice-9/boot-9.scm:
> 1736:10 16 (with-exception-handler _ _ #:unwind? _ # _)
> In unknown file:
> 15 (apply-smob/0 #<thunk 7fda6a3dd2a0>)
> In ice-9/boot-9.scm:
> 1736:10 14 (with-exception-handler _ _ #:unwind? _ # _)
> 1736:10 13 (with-exception-handler _ _ #:unwind? _ # _)
> 1731:15 12 (with-exception-handler #<procedure 7fda698e68d0 at ic?> ?)
> In guix/scripts/substitute.scm:
> 701:17 11 (_)
> 410:7 10 (process-substitution _ "/gnu/store/62hfr56ipl706k17g0?" ?)
> In ice-9/boot-9.scm:
> 1736:10 9 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/scripts/substitute.scm:
> 419:9 8 (_)
> In ice-9/boot-9.scm:
> 1731:15 7 (with-exception-handler #<procedure 7fda68cffcc0 at ic?> ?)
> 1669:16 6 (raise-exception _ #:continuable? _)
> 1667:16 5 (raise-exception _ #:continuable? _)
> 1669:16 4 (raise-exception _ #:continuable? _)
> Backtrace:
> 15 (primitive-load "/gnu/store/lfjklynfh3kwsx0iwfwcm71y4qf36ww3-compute-guix-derivation")
> In ice-9/eval.scm:
> 155:9 14 (_ _)
> 159:9 13 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#<directory (guile-u?> ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
> In ice-9/boot-9.scm:
> 152:2 12 (with-fluid* _ _ _)
> 152:2 11 (with-fluid* _ _ _)
> In ./guix/store.scm:
> 2066:24 10 (run-with-store #<store-connection 256.99 7f1b193713c0> _ #:guile-for-build _ #:system _ #:target _)
> 1900:8 9 (_ _)
> In ./guix/gexp.scm:
> 256:18 8 (_ _)
> 1137:2 7 (_ _)
> 1003:2 6 (_ _)
> 849:4 5 (_ _)
> In ./guix/store.scm:
> 1948:12 4 (_ #<store-connection 256.99 7f1b193713c0>)
> 1362:5 3 (map/accumulate-builds #<store-connection 256.99 7f1b193713c0> _ _)
> 1373:15 2 (_ #<store-connection 256.99 7f1b193713c0> _ _)
> 719:11 1 (process-stderr #<store-connection 256.99 7f1b193713c0> _)
> In ./guix/serialization.scm:
> 80:6 0 (read-int #<input-output: file 10>)
>
> ./guix/serialization.scm:80:6: In procedure read-int:
> ERROR:
> 1. &nar-error:
> file: #f
> port: #<input-output: file 10>
> guix pull: error: You found a bug: the program '/gnu/store/lfjklynfh3kwsx0iwfwcm71y4qf36ww3-compute-guix-derivation'
> failed to compute the derivation for Guix (version: "4dff6ecde85eec473ab231cf75f51e98e8aca1e9"; system: "x86_64-linux";
> host version: "7327295462fccae4ee3e9bf74962c82d3445fec8"; pull-version: 1).
> Please report it by email to <bug-guix@gnu.org>.

Apparently, what happens is that ‘guix substitute’ (invoked by the
daemon) crashes.

Could you say which version of the daemon you’re running? Try
“ps aux | grep guix-daemon” and report the store file name. That will
allow us to map line numbers to actual source.

Thanks for the detailed report!

Ludo’.
L
L
Ludovic Courtès wrote on 18 Apr 2021 12:28
control message for bug #47764
(address . control@debbugs.gnu.org)
87mttvlwdv.fsf@gnu.org
retitle 47764 'guix substitute' crashes while running 'guix pull'
quit
L
L
Ludovic Courtès wrote on 18 Apr 2021 22:17
Re: bug#47764: guix pull bug
(name . Zelphir Kaltstahl)(address . zelphirkaltstahl@posteo.de)(address . 47764@debbugs.gnu.org)
87tuo3ibyh.fsf@gnu.org
Hi,

Zelphir Kaltstahl <zelphirkaltstahl@posteo.de> skribis:

Toggle quote (8 lines)
> This is what is output:
>
> ~~~~
> $ ps aux | grep guix-daemon
> root 875 0.0 0.0 11896 4324 ? Ss 12:53 0:00 guix-daemon --build-users-group=guixbuild
> user 4494 0.0 0.0 12452 2804 pts/0 S+ 13:21 0:00 grep --color=auto guix-daemon
> ~~~~

What about ‘ls -l /proc/875/exe’?

TIA,
Ludo’.
M
M
Maxime Devos wrote on 1 Sep 2022 19:07
Re: bug#57527: compute-guix-derivation has an error
59cb7f24-d9c8-5394-cdbd-605d5addd03a@telenet.be
severity 57527 important
merge 47764 57527
severity 53802 important
merge 47764 53802
severity 56466 important
merge 47764 56466
thanks
Found a few apparent duplicates (they are all about a &nar-error,
read-int and process-stderror).
On second thought, I don't think the patch I referred to #56466 will
help here, though it could hardly harm here.
For now, you can try working-around by retrying "guix pull".
There are two hypotheses on the cause in
The second seems most plausible to me, and the first seems the simplest
to test (and even if it's not the cause, it would still add some
robustness).
Greetings,
Maxime.
Attachment: file
Attachment: OpenPGP_signature
?