* gnu/packages/databases.scm (postgresql)[arguments]: Add configure flag
'--mandir'. Add phase 'install-man'.
---
gnu/packages/databases.scm | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)
Toggle diff (53 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7cff0f99c5..76e99283ed 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1118,12 +1119,14 @@ (define-public postgresql-13
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl"
- ;; PostgreSQL installs its own Makefile (should it?).
- ;; Prevent it from retaining needless references to
- ;; the build tools in order to save size.
- "MKDIR_P=mkdir -p" "INSTALL_BIN=install -c"
- "LD=ld" "TAR=tar")
+ `(#:configure-flags
+ (list "--with-uuid=e2fs" "--with-openssl"
+ (string-append "--mandir=" (assoc-ref %outputs "out") "/share/man")
+ ;; PostgreSQL installs its own Makefile (should it?).
+ ;; Prevent it from retaining needless references to
+ ;; the build tools in order to save size.
+ "MKDIR_P=mkdir -p" "INSTALL_BIN=install -c"
+ "LD=ld" "TAR=tar")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -1138,7 +1141,10 @@ (define-public postgresql-13
(invoke "make" "-C" "contrib")))
(add-after 'install 'install-contrib
(lambda _
- (invoke "make" "-C" "contrib" "install"))))))
+ (invoke "make" "-C" "contrib" "install")))
+ (add-after 'install 'install-man
+ (lambda _
+ (invoke "make" "-C" "doc/src/sgml" "install-man"))))))
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux "lib")
base-commit: 604880ae22e1a7662acb1d3f282242470de0cd03
prerequisite-patch-id: ecd20aaded80566551ed0bd654517209ad239de5
prerequisite-patch-id: 96a62566ab07f5d80f2edd43cd0f89c7191e7ee6
prerequisite-patch-id: 5f8c05b16a80862bfc759169d05d1b03d48284a6
prerequisite-patch-id: 4a455af71d83d984fe88b3cdbc1f8f477b27f2a9
--
2.34.0