[PATCH 3/3] gnu: Add ssh-chat.

  • Open
  • quality assurance status badge
Details
2 participants
  • Stefan Reichör
  • zimoun
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
Merged with
S
S
Stefan Reichör wrote on 10 Feb 2021 22:54
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210210215404.209053-3-stefan@xsteve.at
* gnu/packages/ssh.scm (ssh-chat): New variable.
---
gnu/packages/ssh.scm | 47 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 46 insertions(+), 1 deletion(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 04c8c6ceaa..9e146ea03a 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2017, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2018 Manuel Graf <graf@init.at>
@@ -41,6 +41,7 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages elf)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages groff)
#:use-module (gnu packages guile)
@@ -62,11 +63,13 @@
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -915,3 +918,45 @@ Ed25519 keys.
@item Modern browsers are supported.
@end itemize")
(license license:expat)))
+
+(define-public ssh-chat
+ (package
+ (name "ssh-chat")
+ (version "1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shazow/ssh-chat")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15avqg9j7yx0cx1dvz46r0ipgqnq5i9lfv9rwy2fjqsy501qx03v"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("go-github-com-alexcesaro-log" ,go-github-com-alexcesaro-log)
+ ("go-github-com-shazow-rateio" ,go-github-com-shazow-rateio)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)
+ ("go-github.com-howeyc-gopass" ,go-github.com-howeyc-gopass)
+ ("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)))
+ (arguments
+ `(#:install-source? #f
+ #:import-path "github.com/shazow/ssh-chat"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (with-directory-excursion "src/github.com/shazow/ssh-chat"
+ (invoke "make" "build")
+ #t)))
+ (replace 'install
+ (lambda* (#:key outputs import-path #:allow-other-keys)
+ (let ((dest (string-append (assoc-ref outputs "out") "/bin"))
+ (source (string-append "src/" import-path "/")))
+ (install-file (string-append source "ssh-chat") dest)
+ #t))))))
+ (synopsis "Chat over SSH.")
+ (description "Custom SSH server written in Go. Instead of a shell, you get a chat prompt.")
+ (home-page "https://github.com/shazow/ssh-chat")
+ (license license:expat)))
--
2.25.1
Z
Z
zimoun wrote on 20 Sep 2021 13:47
control message for bug #46432
(address . control@debbugs.gnu.org)
87y27rfozo.fsf@gmail.com
merge 46432 46431
quit
Z
Z
zimoun wrote on 20 Sep 2021 13:47
control message for bug #46430
(address . control@debbugs.gnu.org)
87wnnbfoz8.fsf@gmail.com
merge 46430 46431
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 46432@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46432
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch