[PATCH 1/3] gnu: Add go-github-com-alexcesaro-log.

  • Open
  • quality assurance status badge
Details
2 participants
  • Stefan Reichör
  • zimoun
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
Merged with
S
S
Stefan Reichör wrote on 10 Feb 2021 22:54
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210210215404.209053-1-stefan@xsteve.at
* gnu/packages/golang.scm (go-github-com-alexcesaro-log): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d34bb1acb7..7c0d373a8b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1901,6 +1902,30 @@ applications as well as a program to generate applications and command files.")
(description "Go logging library")
(license license:expat)))
+(define-public go-github-com-alexcesaro-log
+ (let ((commit "61e686294e58a8698a9e1091268bb4ac1116bd5e")
+ (revision "0"))
+ (package
+ (name "go-github-com-alexcesaro-log")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alexcesaro/log")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ckd5crq9rd12wpclahg2q0wprfg0whd6k9zbfzzkr6l1qpmmfam"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/alexcesaro/log"))
+ (home-page "https://github.com/alexcesaro/log")
+ (synopsis "Several logging packages for Go")
+ (description "Several logging packages for Go")
+ (license license:expat))))
+
(define-public go-github-com-spf13-pflag
(package
(name "go-github-com-spf13-pflag")
--
2.25.1
Z
Z
zimoun wrote on 20 Sep 2021 13:47
control message for bug #46430
(address . control@debbugs.gnu.org)
87wnnbfoz8.fsf@gmail.com
merge 46430 46431
quit
?