[PATCH] Add new - EyE

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Maxime Devos
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qq7u2QekGgRL1s5Xetw-5XT4p19WYMyV-5cTU7xk0+4A@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 95776d9dbddf48be560c33df79945f7510787c0b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 25 Jan 2021 17:43:03 +0000
Subject: [PATCH] gnu: Add eye

* gnu/packages/astronomy.scm (eye): New variable
---
gnu/packages/astronomy.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0e1a55481f..8eb74b44ae 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -88,6 +88,29 @@ in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public eye
+ (package
+ (name "eye")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.astromatic.net/download/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "092qhzcbrkcfidbx4bv9wz42w297n80jk7a6kwyi9a3fjfz81d7k"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.astromatic.net/software/eye")
+ (synopsis "Small image feature detector using machine learning")
+ (description
+ "In EyE (Enhance Your Extraction) an artificial neural network connected to
+pixels of a moving window (retina) is trained to associate these input stimuli
+to the corresponding response in one or several output image(s). The resulting
+filter can be loaded in SExtractor to operate complex, wildly non-linear filters
+on astronomical images. Typical applications of EyE include adaptive filtering,
+feature detection and cosmetic corrections.")
+ (license license:gpl3+)))
+
(define-public wcslib
(package
(name "wcslib")
--
2.30.0
Maxime Devos wrote 4 years ago
20d13a9971e03750f25aac32951ce554790ac980.camel@telenet.be
Hi Sharlatan,

Is there any particular reason a http://URL is used
instead of a https://?I believe the latter is preferred.
Also, you can add a copyright line for yourself at the top
of the file. Otherwise, the package definition LGTM.

Greetings,
Maxime
--
Maxime Devos <maximedevos@telenet.be>
PGP Key: C1F3 3EE2 0C52 8FDB 7DD7 011F 49E3 EE22 1917 25EE
Freenode handle: mdevos
-----BEGIN PGP SIGNATURE-----

iI0EABYIADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYA/J8RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7i1gAP9CV4qhRmJiGadUTbVvZcp34sI4
xgG2ATadGa7TrCPGQAEAlzTcspDgAckp6dOzoNxofqjClaTgaLt1LVkj6vL1HAI=
=DSZZ
-----END PGP SIGNATURE-----


Guillaume Le Vaillant wrote 4 years ago
(address . 46103-done@debbugs.gnu.org)
87czxsjc5i.fsf@yamatai
I changed the URLs to use https, fixed the license field and pushed the
patch as 51418c32d95d8188d8877616829f26479f1135c6.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYA/cuQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9mcAD/SRtnATn+Ne8GbZGEkqenDeqU1GsIxryWETcS
DjKyY/IA/jDdMVzTsM9BukxhO9ERCRA3OyxXTfziEk4UyG1osqjD
=/93W
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46103@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46103
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help