John Doe wrote 4 years ago
(address . guix-patches@gnu.org)(name . John Doe)(address . dftxbs3e@free.fr)
* gnu/packages/freedesktop.scm (udisks):
[inputs]: Add dosfstools.
[arguments]: Modify 'wrap-udisksd phase to add dosfstools in PATH with
wrapper.
---
gnu/packages/freedesktop.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (31 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3c4ad57a15..1104a07955 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1112,6 +1112,7 @@ Analysis and Reporting Technology) functionality.")
(inputs
`(("acl" ,acl)
("cryptsetup" ,cryptsetup)
+ ("dosfstools" ,dosfstools)
("libatasmart" ,libatasmart)
("libblockdev" ,libblockdev)
("libgudev" ,libgudev)
@@ -1163,6 +1164,7 @@ Analysis and Reporting Technology) functionality.")
(let ((out (assoc-ref outputs "out"))
(utils (assoc-ref inputs "util-linux"))
(cryptsetup (assoc-ref inputs "cryptsetup"))
+ (dosfstools (assoc-ref inputs "dosfstools"))
(parted (assoc-ref inputs "parted")))
(wrap-program (string-append out "/libexec/udisks2/udisksd")
`("PATH" ":" prefix
@@ -1170,6 +1172,8 @@ Analysis and Reporting Technology) functionality.")
;; cryptsetup is required for setting encrypted
;; partitions, e.g. in gnome-disks
,(string-append cryptsetup "/sbin")
+ ;; Required to format FAT file systems in gnome-disks
+ ,(string-append dosfstools "/sbin")
"/run/current-system/profile/bin"
"/run/current-system/profile/sbin")))
#t))))))
--
2.29.2