[PATCH] gnu: udisks: Add dosfstools to PATH with wrapper.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Doe
  • Maxim Cournoyer
Owner
unassigned
Submitted by
John Doe
Severity
normal

Debbugs page

John Doe wrote 4 years ago
(address . guix-patches@gnu.org)(name . John Doe)(address . dftxbs3e@free.fr)
20201222222127.2659-1-dftxbs3e@free.fr
* gnu/packages/freedesktop.scm (udisks):
[inputs]: Add dosfstools.
[arguments]: Modify 'wrap-udisksd phase to add dosfstools in PATH with
wrapper.
---
gnu/packages/freedesktop.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3c4ad57a15..1104a07955 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1112,6 +1112,7 @@ Analysis and Reporting Technology) functionality.")
(inputs
`(("acl" ,acl)
("cryptsetup" ,cryptsetup)
+ ("dosfstools" ,dosfstools)
("libatasmart" ,libatasmart)
("libblockdev" ,libblockdev)
("libgudev" ,libgudev)
@@ -1163,6 +1164,7 @@ Analysis and Reporting Technology) functionality.")
(let ((out (assoc-ref outputs "out"))
(utils (assoc-ref inputs "util-linux"))
(cryptsetup (assoc-ref inputs "cryptsetup"))
+ (dosfstools (assoc-ref inputs "dosfstools"))
(parted (assoc-ref inputs "parted")))
(wrap-program (string-append out "/libexec/udisks2/udisksd")
`("PATH" ":" prefix
@@ -1170,6 +1172,8 @@ Analysis and Reporting Technology) functionality.")
;; cryptsetup is required for setting encrypted
;; partitions, e.g. in gnome-disks
,(string-append cryptsetup "/sbin")
+ ;; Required to format FAT file systems in gnome-disks
+ ,(string-append dosfstools "/sbin")
"/run/current-system/profile/bin"
"/run/current-system/profile/sbin")))
#t))))))
--
2.29.2
dftxbs3e wrote 4 years ago
(address . 45374@debbugs.gnu.org)
a275d3e7369e3129ec0524cb69b7b9aea3d35499.camel@free.fr
Looks like there has already been some discussion about this:

So what do we do?

Patch libblockdev to use full paths or give it to udisksd's
environment?
-----BEGIN PGP SIGNATURE-----

iHUEABYIAB0WIQQozTys6hLca3Ekt8u3HhLxn6GoewUCX+J2zQAKCRC3HhLxn6Go
e2uZAP9dSOoNdS9P9gy52hIYBsvYxGKeaHzHC9mw+0TpjwxQ5wEAzmLnComUE1vj
wD0z34HjAVxN0VCOq9gG2utCPoKO1w4=
=LdpI
-----END PGP SIGNATURE-----


Maxim Cournoyer wrote 9 months ago
Re: [bug#45374] [PATCH] gnu: udisks: Add dosfstools to PATH with wrapper.
(name . dftxbs3e)(address . dftxbs3e@free.fr)(address . 45374-done@debbugs.gnu.org)
87frtukdvb.fsf@gmail.com
Hi,

dftxbs3e <dftxbs3e@free.fr> writes:

Toggle quote (8 lines)
> Looks like there has already been some discussion about this:
> https://issues.guix.gnu.org/41247
>
> So what do we do?
>
> Patch libblockdev to use full paths or give it to udisksd's
> environment?

I think patching libblockdev is the better solution. I'm applying
Sarah's patches which added dosfstools as an input and did the patching,
so we should be covered.

Closing.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45374@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45374
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help