• Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 12 Dec 2020 01:40
(address . guix-patches@gnu.org)
CAO+9K5r+VMBp4LUmrVWZvZGZhijz2jbbHC4Jy4Po53i3OisqMw@mail.gmail.com
Hi, Guillaume

Thanks you for your point about multiple systems within one source repository.

If I include them with `#:asdf-systems` how I would refer to them in
`(inputs...)` part of the package which has it as a dependency?

Please check one more patch from the list for *command-line-arguments*


- [-] pgloader [24/34] [70%]
1. [X] abnf [100%]
- [X] :packed <2020-12-05 Sat>
- [X] :patch-sent <2020-12-07 Mon>
- [X] :patch-applied-upstream <2020-12-11 Fri>
- [X] :depends-on [2/2]
+ [X] esrap
+ [X] cl-ppcre
2. [X] alexandria
3. [X] cl-base64
4. [X] cl-csv
5. [X] cl-fad
6. [X] cl-log [100%]
- [X] :packed <2020-12-02 Wed>
- [X] :patch-sent <2020-12-02 Wed>
- [X] :patch-applied-upstream <2020-12-05 Sat>
7. [ ] cl-markdown [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on [0/0]
8. [ ] cl-mustache [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on [0/0]
9. [X] closer-mop
10. [-] cl-postgres [0%] - part of Postmodern
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [-] :depends-on [3/4]
- [X] md5
- [X] split-sequence
- [X] cl-base64
- [-] uax-15 [25%]
+ [ ] :packed
+ [ ] :patch-sent
+ [ ] :patch-applied-upstream
+ [X] :depends-on [3/3]
- [X] split-sequence
- [X] cl-ppcre
- [X] uiop - part of ASDF
11. [X] cl-ppcre
12. [-] command-line-arguments [66%]
- [X] :packed <2020-12-12 Sat>
- [X] :patch-sent <2020-12-12 Sat>
- [ ] :patch-applied-upstream
13. [ ] db3 [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
14. [X] drakma
15. [X] esrap
16. [X] flexi-streams
17. [ ] ixf [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
18. [X] local-time
19. [X] lparallel
20. [X] metabang-bind
21. [ ] mssql [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
22. [X] postmodern
23. [ ] py-configparser [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on [0/1]
+ [ ] parse-number
24. [-] qmynd [20%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [-] :depends-on [5/6]
- [X] babel
- [X] flexi-streams
- [X] ironclad
- [ ] list-of - part of asdf-finalizers
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on [0/1]
- [ ] asdf-finalizers
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [X] trivial-gray-streams
- [X] usocket
- [X] :weakly-depends-on [3/3]
- [X] chipz
- [X] cl+ssl
- [X] salza2
25. [X] quri
26. [ ] simple-date [0%] - part of Postmodern
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
27. [X] split-sequence
28. [X] sqlite
29. [X] trivial-backtrace
30. [X] uiop
31. [X] usocket
32. [X] uuid
33. [X] yason
34. [X] zs3 [100%]
- [X] :packed <2020-12-03 Thu>
- [X] :patch-sent <2020-12-03 Thu>
- [X] :patch-applied-upstream <2020-12-05 Sat>
- [X] :depends-on [6/6]
+ [X] drakma
+ [X] alexandria
+ [X] cxml
+ [X] ironclad
+ [X] puri
+ [X] cl-base64


--

… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From ce06f2a6f0509568a1c9aef345526996949e1fc0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=23R=CE=BBatan?= <sharlatanus@gmail.com>
Date: Sat, 12 Dec 2020 00:21:24 +0000
Subject: [PATCH] gnu/packages/lisp-xyz.scm

Add new variables: sbcl-command-line-arguments cl-command-line-arguments ecl-command-line-arguments
---
gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f77e949fea..d596811aab 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -144,6 +144,35 @@ In order to make one or several variables file-local, use the macros
(define-public ecl-net.didierverna.asdf-flv
(sbcl-package->ecl-package sbcl-net.didierverna.asdf-flv))
+(define-public sbcl-command-line-arguments
+ (let ((commit "fbac862fb01c0e368141204f3f639920462c23fe")
+ (revision "1"))
+ (package
+ (name "sbcl-command-line-arguments")
+ (version (git-version "2.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fare/command-line-arguments")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "054m1ikndzqf72mb9ajaa64136cwr3bgag4yfbi1574a9vq75mjq"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/fare/command-line-arguments")
+ (synopsis "Trivial command-line argument parsing library for Common Lisp")
+ (description "A library to abstract away the parsing of Unix-style
+command-line arguments. Use it in conjunction with asdf:program-op or cl-launch
+for portable processing of command-line arguments.")
+ (license license:expat))))
+
+(define-public ecl-command-line-arguments
+ (sbcl-package->ecl-package sbcl-command-line-arguments))
+
+(define-public cl-command-line-arguments
+ (sbcl-package->cl-source-package sbcl-command-line-arguments))
+
(define-public sbcl-fiveam
(package
(name "sbcl-fiveam")
--
2.26.2
G
G
Guillaume Le Vaillant wrote on 13 Dec 2020 10:10
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 45189-done@debbugs.gnu.org)
87v9d68418.fsf@yamatai
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (9 lines)
> Hi, Guillaume
>
> Thanks you for your point about multiple systems within one source repository.
>
> If I include them with `#:asdf-systems` how I would refer to them in
> `(inputs...)` part of the package which has it as a dependency?
>
> Please check one more patch from the list for *command-line-arguments*

command-line-arguments pushed as f42e54dfaaece18a5065ddd328750d8b316605f3.
Thanks.

When you have a package-1 containing several systems (declared with
'#:asd-systems'), and a package-2 depending on at least one of the
systems in package-1, just put package-1 as input in the definition of
package-2 and asdf-build-system will find what it needs to compile
package-2:

(define-public sbcl-package-2
(package
...
(inputs
`(("package-1" ,sbcl-package-1)
...))
...))
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX9Xakw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/z/QD9Gsdn5sRrdLb8FNxXp0eh3aLyT5k/9lUyrMeZ
d9GLR5AA/23hJ0EKWbUTaoZtAEufR/uRopOqcZY08sWK7S7q5DSx
=ftAq
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45189@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45189
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch