Add cl-abnf

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 7 Dec 2020 22:37
(address . guix-patches@gnu.org)
CAO+9K5oBMbQ3UKhV1tJP6zWygQ7+HCqqiY=QCqbP_acD_Ciu6A@mail.gmail.com
Hi,

Thank you for approving my previous patches.

One more package for pgloader.
Could anyone help me to find the best way to pack systems in pgloader and
Postmodern repositories (check the list). I also have difficulties to find
"list-of" and " command-line-arguments" Common Lisp systems.


- [-] pgloader [23/34] [67%]
1. [-] abnf [75%]
- [X] :packed <2020-12-05 Sat>
- [X] :patch-sent <2020-12-07 Mon>
- [ ] :patch-applied-upstream
- [X] :depends-on [2/2]
+ [X] esrap
+ [X] cl-ppcre
2. [X] alexandria
3. [X] cl-base64
4. [X] cl-csv
5. [X] cl-fad
6. [X] cl-log [100%]
- [X] :packed <2020-12-02 Wed>
- [X] :patch-sent <2020-12-02 Wed>
- [X] :patch-applied-upstream <2020-12-05 Sat>
7. [ ] cl-markdown [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on []
8. [ ] cl-mustache [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
9. [X] closer-mop
10. [-] cl-postgres [0%] - part of Postmodern
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [-] :depends-on [3/4]
- [X] md5
- [X] split-sequence
- [X] cl-base64
- [-] uax-15 [25%]
+ [ ] :packed
+ [ ] :patch-sent
+ [ ] :patch-applied-upstream
+ [X] :depends-on [3/3]
- [X] split-sequence
- [X] cl-ppcre
- [X] uiop - part of ASDF
11. [X] cl-ppcre
12. [ ] command-line-arguments [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
13. [ ] db3 [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
14. [X] drakma
15. [X] esrap
16. [X] flexi-streams
17. [ ] ixf [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
18. [X] local-time
19. [X] lparallel
20. [X] metabang-bind
21. [ ] mssql [0%] - part of pgloader
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
22. [X] postmodern
23. [ ] py-configparser [0%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [ ] :depends-on [0/1]
+ [ ] parse-number
24. [-] qmynd [20%]
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
- [-] :depends-on [5/6]
- [X] babel
- [X] flexi-streams
- [X] ironclad
- [ ] list-of - (Hellseher-201205210440) I'm not sure where to find
it
- [X] trivial-gray-streams
- [X] usocket
- [X] :weakly-depends-on [3/3]
- [X] chipz
- [X] cl+ssl
- [X] salza2
25. [X] quri
26. [ ] simple-date [0%] - part of Postmodern
- [ ] :packed
- [ ] :patch-sent
- [ ] :patch-applied-upstream
27. [X] split-sequence
28. [X] sqlite
29. [X] trivial-backtrace
30. [X] uiop
31. [X] usocket
32. [X] uuid
33. [X] yason
34. [X] zs3 [100%]
- [X] :packed <2020-12-03 Thu>
- [X] :patch-sent <2020-12-03 Thu>
- [X] :patch-applied-upstream <2020-12-05 Sat>
- [X] :depends-on [6/6]
+ [X] drakma
+ [X] alexandria
+ [X] cxml
+ [X] ironclad
+ [X] puri
+ [X] cl-base64
---
… ??? ????? - ???????????? ?????????????? ?????? ??????? ???????? ?????
????? ????? ? ??? ??????, ??????????? ????? ???????, ?? ?????????? ?? ?
????????? ??????? ????? ? ?????????????????.
Attachment: file
From ddd02e564b7fbf845433964cf620c6ff05a3d780 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=23R=CE=BBatan?= <sharlatanus@gmail.com>
Date: Mon, 7 Dec 2020 21:22:50 +0000
Subject: [PATCH] gnu/packages/lisp-xyz.scm cl-abnf Add cl-abnf

---
gnu/packages/lisp-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6fd4ec5b2d..9ad5f20053 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -309,6 +309,45 @@ streams which are similar to string streams.")
(define-public ecl-flexi-streams
(sbcl-package->ecl-package sbcl-flexi-streams))
+(define-public sbcl-cl-abnf
+ ;; There are no releases
+ (let ((commit "ba1fbb104dedbdaddb1ef93d2e4da711bd96cd70")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-abnf")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimitri/cl-abnf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f09nsndxa90acm71zd4qdnp40v705a4sqm04mnv9x76h6dlggmz"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("esrap" ,sbcl-esrap)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (arguments
+ `(#:asd-systems '("abnf")))
+ (home-page "https://github.com/dimitri/cl-abnf")
+ (synopsis "ABNF Parser Generator, per RFC2234")
+ (description "This Common Lisp librairie implements a parser generator for
+the ABNF grammar format as described in RFC2234. The generated parser is a
+regular expression scanner provided by the cl-ppcre lib, which means that we
+can't parse recursive grammar definition. One such definition is the ABNF
+definition as given by the RFC. Fortunately, as you have this lib, you most
+probably don't need to generate another parser to handle that particular ABNF
+grammar.")
+ (license license:expat))))
+
+(define-public ecl-cl-abnf
+ (sbcl-package->ecl-package sbcl-cl-abnf))
+
+(define-public cl-abnf
+ (sbcl-package->cl-source-package sbcl-cl-abnf))
+
(define-public sbcl-cl-ppcre
(package
(name "sbcl-cl-ppcre")
--
2.26.2
G
G
Guillaume Le Vaillant wrote on 11 Dec 2020 19:40
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 45107-done@debbugs.gnu.org)
87o8j0424n.fsf@yamatai
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (9 lines)
> Hi,
>
> Thank you for approving my previous patches.
>
> One more package for pgloader.
> Could anyone help me to find the best way to pack systems in pgloader and
> Postmodern repositories (check the list). I also have difficulties to find
> "list-of" and " command-line-arguments" Common Lisp systems.

Pushed as 2ae3033449a6ee803fc3ead77c5f26967e9dc34c with some
modifications. Thanks.

When there are several Common Lisp systems in one repository, you can
use the 'asd-systems' keyword in the arguments of the package definition
to list them and they will all be compiled. You can take a look at the
package definition for sbcl-cffi to get an example.

I checked the source code of Quicklisp: it takes the "list-of"
"command-line-arguments" system from

Hope that helps.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX9O9OA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9CdwD/ZIJuF+MK5wsC2cXIXLl6rr3BgMNo8wjQfm+x
hYqSLl4A/1FoFJ259rYV7IhmHPXdlmF8TtgVnTuRQS4H4DUIvmW0
=IAHy
-----END PGP SIGNATURE-----

Closed
?