fiano-fmap test failure

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Jack Hill
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
Merged with
J
J
Jack Hill wrote on 11 Dec 2020 07:10
(address . bug-guix@gnu.org)
alpine.DEB.2.21.2012110108440.5691@marsh.hcoop.net
Hi Guix,

fiano-fmap fails to build with a test failure. I'm using guix
937bc5841429f40a64e6b25d5d4c2fe3276789f1. The log from the check phase is:

"""
starting phase `check'
# github.com/linuxboot/fiano/cmds/fmap
package github.com/linuxboot/fiano/cmds/fmap (test)
imports github.com/u-root/u-root/pkg/testutil: cannot find package "github.com/u-root/u-root/pkg/testutil" in any of:
/tmp/guix-build-fiano-fmap-5.0.0.drv-0/src/github.com/linuxboot/fiano/vendor/github.com/u-root/u-root/pkg/testutil (vendor tree)
/gnu/store/cb9kqjg7m6xk1wz7ap8as792fd5kcmd2-go-1.14.10/src/github.com/u-root/u-root/pkg/testutil (from $GOROOT)
/tmp/guix-build-fiano-fmap-5.0.0.drv-0/src/github.com/u-root/u-root/pkg/testutil (from $GOPATH)
FAIL github.com/linuxboot/fiano/cmds/fmap [setup failed]
FAIL
command "go" "test" "github.com/linuxboot/fiano/cmds/fmap" failed with status 1

Some deprecated features have been used. Set the environment
variable GUILE_WARN_DEPRECATED to "detailed" and rerun the
program to get more information. Set it to "no" to suppress
this message.
builder for `/gnu/store/zqd7flscj1x4922vhp6y5nnkgsgs5zsm-fiano-fmap-5.0.0.drv' failed with exit code 1
"""

Best,
Jack
D
D
Danny Milosavljevic wrote on 11 Dec 2020 22:35
20201211223543.7d6664b7@scratchpost.org
Hello,

I confirm the test failure.

I tried fixing it with the patch below, but there's still something up with it.
I don't know the go build system enough to be able to tell what's up--can
someone else help?

Toggle diff (68 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e595ad3702..2b46928512 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -85,6 +85,7 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages elf)
#:use-module (gnu packages file)
+ #:use-module (gnu packages firmware)
#:use-module (gnu packages flex)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -4246,7 +4247,8 @@ disk utilization, priority, username, state, and exit code.")
`())
(inputs
`(("go-golang-org-x-text" ,go-golang-org-x-text)
- ("go-github.com-ulikunitz-xz" ,go-github.com-ulikunitz-xz)))
+ ("go-github.com-ulikunitz-xz" ,go-github.com-ulikunitz-xz)
+ ("go-github.com-u-root-u-root" ,u-root))) ; does not work for some reason
(synopsis "UEFI image editor")
(description "This package provides a command-line UEFI image editor.")
(home-page "https://github.com/linuxboot/fiano")
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index fcdb5a801e..992ff812c2 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -30,6 +30,7 @@
#:use-module (guix utils)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages assembly)
@@ -621,3 +622,33 @@ switching support).\n")
#t)))))
(native-inputs `(("cross-gcc" ,(cross-gcc "arm-none-eabi" #:xgcc gcc-7))
("cross-binutils" ,(cross-binutils "arm-none-eabi"))))))
+
+;; TODO: busybox mode.
+;; TODO: Unvendor things: gopkg.in (yaml.v2), gopkg.in (alecthomas/kingpin.v2), golang.org (x-text, x-tools, x-xerrors, x/mod/semver, x/mod/module, x/net/ipv4, x/net/ipv6, x/crypto, x/sys/unix, x/sys/windows, x/sys/cpu), github.com (gliderlabs/ssh, beevik/ntp, intel-go/cpuid, stretchr/testify, u-root/iscsinl, google/go-tpm, goexpect, goterm, go-cmp, safchain, rck, mattn/go-isatty, creack/pty, ...)
+(define-public u-root
+ (package
+ (name "u-root")
+ (version "7.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/u-root/u-root.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1awpbzmfmzyzwyjk917dvmmz2ssz15fj4raqhv7dhg9k6vy00px1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f
+ #:import-path "github.com/u-root/u-root"
+ #:unpack-path "github.com/u-root/u-root"))
+ (native-inputs
+ `())
+ (inputs
+ `())
+ (synopsis "Minimal initrd with system tools")
+ (description "Go-based embedded initrd with system tools
+(it's like busybox, just in Go).")
+ (home-page "https://u-root.org/")
+ (license license:bsd-3)))
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl/T5i8ACgkQ5xo1VCww
uqW2RQf/Tob4CiZjspxjjgVb+gBHIBQapRV2tCZJj77mbWov2JKPsJk7QciU2lhq
TVld+z3evSq/XPvUtQJfsWz9v4IXc+0MnHreuQLnHWnfNU7ae+4nJZsOQrID7NvA
Zl+2Nro8fmBEZlropsNg7UCyiBT3FAY/Tul7u4gebRVlm5ZTfdTz9AEUi/LrPhFb
N8TDbRNxK0aTAVBNkwwqHQU0BD0+rRaivGN6FzIGwpajNYMOtAcYA00ktvYwRETp
tI4OqzL3DOJpZ6mt8r6eWfWevH39OqJa6Ua0xbTC4YQJkpwg+e4ezPYNspRodUdu
/SL+LwPlpDpV4PyaqBQrGSMC7RTCWQ==
=9KoT
-----END PGP SIGNATURE-----


J
J
Jack Hill wrote on 31 Mar 2021 16:42
fiano-fmap test failure
(address . control@debbugs.gnu.org)
alpine.DEB.2.21.2103311042000.8138@marsh.hcoop.net
reassign 47506 guix
merge 47506 45172
thanks
S
S
Sharlatan Hellseher wrote on 4 Apr 18:45 +0200
(address . 45172-done@debbugs.gnu.org)
874jchqdpq.fsf@gmail.com
Hi,

Closing this issue as resolved in https://issues.guix.gnu.org/70123.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYO2REACgkQdtcnv/Ys
0rXoIA//e7Tj4VbEJYmFeqrLMVlpTYVnVos3L/yViaqyq8s/vf1zJHFFaItIzTlP
hdpvYGffhJcu/A+eFONg/sUYgTbfxgG37Cm88Sal/hri06Qs8cw17IVsJfP3osTx
JtlVSyIvOSjT3/ozHh5vqmYxoPRNJvjHvWF9gzOWw/REFwUM8oqzdteDOdiuXahD
6CgvA8p5yFxWYKw1FbO8IMIPHPgzc88Mx/BxFkabo0nhd/dIEq771Okrook60mlY
40hxhSAWxfbi/ipMR7j0PwCQ18OuChTjhGKhSiqOhB8jDTmipQXpbTSRzmTBk8jX
LaKZZg3T8wFpSbJ15qr4stPD1WXcE3cDVgG9z4S5HgPTpZClND8bzCKRBTcSpjFV
WP8skPGcFYlxXyUmPobHz1ityNs0aAEL7ZugBBKcMZCSAJ7fC/PjNW4ng/AfuVnY
AAvkRKzqKTWRjdOBNGHIKK55BD9tW06HVONebQh/c0lvRCtmgXzpgLM3dXxaaHFo
kWcGh+OZnvGBWH8Hv111QF+jhgLnXWL0HjtK0wyUIUnghOzMFekxPosWvfilX49c
0osHTOlPzhuSTQSY89l962s763IHCK6z6WUDjHMr3NTNGGAX6hgcS8RwEeo8Nfap
OBsTvdeutboHp58BzQc2ArFH49qarbpbcfx4jGGp3ucMamB5kwc=
=fNhu
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45172@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45172
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch