[PATCH] gnu: packages: Add tiny-bignum.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Christopher Baines
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 1 Dec 2020 02:44
(address . guix-patches@gnu.org)
20201201014454.18663-1-rprior@protonmail.com
* gnu/packages/maths.scm (tiny-bignum): New variable.
---
gnu/packages/maths.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d3f3539e26..a0dd9a761c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4984,6 +4984,52 @@ be fed to @command{tcalc} through the command line.")
(home-page "https://sites.google.com/site/mohammedisam2000/tcalc")
(license license:gpl3+)))
+(define-public tiny-bignum
+ (let ((commit "1d7a1f9b8e77316187a6b3eae8e68d60a6f9a4d4"))
+ (package
+ (name "tiny-bignum")
+ (version (git-version "0" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kokke/tiny-bignum-c")
+ (commit commit)))
+ (file-name (git-file-name "tiny-bignum" commit))
+ (sha256
+ (base32 "0vj71qlhlaa7d92bfar1kwqv6582dqrby8x3kdw0yzh82k2023g6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda _
+ (substitute* "scripts/test_rand.py"
+ (("\t") " ")
+ (("\" % (\\w+)" _ symbol) (string-append "\" % int(" symbol ")")))
+ (invoke "make" "test")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out") "/share"))
+ (doc (string-append (assoc-ref outputs "out") "/doc")))
+ (mkdir-p share)
+ (install-file "bn.c" share)
+ (install-file "bn.h" share)
+ (mkdir-p doc)
+ (install-file "LICENSE" doc)
+ (install-file "README.md" doc)))))))
+ (native-inputs
+ `(("python" ,python-wrapper)))
+ (home-page "https://github.com/kokke/tiny-bignum-c")
+ (synopsis "Small portable multiple-precision unsigned integer arithmetic in C")
+ (description
+ "This library provides portable Arbitrary-precision unsigned integer
+arithmetic in C, for calculating with large numbers. Basic arithmetic (+, -,
+*, /, %) and bitwise operations (&, |, ^. <<, >>) plus increments, decrements
+and comparisons are supported.")
+ (license license:unlicense))))
+
(define-public sundials
(package
(name "sundials")
--
2.29.2
R
R
Ryan Prior wrote on 1 Dec 2020 05:10
[PATCH] gnu: Add cjson.
(address . 44978@debbugs.gnu.org)
20201201041027.6129-1-rprior@protonmail.com
* gnu/packages/web.scm (cjson): New variable.
---
gnu/packages/web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f559d63f1b..21fc1ae964 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -957,6 +957,26 @@ project)
@end itemize")
(license license:bsd-2)))
+(define-public cjson
+ (package
+ (name "cjson")
+ (version "1.7.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DaveGamble/cJSON")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rlnailhjm180zb6pc17jwphjwivw8kfpqgixjfgq4iyryq46sah"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DENABLE_CJSON_UTILS=On")))
+ (home-page "https://github.com/DaveGamble/cJSON")
+ (synopsis "JSON parser written in ANSI C")
+ (description "This library provides a portable embeddable JSON parser.")
+ (license license:expat)))
+
(define-public qjson
(package
(name "qjson")
--
2.29.2
R
R
Ryan Prior wrote on 1 Dec 2020 05:15
[PATCH 1/3] gnu: vlang: Update to 0.1.30.
(address . 44978@debbugs.gnu.org)
20201201041510.8476-1-rprior@protonmail.com
* gnu/packages/vlang.scm (vlang): Update to 0.1.30.
- Moves the cc-patching logic out of check into an explicit "patch-cc" stage.
- Adds "build-tools" stage to pre-build the included tools.
- Sets native-search-paths.
- Fixes many tests.
---
gnu/packages/vlang.scm | 89 +++++++++++++++++++++++++++++-------------
1 file changed, 61 insertions(+), 28 deletions(-)

Toggle diff (165 lines)
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index e0b2e7bcfc..655a77fadc 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -20,9 +20,12 @@
(define-module (gnu packages vlang)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages node)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages valgrind)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
#:use-module (guix git-download)
@@ -30,10 +33,21 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define markdown-origin
+ (let ((markdown-version "1ccfbcba945b649b61738b9c0455d31cf99564b2"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vlang/markdown")
+ (commit markdown-version)))
+ (file-name (git-file-name "vlang-markdown" markdown-version))
+ (sha256
+ (base32 "0s982qiwy4s9y07x9fsy4yn642schplhp9hrw2libg2bx4sw43as")))))
+
(define-public vlang
(package
(name "vlang")
- (version "0.1.29")
+ (version "0.1.30")
(source
(origin
(method git-fetch)
@@ -42,7 +56,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1rqi7cah5nq8aggrib9xvdpfjxq20li91svv0w9yny6nn1ag7snx"))))
+ (base32 "0adpjmb8ak4hsbm7iqrx4b5s1a99sc9byg5ah6c1whhsxm781k9r"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -60,54 +74,66 @@
(add-before 'build 'patch-makefile
(lambda _
(substitute* "Makefile"
- (("rm -rf") "true")
- (("v self") (string-append "v -cc " ,(cc-for-target) " cmd/v")))
- #t))
- (add-before 'check 'delete-failing-tests
- ;; XXX As always, these should eventually be fixed and run.
+ (("rm -rf") "true"))))
+ (add-before 'build 'patch-cc
+ (lambda _
+ (let* ((bin "tmp/bin")
+ (gcc (which "gcc")))
+ (mkdir-p bin)
+ (symlink gcc (string-append bin "/cc"))
+ (setenv "PATH" (string-append bin ":" (getenv "PATH"))))))
+ (add-after 'build 'build-tools
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "vmodules/markdown") "vmodules/markdown")
+ (setenv "VMODULES" (string-append (getcwd) "/vmodules"))
+ (invoke "./v" "build-tools" "-v")))
+ (add-before 'check 'fix-or-delete-failing-tests
(lambda _
+ ;; The x64 tests copy .vv files into the test directory and then
+ ;; write to them, so we need to make them writeable.
+ (for-each (lambda (vv) (chmod vv #o644))
+ (find-files "vlib/v/gen/x64/tests/" "\\.vv$"))
+ ;; The process test explicitly calls "/bin/sleep" and "/bin/date"
+ (substitute* "vlib/os/process_test.v"
+ (("/bin/sleep") (which "sleep"))
+ (("/bin/date") (which "date")))
+ ;; The valgrind test can't find `cc' even though it's on PATH, so
+ ;; we pass it as an explicit argument.
+ (substitute* "vlib/v/tests/valgrind/valgrind_test.v"
+ (("\\$vexe") "$vexe -cc gcc"))
(for-each delete-file
- '("vlib/v/gen/x64/tests/x64_test.v"
- "vlib/v/tests/repl/repl_test.v"
- "vlib/v/tests/valgrind/valgrind_test.v"
- "vlib/v/tests/valgrind/strings_and_arrays.vv"
+ '(;; XXX As always, these should eventually be fixed and run.
+ "vlib/vweb/tests/vweb_test.v"
"vlib/v/tests/live_test.v"
- "vlib/net/websocket/ws_test.v"))
- #t))
+ "vlib/v/tests/repl/repl_test.v"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
- (let* ((bin "tmp/bin")
- (gcc (which "gcc")))
- (when tests?
- (mkdir-p bin)
- (symlink gcc (string-append bin "/cc"))
- (setenv "PATH" (string-append bin ":" (getenv "PATH")))
- (invoke "./v" "test-fixed")))
- #t))
+ (when tests?
+ (invoke "./v" "test-fixed"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (tools (string-append bin "/cmd/tools"))
+ (cmd (string-append bin "/cmd"))
(thirdparty (string-append bin "/thirdparty"))
(vlib (string-append bin "/vlib"))
+ (vmodules (string-append bin "/vmodules"))
(vmod (string-append bin "/v.mod")))
(mkdir-p bin)
(copy-file "./v" (string-append bin "/v"))
;; v requires as of 0.1.27 that these other components are in the
;; same directory. In a future release we may be able to move
;; these into other output folders.
- (copy-recursively "cmd/tools" tools)
+ (copy-recursively "cmd" cmd)
(copy-recursively "thirdparty" thirdparty)
(copy-recursively "vlib" vlib)
- (copy-file "v.mod" vmod))
- #t)))))
+ (copy-file "v.mod" vmod)))))))
(inputs
`(("glib" ,glib)))
(native-inputs
`(("vc"
;; Versions are not consistently tagged, but the matching commit will
;; probably have ‘v0.x.y’ in the commit message.
- ,(let ((vc-version "b01d0fcda4b55861baa4be82e307cca4834b1641"))
+ ,(let ((vc-version "e8da48b5e44c3671cf5fc649cae5c38983b1ff52"))
;; v bootstraps from generated c source code from a dedicated
;; repository. It's readable, as generated source goes, and not at all
;; obfuscated, and it's about 15kb. The original source written in
@@ -121,13 +147,20 @@
(commit vc-version)))
(file-name (git-file-name "vc" vc-version))
(sha256
- (base32 "052gp5q2k31r3lci3rx4k0vy0vjdjva64xvrbbihn8lgmw63lc9f")))))
+ (base32 "066q54nnpaainmnvzkhl65nw6b5l18fyshgv7g0zwqldnc60pv1r")))))
+ ("vmodules/markdown" ,markdown-origin)
;; For the tests.
("libx11" ,libx11)
("node" ,node)
("openssl" ,openssl)
- ("sqlite" ,sqlite)))
+ ("ps" ,procps)
+ ("sqlite" ,sqlite)
+ ("valgrind" ,valgrind)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "VMODULES")
+ (files '("bin/")))))
(home-page "https://vlang.io/")
(synopsis "Compiler for the V programming language")
(description
--
2.29.2
R
R
Ryan Prior wrote on 1 Dec 2020 05:15
[PATCH 2/3] gnu: vlang: Use system tiny-bignum.
(address . 44978@debbugs.gnu.org)
20201201041510.8476-2-rprior@protonmail.com
* gnu/packages/vlang.scm (vlang): Update to use system tiny-bignum.
---
gnu/packages/vlang.scm | 20 +++++++++++++++-----
1 file changed, 15 insertions(+), 5 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index 655a77fadc..83bacfc6c3 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages vlang)
#:use-module (gnu packages glib)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages node)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
@@ -56,7 +57,12 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0adpjmb8ak4hsbm7iqrx4b5s1a99sc9byg5ah6c1whhsxm781k9r"))))
+ (base32 "0adpjmb8ak4hsbm7iqrx4b5s1a99sc9byg5ah6c1whhsxm781k9r"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Eventually remove the whole thirdparty directory.
+ (delete-file-recursively "thirdparty/bignum")))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -71,10 +77,13 @@
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-before 'build 'patch-makefile
- (lambda _
+ (add-before 'build 'patch-files
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
- (("rm -rf") "true"))))
+ (("rm -rf") "true"))
+ (substitute* "vlib/math/big/big.v"
+ (("@VROOT/thirdparty/bignum")
+ (string-append (assoc-ref inputs "tiny-bignum") "/share")))))
(add-before 'build 'patch-cc
(lambda _
(let* ((bin "tmp/bin")
@@ -128,7 +137,8 @@
(copy-recursively "vlib" vlib)
(copy-file "v.mod" vmod)))))))
(inputs
- `(("glib" ,glib)))
+ `(("glib" ,glib)
+ ("tiny-bignum" ,tiny-bignum)))
(native-inputs
`(("vc"
;; Versions are not consistently tagged, but the matching commit will
--
2.29.2
R
R
Ryan Prior wrote on 1 Dec 2020 05:15
[PATCH 3/3] gnu: vlang: Use system cJSON.
(address . 44978@debbugs.gnu.org)
20201201041510.8476-3-rprior@protonmail.com
* gnu/packages/vlang.scm (vlang): Use system cJSON.
---
gnu/packages/vlang.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index 83bacfc6c3..334901ffb6 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
#:use-module (guix git-download)
@@ -62,7 +63,8 @@
(snippet
'(begin
;; Eventually remove the whole thirdparty directory.
- (delete-file-recursively "thirdparty/bignum")))))
+ (delete-file-recursively "thirdparty/bignum")
+ (delete-file-recursively "thirdparty/cJSON")))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -83,7 +85,10 @@
(("rm -rf") "true"))
(substitute* "vlib/math/big/big.v"
(("@VROOT/thirdparty/bignum")
- (string-append (assoc-ref inputs "tiny-bignum") "/share")))))
+ (string-append (assoc-ref inputs "tiny-bignum") "/share")))
+ (substitute* "vlib/json/json_primitives.v"
+ (("@VROOT/thirdparty/cJSON")
+ (assoc-ref inputs "cJSON")))))
(add-before 'build 'patch-cc
(lambda _
(let* ((bin "tmp/bin")
@@ -138,7 +143,8 @@
(copy-file "v.mod" vmod)))))))
(inputs
`(("glib" ,glib)
- ("tiny-bignum" ,tiny-bignum)))
+ ("tiny-bignum" ,tiny-bignum)
+ ("cJSON" ,(package-source cjson))))
(native-inputs
`(("vc"
;; Versions are not consistently tagged, but the matching commit will
--
2.29.2
R
R
Ryan Prior wrote on 6 Dec 2020 05:59
Update vlang
(name . 44978@debbugs.gnu.org)(address . 44978@debbugs.gnu.org)
35N2DXLpecT3OpRRYasD3SsEGFOI5ao9iclbzCUwJUyg6bBX913C2Rgudodrv7hBdmGziuxgYpMDhlvHsOttozbs41_457dJDkbYJ3M5Ch4=@protonmail.com
Hi there! It would be good to get some feedback on this patch series, if you have any question or reservations!

Also, since it's related, some updates on vlang packaging efforts:

!
1) The next release will have support for multiple directores in the VMODULES environment variable, allowing us to use it as a search path similar to how we do GOPATH. This opens the door to a v-build-system and inclusion of packages for v libraries, which I'm researching how to contribute. This is the last v release where all the libraries have to be copied into a single directory.
2) The build system for compiling tools ahead-of-time has not been in good shape, but with some prodding from myself, it's improving. Hopefully by the next release we should have a fix for https://issues.guix.gnu.org/44978

Cheers,
Ryan
Attachment: file
C
C
Christopher Baines wrote on 8 Dec 2020 10:40
Re: [bug#44978] [PATCH] gnu: packages: Add tiny-bignum.
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 44978@debbugs.gnu.org)
87o8j4iqk4.fsf@cbaines.net
Hey, I've pushed this to master as
ab58b2cc32068fc9e5f0a7c7ae112349943b7dfd with a few changes.


Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/maths.scm (tiny-bignum): New variable.

I removed packages: from the commit message, I think just gnu: Add
foo. is the convention.

Toggle quote (38 lines)
> ---
> gnu/packages/maths.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 46 insertions(+)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index d3f3539e26..a0dd9a761c 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -4984,6 +4984,52 @@ be fed to @command{tcalc} through the command line.")
> (home-page "https://sites.google.com/site/mohammedisam2000/tcalc")
> (license license:gpl3+)))
>
> +(define-public tiny-bignum
> + (let ((commit "1d7a1f9b8e77316187a6b3eae8e68d60a6f9a4d4"))
> + (package
> + (name "tiny-bignum")
> + (version (git-version "0" "0" commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/kokke/tiny-bignum-c")
> + (commit commit)))
> + (file-name (git-file-name "tiny-bignum" commit))
> + (sha256
> + (base32 "0vj71qlhlaa7d92bfar1kwqv6582dqrby8x3kdw0yzh82k2023g6"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (replace 'check
> + (lambda _
> + (substitute* "scripts/test_rand.py"
> + (("\t") " ")
> + (("\" % (\\w+)" _ symbol) (string-append "\" % int(" symbol ")")))
> + (invoke "make" "test")))

I split this phase, so 'check just does the testing, and I tweaked it to
use the tests? argument.

Toggle quote (11 lines)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((share (string-append (assoc-ref outputs "out") "/share"))
> + (doc (string-append (assoc-ref outputs "out") "/doc")))
> + (mkdir-p share)
> + (install-file "bn.c" share)
> + (install-file "bn.h" share)
> + (mkdir-p doc)
> + (install-file "LICENSE" doc)
> + (install-file "README.md" doc)))))))

The build output showed:

## WARNING: phase `install' returned `#<unspecified>'. Return values other than #t
## are deprecated. Please migrate this package so that its phase
## procedures report errors by raising an exception, and otherwise
## always return #t.

So I added #t at the end.

Toggle quote (15 lines)
> + (native-inputs
> + `(("python" ,python-wrapper)))
> + (home-page "https://github.com/kokke/tiny-bignum-c")
> + (synopsis "Small portable multiple-precision unsigned integer arithmetic in C")
> + (description
> + "This library provides portable Arbitrary-precision unsigned integer
> +arithmetic in C, for calculating with large numbers. Basic arithmetic (+, -,
> +*, /, %) and bitwise operations (&, |, ^. <<, >>) plus increments, decrements
> +and comparisons are supported.")
> + (license license:unlicense))))
> +
> (define-public sundials
> (package
> (name "sundials")

Final thing, I'm not sure the location of the bn.c and bn.h files in the
output are particularly conventional. I'd expect the .h file to be in
include I think, rather than share. Also, with a C library, I think
you'd expect to have a .so file in lib, and the .c file not to be
included. Looking ahead to where you're using this, I think I see why
you've done it this way, but it could mean that using this package is
harder in other packages.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/PSgtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XetPxAAp4cgnVZ1ShS9rgs5f9nFKTKcU8Ld8bvV
G3Rm8d+MD+SIf+PGA7LyaeujM1fmkfIbtysxSRSBPAX8jKhiBKgBWh+UVTbl9Qsq
mxljvbBXdKFpg2qQykHFPcjlp7EYssGjrMVDBR9AK+SYw77l5dh+nE37gO3YwRr+
KKl4xYQpe0wRD8bSlkJUuVhQWeg1Y4e+7AZGHAJ2zKleIomY4maAtS+hc8jCMZTE
CbzLiuhrD84PalLzfEU/U86YtSAMX1zQfi1gFJySdqwxX2+VcWqF+QZIQLvrvT4g
Lo+S4lDu7ejbOUb7/L3hidPGCjkH5d50ORlVWK339Top2TjIFy4oysZKdq2mA7zs
PnCHr1p7CXVeXLHCB5L2nOMwWpaHmALSmlej6u7QeEzLrZQN/gN3FimHsKAhiYdn
GW4bsB3S6h4E3eNvAZLdLR9/3wRmDVfzbKKJGJb9jiO9RP3Ja4PWe3n8N4akioO9
Ey10YuQQo+Gni9h90UUDqizRjhgZ7wukJijgy92OvfzK1093bUvxzBUFaN2BtSZS
j8/tmipoWkuUqlZajQzMqo8BRoL0vkZ9fDs0nDniLUO4w1lRHd4VrjQB0ovo2VYm
Tu9iiUjX+uYHVwxfJyYcRaWV0Tl7OO/uwJyArfX3gsUqVEsLQr+flLYUA/RGlInf
2NIOenacdwM=
=CyDV
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 8 Dec 2020 10:41
Re: [bug#44978] [PATCH] gnu: Add cjson.
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 44978@debbugs.gnu.org)
87lfe8iqia.fsf@cbaines.net
Hey, I pushed this to master as
ab58b2cc32068fc9e5f0a7c7ae112349943b7dfd.

The only thing I changed here is I moved the package in to the
javascript module, as that seemed more appropriate than the web module.

Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (36 lines)
> * gnu/packages/web.scm (cjson): New variable.
> ---
> gnu/packages/web.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index f559d63f1b..21fc1ae964 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -957,6 +957,26 @@ project)
> @end itemize")
> (license license:bsd-2)))
>
> +(define-public cjson
> + (package
> + (name "cjson")
> + (version "1.7.14")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/DaveGamble/cJSON")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1rlnailhjm180zb6pc17jwphjwivw8kfpqgixjfgq4iyryq46sah"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:configure-flags '("-DENABLE_CJSON_UTILS=On")))
> + (home-page "https://github.com/DaveGamble/cJSON")
> + (synopsis "JSON parser written in ANSI C")
> + (description "This library provides a portable embeddable JSON parser.")
> + (license license:expat)))
> +
> (define-public qjson
> (package
> (name "qjson")
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/PSk1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd19w/+IWihKICmv7cHAkjYdvFyfpzLj/P3vRef
KgKisiItv6MRUG+oJQ7cFmWN2OeBI2xAo5L3HqMOBXnCZQz6YzYbD1iHrKGkGw9G
TnjB3Hk8/NhRlNGf7RdgxITdiyI39bZvwcHl8sYgOyxG9tPpKOGqnZxY4uA8RlWT
CyL/omEmLNnML2lwUBbHvYg+EGvJ2xBUiIVgimU722Vw5Ww4VosUKWDa4UbSQX5+
eiB6XqzVSCosqMgzaC2YX24qJclEEfnJpQOGd++zQyNGuv9pvm7JonJZa5Mf4Pqq
DnLC1fY9vkX7m7vm5Ra6kbOSxaqg+hN5vk1rp/U16ONfJiHBNCUBdnXtg8q8Ddkr
HXww1vDHeuKGwNiRgwaTdzaghEuA/IhSfT9/IAlTrp0/bTApABoeg9fbdEkKPhzk
c66rv1Le7GQpEnTY0YFIdWl/K26ct6SfZfhhHpeqiB4GeRXU+pwrXBPfjSJ9wGnb
5lQJ6M6QSW1j3GHmu5aWM0bN+dqsgCrn4kQGBD7Cv+m402lt2xT3anKI7wzcBKqM
Q/XAJ9IpKp1hgbHCJ2oBguU51cxHHoOnsAptpbV44zNITqlzvCFd4dKYYwyKlmpS
vrOgbbGTKsZFZQBzNaXHwZeJUlxUlH945PLHY29dF9CPvqdUU2d0qdUbsipIBDHX
K7IgpmGmNJQ=
=FnK2
-----END PGP SIGNATURE-----

R
R
Ryan Prior wrote on 24 Dec 2020 03:44
Package v 0.1.30 in preparation for 0.2
(name . 44978@debbugs.gnu.org)(address . 44978@debbugs.gnu.org)
0gb0j1LPUXE1LC-eLcvFAXxU5JJrfE3cMVV7-J-V_AWNgow8BD6wYScfdSzpoVlDVWm6suW-uSLNEv7fhT9U6cjzuK1khaZVducfpAIqRYg=@protonmail.com
Hi there! Bumping this again since vlang recently released 0.2, a major release has has a number of goodies I've asked for to help improve the quality of our package. I'm beginning the work to update our package to 0.2, and hopefully will also succeed at moving a few more of the vendored sources out into dedicated packages.

If I can get any feedback on this patch series it would be very appreciated!
Attachment: file
L
L
Leo Famulari wrote on 24 Dec 2020 23:03
(name . Ryan Prior via Guix-patches via)(address . guix-patches@gnu.org)(name . 44978@debbugs.gnu.org)(address . 44978@debbugs.gnu.org)
X+UQMGTmNX68aS8S@jasmine.lan
On Thu, Dec 24, 2020 at 02:44:57AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (4 lines)
> Hi there! Bumping this again since vlang recently released 0.2, a major release has has a number of goodies I've asked for to help improve the quality of our package. I'm beginning the work to update our package to 0.2, and hopefully will also succeed at moving a few more of the vendored sources out into dedicated packages.
>
> If I can get any feedback on this patch series it would be very appreciated!

It looks like some parts of the patch series have been pushed. Can you
clarify what remains to be done? For example, attach your proposed
further work to a reply message.
R
R
Ryan Prior wrote on 1 Jan 2021 20:47
What remains to be done for bug#44978
(name . 44978@debbugs.gnu.org)(address . 44978@debbugs.gnu.org)
0eRgSomwIQZNX7A7BeHMHtPuoxjWnTzKHnmPgMY15T9UEQNE5DeepkpGQApVW1YfLAZ85pSA4XOASkkSo79a_U-doiQMuCukhMdOID9GPYY=@protonmail.com
Thanks Leo! I published a new patch series which obsoletes this one. See debbugs 45601.
Attachment: file
R
R
Ryan Prior wrote on 1 Jan 2021 20:49
re: bug#44978
(name . control@debbugs.gnu.org)(address . control@debbugs.gnu.org)
q4a_jqgA4thoxoesADcK60FMGfZ5LqIkgWXZjwhsrNKi5OdhSXOpEm5j6J7IVvJs7fMiv5s-temdZcAKr6JsLbDDStcPyphyQfh_xe4Gyf4=@protonmail.com
close 44978
Attachment: file
?