[PATCH] gnu: fonts.scm: Add nerd-fonts

  • Open
  • quality assurance status badge
Details
3 participants
  • benoit
  • Barnabas Beres
  • John Kehayias
Owner
unassigned
Submitted by
Barnabas Beres
Severity
normal
Merged with
B
B
Barnabas Beres wrote on 11 Nov 2020 14:47
(address . guix-patches@gnu.org)(name . Barnabas Beres)(address . beresbarnus03@gmail.com)
20201111134713.9025-1-beresbarnus03@gmail.com
* gnu/packages/fonts.scm (nerd-fonts): New variable
---
gnu/packages/fonts.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 396e89a1fd..67cdf8335a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2009,3 +2009,36 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-nerd-fonts
+ (package
+ (name "font-nerd-fonts")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanoasis/nerd-fonts")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1la79y16k9rwcl2zsxk73c0kgdms2ma43kpjfqnq5jlbfdj0niwg"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-files-writable
+ (lambda _
+ (for-each
+ make-file-writable
+ (find-files "." ".*\\.(otf|otc|ttf|ttc)$"))
+ #t)))))
+ (home-page "https://www.nerdfonts.com/")
+ (synopsis "Iconic font aggregator, collection, and patcher")
+ (description
+ "Nerd Fonts patches developer targeted fonts with a high number
+of glyphs (icons). Specifically to add a high number of extra glyphs
+from popular ‘iconic fonts’ such as Font Awesome, Devicons, Octicons,
+and others.")
+ (license license:expat)))
--
2.29.2
J
J
John Kehayias wrote on 18 Aug 2021 22:29
Re: Processed: bug#44476 ([PATCH] gnu: fonts.scm: Add nerd-fonts)
(address . control@debbugs.gnu.org)
YvrkkHBrI1lwrqHuQRfvjVNDrsSmHHpf4M8z7GYI2GvnhcWnkWQGP-T0QGdu9XPiJkUMhKDyAqNzMPGc3NXHUtWSD-sgf1SBkU1yRU8vpGY=@protonmail.com
merge 44575 44476
J
J
John Kehayias wrote on 18 Aug 2021 22:32
[PATCH] gnu: fonts.scm: Add nerd-fonts
(name . 44575@debbugs.gnu.org)(address . 44575@debbugs.gnu.org)
DVZY2NucbNPpn6TkwNcjYmR9sddkuxzw_1p-mbuZR_DTRKsAlaDhZkVEqSpl0HcbJot-KoUx60CKDewZIBXYuZE_EQsNvcydi-WyNZZhN6c=@protonmail.com
Hello,

(Sorry, only saw the duplicated patches after I reopened an older one, hopefully now all merged and open. Let's continue on the newest bug #. Forgive the spam.)

Doesn't look like this patch was ever merged or reviewed. I would love to have nerd-fonts in Guix, though it may be very large to have all the fonts together. We could alternatively have packages for each font, maybe all derived from the complete package (though ideally you'd want to avoid downloading everything for each font). Or at least split off the large ones, like Noto?

Thoughts on this package?

Thanks,
John
B
B
benoit wrote on 14 Jun 2022 18:56
splitting
(address . 44575@debbugs.gnu.org)
e48d801f121c38e2a58a24b605b1450d@benoitj.ca
Hi,

thanks for posting this patch.

I myself use nerd-fonts FiraCode and cant see a benefit to install >1GB
of fonts when all I would like to get is just one of the variant.

I do think this should be split by fonts that people find useful. Nerd
fonts has a long list of patched fonts, I think this effort could focus
on the most popular ones to start with.

To go around this, I modified this patch to be firacode specific with a
url-fetch method, a url pointing to
and installed this font-nerd-fonts-firacode guix package.

It does work for me.

what do you think?

Benoit
?