(address . guix-patches@gnu.org)(name . Barnabas Beres)(address . beresbarnus03@gmail.com)
* gnu/packages/fonts.scm (nerd-fonts): New variable
---
gnu/packages/fonts.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 360a3ece76..3969d5eb97 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2020 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Barnabas Beres <beresbarnus03@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1979,3 +1980,36 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-nerd-fonts
+ (package
+ (name "font-nerd-fonts")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanoasis/nerd-fonts")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1la79y16k9rwcl2zsxk73c0kgdms2ma43kpjfqnq5jlbfdj0niwg"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-files-writable
+ (lambda _
+ (for-each
+ make-file-writable
+ (find-files "." ".*\\.(otf|otc|ttf|ttc)$"))
+ #t)))))
+ (home-page "https://www.nerdfonts.com/")
+ (synopsis "Iconic font aggregator, collection, and patcher")
+ (description
+ "Nerd Fonts patches developer targeted fonts with a high number
+of glyphs (icons). Specifically to add a high number of extra glyphs
+from popular ‘iconic fonts’ such as Font Awesome, Devicons, Octicons,
+and others.")
+ (license license:expat)))
--
2.26.0