cuirass: fail to install with simple configuration

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
important
J
J
Jonathan Brielmaier wrote on 2 Oct 2020 13:11
(name . bug-guix)(address . bug-guix@gnu.org)
4b43ccaa-58d1-f834-6e7c-d5be4e31c55b@web.de
Hi,

I'm trying to set up a simple cuirass server. But in the last month I
never got it working. This time I tried with help from Mathieu.

cuirass-spec:
```
(define %cuirass-specs
'((#:name . "my-manifest")
(#:load-path-inputs . ("guix"))
(#:package-path-inputs . ())
(#:proc-input . "guix")
(#:proc-file . "build-aux/cuirass/gnu-system.scm")
(#:proc . cuirass-jobs)
(#:proc-args (subset . "all"))
(#:inputs . (((#:name . "guix")
(#:url . "git://git.savannah.gnu.org/guix.git")
(#:load-path . ".")
(#:branch . "master")
(#:no-compile? . #t))
((#:name . "jonsger-guix")
(#:load-path . ".")
(#:branch . "master")
(#:no-compile? . #t))))
(#:build-outputs . ())))
(list %cuirass-specs)
```

Used as:
```
(service cuirass-service-type
(cuirass-configuration
(specifications %cuirass-specs)
(use-substitutes? #t)))
```

Gives following error when reconfiguring this system:
```
Backtrace:
In guix/status.scm:
776:4 19 (call-with-status-report _ _)
In guix/scripts/system.scm:
1170:4 18 (_)
In ice-9/boot-9.scm:
1736:10 17 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
631:37 16 (thunk)
1300:8 15 (call-with-build-handler _ _)
1300:8 14 (call-with-build-handler _ _)
1300:8 13 (call-with-build-handler #<procedure 7fc206bd3450 at
guix/ui.scm:1166:2 (continue store things mode)> _)
2042:24 12 (run-with-store #<store-connection 256.99 7fc202e2af50> _
#:guile-for-build _ #:system _ #:target _)
In guix/scripts/system.scm:
840:13 11 (_ _)
748:13 10 (_ _)
In ice-9/boot-9.scm:
152:2 9 (with-fluid* _ _ _)
In unknown file:
8 (primitive-load
"/gnu/store/ki892f95cw5i48r165k6di4n3wb2d2cc-switch-to-system.scm")
7 (primitive-load
"/gnu/store/smpbrrw738f6ncpgrlw4h9qwbgr2vwaa-activate.scm")
In ice-9/boot-9.scm:
260:13 6 (for-each #<procedure primitive-load (_)> _)
In unknown file:
5 (primitive-load
"/gnu/store/z2yjxn8c7spiql4cdv6ydkvrqbdl85kd-activate-service.scm")
In ice-9/eval.scm:
619:8 4 (_ #(#<directory (guile-user) 7fc2119e1f00> 980 982))
In ice-9/ports.scm:
461:11 3 (call-with-output-file #f #<procedure 7fc202f17940 at
ice-9/boot-9.scm:803:2 _> #:binary _ #:encoding _)
In unknown file:
2 (open-file #f "w" #:encoding #f)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Wrong type (expecting string): #f
```
J
J
Jonathan Brielmaier wrote on 2 Oct 2020 13:20
control message for 43760
(address . control@debbugs.gnu.org)
32a86c53-9cfa-af8a-9fcd-83ab6f731c57@web.de
severity 43760 important
M
M
Mathieu Othacehe wrote on 2 Oct 2020 15:02
Re: bug#43760: cuirass: fail to install with simple configuration
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 43760@debbugs.gnu.org)
87sgawhjcf.fsf@gnu.org
Hello Jonathan,

Toggle quote (3 lines)
> ice-9/boot-9.scm:1669:16: In procedure raise-exception:
> Wrong type (expecting string): #f

Thanks for the bug report. This should be fixed with
d6a8f0a9781a90c3037f25e51d7ff32e50f7a8c1.

You will then probably hit this one:


but we'll see that later :)

Thanks,

Mathieu
J
J
Jonathan Brielmaier wrote on 2 Oct 2020 16:05
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43760-done@debbugs.gnu.org)
3de8932c-2aa2-47c0-36a5-d7004e90c7e8@web.de
On 02.10.20 15:02, Mathieu Othacehe wrote:
Toggle quote (9 lines)
>
> Hello Jonathan,
>
>> ice-9/boot-9.scm:1669:16: In procedure raise-exception:
>> Wrong type (expecting string): #f
>
> Thanks for the bug report. This should be fixed with
> d6a8f0a9781a90c3037f25e51d7ff32e50f7a8c1.

Yes, fix confirmed.

Toggle quote (4 lines)
> You will then probably hit this one:
>
> https://issues.guix.gnu.org/43757

I do :(
Closed
M
M
Mathieu Othacehe wrote on 2 Oct 2020 16:14
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 43760-done@debbugs.gnu.org)
87o8lkhfzq.fsf@gnu.org
Toggle quote (4 lines)
>
> I do :(

At least it's reproducible. Using one input works, but using more than
one input causes an exception during git fetching. It seems to be broken
since at least a few months.

It makes me think that we need a stronger test suite for Cuirass.

Thanks,

Mathieu
Closed
M
M
Mathieu Othacehe wrote on 3 Oct 2020 12:46
(address . 43760@debbugs.gnu.org)(address . jonathan.brielmaier@web.de)
87d01zio38.fsf@gnu.org
Hello Jonathan,

Toggle quote (6 lines)
>> You will then probably hit this one:
>>
>> https://issues.guix.gnu.org/43757
>
> I do :(

After fixing this issue, see: 761443bca6178b4ac299a8bd368d1cac4abda5f8,
I'm able to successfully evaluate and build your specification.

I still need to update the Cuirass package accordingly.

Thanks,

Mathieu
J
J
Jonathan Brielmaier wrote on 3 Oct 2020 12:55
40ca87e1-d252-8a71-69e9-6b5d72bea74f@web.de
On 03.10.20 12:46, Mathieu Othacehe wrote:
Toggle quote (14 lines)
>
> Hello Jonathan,
>
>>> You will then probably hit this one:
>>>
>>> https://issues.guix.gnu.org/43757
>>
>> I do :(
>
> After fixing this issue, see: 761443bca6178b4ac299a8bd368d1cac4abda5f8,
> I'm able to successfully evaluate and build your specification.
>
> I still need to update the Cuirass package accordingly.

Would be great :)
Thanks
M
M
Mathieu Othacehe wrote on 3 Oct 2020 15:15
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 43760@debbugs.gnu.org)
871rifih6k.fsf@gnu.org
Toggle quote (2 lines)
> Would be great :)

Done with b3f5402d2d506271857d2c987b79b741d4b0ec33.

Mathieu
?