(address . bug-guix@gnu.org)
Hello,
Running local tests, I have the following error:
Toggle snippet (28 lines)
2020-10-02T11:54:09 fatal: uncaught exception 'misc-error' in 'build' fiber!
2020-10-02T11:54:09 exception arguments: (#f "Attempt to suspend fiber within continuation barrier" () #f)
In ice-9/boot-9.scm:
1731:15 13 (with-exception-handler #<procedure 7f4eb362df60 at ic?> ?)
1736:10 12 (with-exception-handler _ _ #:unwind? _ # _)
152:2 11 (with-fluid* _ _ _)
718:2 10 (call-with-prompt ("break") #<procedure 7f4eb76adb60 a?> ?)
718:2 9 (call-with-prompt ("continue") #<procedure 7f4eb76ad14?> ?)
In ice-9/eval.scm:
619:8 8 (_ #(#(#<directory (guile-user) 7f4eb72d7f00> #<var?> ?)))
In srfi/srfi-1.scm:
634:9 7 (for-each #<procedure 7f4eb3750660 at cuirass/base.scm?> ?)
In ice-9/boot-9.scm:
1731:15 6 (with-exception-handler #<procedure 7f4eb3673ba0 at ic?> ?)
1669:16 5 (raise-exception _ #:continuable? _)
1764:13 4 (_ #<&compound-exception components: (#<&error> #<&orig?>)
In cuirass/utils.scm:
240:8 3 (_ _ . _)
In ice-9/boot-9.scm:
1731:15 2 (with-exception-handler #<procedure 7f4eb7616480 at ic?> ?)
In cuirass/utils.scm:
241:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
Attempt to suspend fiber within continuation barrier
the specification is:
Toggle snippet (22 lines)
(define manifest
'((#:name . "my-manifest")
(#:load-path-inputs . ("guix"))
(#:package-path-inputs . ())
(#:proc-input . "guix")
(#:proc-file . "build-aux/cuirass/gnu-system.scm")
(#:proc . cuirass-jobs)
(#:proc-args (subset . "all"))
(#:inputs . (((#:name . "guix")
(#:url . "git://git.savannah.gnu.org/guix.git")
(#:load-path . ".")
(#:branch . "master")
(#:no-compile? . #t))
((#:name . "guix2")
(#:url . "git://git.savannah.gnu.org/guix.git")
(#:load-path . ".")
(#:branch . "master")
(#:no-compile? . #t))))
(#:build-outputs . ())))
(list manifest)
It looks like adding a second input, creates an exception during inputs
fetching.
Thanks,
Mathieu
--