[PATCH] gnu: Add tic-80.

  • Open
  • quality assurance status badge
Details
4 participants
  • Björn Höfling
  • Chris Lemmer-Webber
  • Gabriel Arazas
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Arazas
Severity
normal
G
G
Gabriel Arazas wrote on 26 Sep 2020 12:17
(address . guix-patches@gnu.org)
20200926101738.18925-1-foo.dogsquared@gmail.com
TIC-80 features a PRO version that you can easily compile it for yourself
(just add DBUILD_PRO=TRUE to CMake configure flags).
Out of respect, the package is compiling the free version unless someone disagrees.
G
G
Gabriel Arazas wrote on 26 Sep 2020 12:17
(address . guix-patches@gnu.org)(name . Gabriel Arazas)(address . foo.dogsquared@gmail.com)
20200926101738.18925-2-foo.dogsquared@gmail.com
* gnu/packages/game-development.scm (tic-80): New variable.
---
gnu/packages/game-development.scm | 57 +++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 3252eb322e..3d0b2e7413 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2477,3 +2478,59 @@ fully dynamic omnidirectional shadows, global illumination, HDR lighting,
deferred shading, morphological / temporal / multisample anti-aliasing, and
much more.")
(license license:zlib))))
+
+(define-public tic-80
+ ;; TODO: Package TIC-80 with an additional output as a WASM module.
+ (package
+ (name "tic-80")
+ (version "0.80.1344")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nesbox/TIC-80")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b1qm1m1wwss4bh3q8gx26kk4g8j4n9mzdd4lbyj7k37fx5v09rp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (share/applications (string-append out "/share/applications"))
+ (share/icons (string-append out "/share/icons")))
+ (substitute* "CMakeLists.txt"
+ ;; Replace the destinations to be inline with Guix.
+ (("/usr/share/applications") bin)
+ (("/usr/share/icons") share/icons)
+ (("\\$\\{TIC80_DESKTOP_DIR}") share/applications))
+
+ ;; The files inside of the folder should have write permissions
+ ;; but it will be overwritten by the build process anyways so it
+ ;; is faster to delete them instead.
+ (delete-file-recursively "build/assets")
+ (mkdir-p "build/assets"))
+ #t)))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("freeglut" ,freeglut)
+ ("glu" ,glu)
+ ("gtk+" ,gtk+)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://tic80.com")
+ (synopsis "Fantasy computer with built-in tools for game development")
+ (description
+ "A fantasy computer featuring built-in tools such as a sprite editor,
+music tracker, and a text editor. This package builds the free version of the
+software which you can override the package and build the PRO version
+yourself.")
+ (license license:expat)))
--
2.28.0
L
L
Ludovic Courtès wrote on 28 Oct 2020 16:11
(name . Gabriel Arazas)(address . foo.dogsquared@gmail.com)(address . 43630@debbugs.gnu.org)
87lffq1j3o.fsf@gnu.org
Hi Gabriel,

Sorry for the long delay!

Gabriel Arazas <foo.dogsquared@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/game-development.scm (tic-80): New variable.

[...]

Toggle quote (6 lines)
> + (description
> + "A fantasy computer featuring built-in tools such as a sprite editor,
> +music tracker, and a text editor. This package builds the free version of the
> +software which you can override the package and build the PRO version
> +yourself.")

We need full sentences and, as per the FSDG, we won’t advertise the
“PRO” version (which is non-free I guess?) here. So instead I propose
this:

(description
"TIC-80 is a fantasy computer for making, playing and sharing tiny games.
There are built-in tools for development: code, sprites, maps, sound editors
and the command line, which is enough to create a mini retro game. At the
exit you will get a cartridge file, which can be stored and played on the
website.")

Another issue: the code bundles quite a few libraries. We should remove
them in a snippet and use the corresponding packages instead. Here’s
what I see in the log:

Toggle snippet (8 lines)
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sdl2'...
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sokol'...
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/squirrel'...
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/wren'...
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zip'...
Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zlib'...

‘sokol’ and ‘wren’ are apparently not packaged yet in Guix. As a first
step, you could remove everything but these two libraries, leaving a
FIXME about them.

Could you send an updated patch?

Thanks,
Ludo’.
B
B
Björn Höfling wrote on 28 Dec 2020 00:09
(name . Ludovic Courtès)(address . ludo@gnu.org)
20201228000950.29bdd294@alma-ubu
Hi Gabriel,

ping!

Would you like to send an updated patch with Ludovic's suggestions
included?

Thanks,

Björn

On Wed, 28 Oct 2020 16:11:07 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (56 lines)
> Hi Gabriel,
>
> Sorry for the long delay!
>
> Gabriel Arazas <foo.dogsquared@gmail.com> skribis:
>
> > * gnu/packages/game-development.scm (tic-80): New variable.
>
> [...]
>
> > + (description
> > + "A fantasy computer featuring built-in tools such as a sprite
> > editor, +music tracker, and a text editor. This package builds the
> > free version of the +software which you can override the package
> > and build the PRO version +yourself.")
>
> We need full sentences and, as per the FSDG, we won’t advertise the
> “PRO” version (which is non-free I guess?) here. So instead I propose
> this:
>
> (description
> "TIC-80 is a fantasy computer for making, playing and sharing
> tiny games. There are built-in tools for development: code, sprites,
> maps, sound editors and the command line, which is enough to create a
> mini retro game. At the exit you will get a cartridge file, which
> can be stored and played on the website.")
>
> Another issue: the code bundles quite a few libraries. We should
> remove them in a snippet and use the corresponding packages instead.
> Here’s what I see in the log:
>
> --8<---------------cut here---------------start------------->8---
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sdl2'...
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sokol'...
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/squirrel'...
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/wren'...
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zip'...
> Cloning into
> '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zlib'...
> --8<---------------cut here---------------end--------------->8---
>
> ‘sokol’ and ‘wren’ are apparently not packaged yet in Guix. As a
> first step, you could remove everything but these two libraries,
> leaving a FIXME about them.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
>
>
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCX+kUPgAKCRC/KGy2WT5f
/ZuSAKCNXBHfADw9cKCyPUDoDdkoFk+rVQCeILn3z8Y9qwvwe+u0T7g+jWITRmY=
=ZdPN
-----END PGP SIGNATURE-----


C
C
Chris Lemmer-Webber wrote on 23 Jul 2021 00:32
(name . Ludovic Courtès)(address . ludo@gnu.org)
87lf5y7zex.fsf@dustycloud.org
I don't have a version fulfilling all the changes Ludo' recommended,
but I got this to build and run on my computer based on Gabriel's patch.

I also tried bumping to the latest version (v0.90.1706) but curiously
that one built fine but segfaults when you try to run it... some
floating point exception. Just noting that in case someone is picking
this up and trying to advance it.

Ludovic Courtès writes:

Toggle quote (48 lines)
> Hi Gabriel,
>
> Sorry for the long delay!
>
> Gabriel Arazas <foo.dogsquared@gmail.com> skribis:
>
>> * gnu/packages/game-development.scm (tic-80): New variable.
>
> [...]
>
>> + (description
>> + "A fantasy computer featuring built-in tools such as a sprite editor,
>> +music tracker, and a text editor. This package builds the free version of the
>> +software which you can override the package and build the PRO version
>> +yourself.")
>
> We need full sentences and, as per the FSDG, we won’t advertise the
> “PRO” version (which is non-free I guess?) here. So instead I propose
> this:
>
> (description
> "TIC-80 is a fantasy computer for making, playing and sharing tiny games.
> There are built-in tools for development: code, sprites, maps, sound editors
> and the command line, which is enough to create a mini retro game. At the
> exit you will get a cartridge file, which can be stored and played on the
> website.")
>
> Another issue: the code bundles quite a few libraries. We should remove
> them in a snippet and use the corresponding packages instead. Here’s
> what I see in the log:
>
> --8<---------------cut here---------------start------------->8---
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sdl2'...
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/sokol'...
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/squirrel'...
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/wren'...
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zip'...
> Cloning into '/gnu/store/hb5kz8vrk5ykyc3xmx30h20f2bm7pmcp-tic-80-0.80.1344-checkout/vendor/zlib'...
> --8<---------------cut here---------------end--------------->8---
>
> ‘sokol’ and ‘wren’ are apparently not packaged yet in Guix. As a first
> step, you could remove everything but these two libraries, leaving a
> FIXME about them.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
?