On Mon, Sep 14, 2020 at 09:25:25PM -0700, Mike Rosset wrote:
Toggle quote (43 lines)
> * gnu/packages/audio.scm (jack-2): Update to 1.9.14.
> [arguments]: new 'declare-for-int phase after unpack that declares 'i in the
> for initialize statement. Add -lstdc++ to LDFLAGS 'set-linkflags phase
> ensures -lstdc++ is at the tail.
>
> This fixes issues that cause jack-2 to not build on system aarh64-linux.
> ---
> gnu/packages/audio.scm | 14 ++++++++++++--
> 1 file changed, 12 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 38ee4f8bcc..83c08b718e 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -2030,7 +2030,7 @@ synchronous execution of all clients, and low latency operation.")
> (define-public jack-2
> (package (inherit jack-1)
> (name "jack2")
> - (version "1.9.13")
> + (version "1.9.14")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://github.com/jackaudio/jack2/releases/"
> @@ -2039,7 +2039,7 @@ synchronous execution of all clients, and low latency operation.")
> (file-name (string-append name "-" version ".tar.gz"))
> (sha256
> (base32
> - "1d1d403jn4366mqig6g8ghr8057b3rn7gs26b5p3rkal34j20qw2"))))
> + "0z11hf55a6mi8h50hfz5wry9pshlwl4mzfwgslghdh40cwv342m2"))))
> (build-system waf-build-system)
> (arguments
> `(#:tests? #f ; no check target
> @@ -2047,8 +2047,18 @@ synchronous execution of all clients, and low latency operation.")
> "--alsa")
> #:phases
> (modify-phases %standard-phases
> + (add-after 'unpack 'declare-for-int
> + (lambda _
> + ;; Declare the for loop i incrementer.
> + (substitute* "dbus/sigsegv.c"
> + (("for\\(i = 0") "for(int i = 0"))
> + #t))
Any chance of an upstream bug number or something for this? It seems
like the type of thing that might be put into a snippet.
Toggle quote (16 lines)
> (add-before 'configure 'set-linkflags
> (lambda _
> + ;; Ensure -lstdc++ is the tail of LDFLAGS or the simdtests.cpp
> + ;; will not link with undefined reference to symbol
> + ;; '__gxx_personality_v0@@CXXABI_1.3'
> + (setenv "LDFLAGS" "-lstdc++")
> ;; Add $libdir to the RUNPATH of all the binaries.
> (substitute* "wscript"
> ((".*CFLAGS.*-Wall.*" m)
> --
> 2.28.0
>
>
>
>
--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9gXXAACgkQQarn3Mo9
g1EocBAAvHedkb2yUnqp4FKFzsElwMVdkg4aylCXjv40FDpM+q+lkjD6fQYH6QnM
BNctLLQQS5gxoo/bFZy/cYSR+mAl0eQtxoO2CeNUq1rDHgZh/3GxCGF5xjMV1OX+
Rbfj6fEdA/PW2BmpmJhokLMl41I0c7kHFeoEeMyMSNenAS2He66Nonmms0w9yWKP
/4Ow/rJ9MhBGhjL0sYAVbP0sNsM4sARrvedGdCEXf//5BuV4HwkoXUsjZvcYKydN
2qdDTTxsldewKg0MRV80ItjD5w+V3lEHr8lK75KZ2IUZvZ9ntyYNMxaouPfhbHIB
rNZ2jC6lVevgl97DJuh9FPEi4CjB2oH6bRnptRiPRwi1Aox69+pMf6AQLj6Fq4ax
kExAOcMOnL72Zsi9HQFNrDN68Pcz+JpWUUhKGo3hbDVPK2rSf3SxOG8OC1t1uxzQ
jFheJzXq8I4/9t+XQzFhx9KmMbG3sD5g4+6m1++Yf2Nh2ln503M6/1GzPGTt50Pp
SlgdFu4u3qOknT8SSW6HoVPROl9umosxcHuerx6lc4/i/X1moYUPyUHNs+gi+Ud+
WOgJ0juBnMY3RlyYk91aPj+icxDXt4fG+1z4y086L8xf5aXRfPL/t5/TRySe85iJ
3vxU2dadgpiRtA/m+0omBiW0J/qNIg4iGxrCCuFONYG0yadWNi4=
=eSJI
-----END PGP SIGNATURE-----