cabal-install/GHC fails to find libraries

  • Done
  • quality assurance status badge
Details
3 participants
  • John Soo
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 5 years ago
(address . bug-guix@gnu.org)
875zafcrt9.fsf@asu.edu
Hi Guix,

I have a haskell project until recently compiled with the following:

env -u GHC_PACKAGE_PATH cabal new-build

Now it fails with the following:

ld: cannot find -lm
ld: cannot find -lpthread
ld: cannot find -lz
ld: cannot find -lrt
ld: cannot find -lutil
ld: cannot find -ldl
ld: cannot find -lpthread
ld: cannot find -lm
ld: cannot find -lrt
ld: cannot find -ldl
ld: cannot find -lpthread
ld: cannot find -lpthread
ld: cannot find -lpthread
ld: cannot find -lc

Could a graft be failing to update references to various libraries?

I really don't know what could be going on.

Thanks!

John
Ricardo Wurmus wrote 5 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 42480@debbugs.gnu.org)
87zh7rz09q.fsf@elephly.net
John Soo <jsoo1@asu.edu> writes:

Toggle quote (6 lines)
> I have a haskell project until recently compiled with the following:
>
> env -u GHC_PACKAGE_PATH cabal new-build
>
> Now it fails with the following: [ld errors]

Do you have “gcc-toolchain” installed?

--
Ricardo
John Soo wrote 5 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 42480@debbugs.gnu.org)
87zh7rt8sz.fsf@asu.edu
Hi Ricardo,

I do have gcc-toolchain installed and I just realized that my project
compiles fine if I do not try to statically link. I believe this can be
closed as dynamic linking works fine. My mistake. I did see the issue
regarding captured inputs to ghc. I am in favor of removing them. I
always must have gcc-toolchain installed when using ghc anyways.

Thanks again,

John
Simon Tournier wrote 1 years ago
(name . John Soo)(address . jsoo1@asu.edu)(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 42480-done@debbugs.gnu.org)
875y4289p0.fsf@gmail.com
Hi

I think this old bug#42480,


can be closed.

On Wed, 22 Jul 2020 at 16:43, John Soo <jsoo1@asu.edu> wrote:

Toggle quote (6 lines)
> I do have gcc-toolchain installed and I just realized that my project
> compiles fine if I do not try to statically link. I believe this can be
> closed as dynamic linking works fine. My mistake. I did see the issue
> regarding captured inputs to ghc. I am in favor of removing them. I
> always must have gcc-toolchain installed when using ghc anyways.

Adding gcc-toolchain fixes the issue.

I am closing. Let me know if I am missing something.


Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42480@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42480
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help