blast+ is not reproducible

  • Done
  • quality assurance status badge
Details
3 participants
  • Maxim Cournoyer
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 30 Jun 2020 18:42
(address . bug-guix@gnu.org)
87sgecmroj.fsf@elephly.net
This should be rather easy to fix:

Toggle snippet (26 lines)
diff -r /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check
diff -r /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
4,13c4,13
< #define NCBI_RANDOM_VALUE_0 1770246234u
< #define NCBI_RANDOM_VALUE_1 2685550394u
< #define NCBI_RANDOM_VALUE_2 1952513968u
< #define NCBI_RANDOM_VALUE_3 4081691487u
< #define NCBI_RANDOM_VALUE_4 1126642990u
< #define NCBI_RANDOM_VALUE_5 2363626105u
< #define NCBI_RANDOM_VALUE_6 444644742u
< #define NCBI_RANDOM_VALUE_7 2799580837u
< #define NCBI_RANDOM_VALUE_8 216161479u
< #define NCBI_RANDOM_VALUE_9 992434062u
---
> #define NCBI_RANDOM_VALUE_0 2851596927u
> #define NCBI_RANDOM_VALUE_1 4039058594u
> #define NCBI_RANDOM_VALUE_2 3204116600u
> #define NCBI_RANDOM_VALUE_3 4270143185u
> #define NCBI_RANDOM_VALUE_4 1366873742u
> #define NCBI_RANDOM_VALUE_5 703144487u
> #define NCBI_RANDOM_VALUE_6 2507785646u
> #define NCBI_RANDOM_VALUE_7 3995716134u
> #define NCBI_RANDOM_VALUE_8 907933519u
> #define NCBI_RANDOM_VALUE_9 1149060107u

--
Ricardo
M
M
Maxim Cournoyer wrote on 29 Sep 2022 02:35
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 42141-done@debbugs.gnu.org)
87k05now4i.fsf@gmail.com
Hi,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (27 lines)
> This should be rather easy to fix:
>
> diff -r /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check
> diff -r /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
> 4,13c4,13
> < #define NCBI_RANDOM_VALUE_0 1770246234u
> < #define NCBI_RANDOM_VALUE_1 2685550394u
> < #define NCBI_RANDOM_VALUE_2 1952513968u
> < #define NCBI_RANDOM_VALUE_3 4081691487u
> < #define NCBI_RANDOM_VALUE_4 1126642990u
> < #define NCBI_RANDOM_VALUE_5 2363626105u
> < #define NCBI_RANDOM_VALUE_6 444644742u
> < #define NCBI_RANDOM_VALUE_7 2799580837u
> < #define NCBI_RANDOM_VALUE_8 216161479u
> < #define NCBI_RANDOM_VALUE_9 992434062u
> ---
>> #define NCBI_RANDOM_VALUE_0 2851596927u
>> #define NCBI_RANDOM_VALUE_1 4039058594u
>> #define NCBI_RANDOM_VALUE_2 3204116600u
>> #define NCBI_RANDOM_VALUE_3 4270143185u
>> #define NCBI_RANDOM_VALUE_4 1366873742u
>> #define NCBI_RANDOM_VALUE_5 703144487u
>> #define NCBI_RANDOM_VALUE_6 2507785646u
>> #define NCBI_RANDOM_VALUE_7 3995716134u
>> #define NCBI_RANDOM_VALUE_8 907933519u
>> #define NCBI_RANDOM_VALUE_9 1149060107u

Not anymore, according to:

Toggle snippet (8 lines)
$ guix challenge blast+

1 store items were analyzed:
- 1 (100.0%) were identical
- 0 (0.0%) differed
- 0 (0.0%) were inconclusive

That's for blast+ 2.11.0.

Closing!

Maxim
Closed
R
R
Ricardo Wurmus wrote on 29 Sep 2022 11:24
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87h70qsf9m.fsf@elephly.net
reopen 42141
thanks

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (44 lines)
> Hi,
>
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> This should be rather easy to fix:
>>
>> diff -r
>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include
>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check
>> diff -r
>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
>> 4,13c4,13
>> < #define NCBI_RANDOM_VALUE_0 1770246234u
>> < #define NCBI_RANDOM_VALUE_1 2685550394u
>> < #define NCBI_RANDOM_VALUE_2 1952513968u
>> < #define NCBI_RANDOM_VALUE_3 4081691487u
>> < #define NCBI_RANDOM_VALUE_4 1126642990u
>> < #define NCBI_RANDOM_VALUE_5 2363626105u
>> < #define NCBI_RANDOM_VALUE_6 444644742u
>> < #define NCBI_RANDOM_VALUE_7 2799580837u
>> < #define NCBI_RANDOM_VALUE_8 216161479u
>> < #define NCBI_RANDOM_VALUE_9 992434062u
>> ---
>>> #define NCBI_RANDOM_VALUE_0 2851596927u
>>> #define NCBI_RANDOM_VALUE_1 4039058594u
>>> #define NCBI_RANDOM_VALUE_2 3204116600u
>>> #define NCBI_RANDOM_VALUE_3 4270143185u
>>> #define NCBI_RANDOM_VALUE_4 1366873742u
>>> #define NCBI_RANDOM_VALUE_5 703144487u
>>> #define NCBI_RANDOM_VALUE_6 2507785646u
>>> #define NCBI_RANDOM_VALUE_7 3995716134u
>>> #define NCBI_RANDOM_VALUE_8 907933519u
>>> #define NCBI_RANDOM_VALUE_9 1149060107u
>
> Not anymore, according to:
>
> $ guix challenge blast+
>
> 1 store items were analyzed:
> - 1 (100.0%) were identical
> - 0 (0.0%) differed
> - 0 (0.0%) were inconclusive

This is still a problem:

Toggle snippet (42 lines)
$ diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check
diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h
--- /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h 1970-01-01 01:00:01.000000000 +0100
+++ /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h 1970-01-01 01:00:01.000000000 +0100
@@ -1095,7 +1095,7 @@
/* Build signature: compiler-name '_' compiler-version '-' configuration '--'
platform-name '-' hostname */
-#define NCBI_SIGNATURE "GCC_1030-DebugMTDLL64--x86_64-unknown-linux5.15.10-gnu2.33-localhost"
+#define NCBI_SIGNATURE "GCC_1030-DebugMTDLL64--x86_64-unknown-linux5.15.59-gnu2.33-localhost"
/* Define to 1 if SQLColAttribute's last argument is an SQLLEN * */
#define NCBI_SQLCOLATTRIBUTE_SQLLEN 1
diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
--- /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h 1970-01-01 01:00:01.000000000 +0100
+++ /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h 1970-01-01 01:00:01.000000000 +0100
@@ -1,13 +1,13 @@
#define NCBI_RANDOM_VALUE_TYPE Uint4
#define NCBI_RANDOM_VALUE_MIN 0
#define NCBI_RANDOM_VALUE_MAX 0xffffffffu
-#define NCBI_RANDOM_VALUE_0 3249030781u
-#define NCBI_RANDOM_VALUE_1 3573796697u
-#define NCBI_RANDOM_VALUE_2 2130009325u
-#define NCBI_RANDOM_VALUE_3 4284761029u
-#define NCBI_RANDOM_VALUE_4 3467737853u
-#define NCBI_RANDOM_VALUE_5 3267844710u
-#define NCBI_RANDOM_VALUE_6 4107058373u
-#define NCBI_RANDOM_VALUE_7 166436459u
-#define NCBI_RANDOM_VALUE_8 960927418u
-#define NCBI_RANDOM_VALUE_9 3839848519u
+#define NCBI_RANDOM_VALUE_0 2845495105u
+#define NCBI_RANDOM_VALUE_1 2158634051u
+#define NCBI_RANDOM_VALUE_2 4072202242u
+#define NCBI_RANDOM_VALUE_3 902228395u
+#define NCBI_RANDOM_VALUE_4 1353323915u
+#define NCBI_RANDOM_VALUE_5 574823513u
+#define NCBI_RANDOM_VALUE_6 4119501261u
+#define NCBI_RANDOM_VALUE_7 2477640938u
+#define NCBI_RANDOM_VALUE_8 2776595395u
+#define NCBI_RANDOM_VALUE_9 270550684u

--
Ricardo
R
R
Ricardo Wurmus wrote on 29 Sep 2022 11:32
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 42141@debbugs.gnu.org)
87czbesewx.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (92 lines)
> reopen 42141
> thanks
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi,
>>
>> Ricardo Wurmus <rekado@elephly.net> writes:
>>
>>> This should be rather easy to fix:
>>>
>>> diff -r
>>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include
>>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check
>>> diff -r
>>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
>>> /gnu/store/3y97kfanv9ynxnahyykixchlbpbyvjmm-blast+-2.10.1-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
>>> 4,13c4,13
>>> < #define NCBI_RANDOM_VALUE_0 1770246234u
>>> < #define NCBI_RANDOM_VALUE_1 2685550394u
>>> < #define NCBI_RANDOM_VALUE_2 1952513968u
>>> < #define NCBI_RANDOM_VALUE_3 4081691487u
>>> < #define NCBI_RANDOM_VALUE_4 1126642990u
>>> < #define NCBI_RANDOM_VALUE_5 2363626105u
>>> < #define NCBI_RANDOM_VALUE_6 444644742u
>>> < #define NCBI_RANDOM_VALUE_7 2799580837u
>>> < #define NCBI_RANDOM_VALUE_8 216161479u
>>> < #define NCBI_RANDOM_VALUE_9 992434062u
>>> ---
>>>> #define NCBI_RANDOM_VALUE_0 2851596927u
>>>> #define NCBI_RANDOM_VALUE_1 4039058594u
>>>> #define NCBI_RANDOM_VALUE_2 3204116600u
>>>> #define NCBI_RANDOM_VALUE_3 4270143185u
>>>> #define NCBI_RANDOM_VALUE_4 1366873742u
>>>> #define NCBI_RANDOM_VALUE_5 703144487u
>>>> #define NCBI_RANDOM_VALUE_6 2507785646u
>>>> #define NCBI_RANDOM_VALUE_7 3995716134u
>>>> #define NCBI_RANDOM_VALUE_8 907933519u
>>>> #define NCBI_RANDOM_VALUE_9 1149060107u
>>
>> Not anymore, according to:
>>
>> $ guix challenge blast+
>>
>> 1 store items were analyzed:
>> - 1 (100.0%) were identical
>> - 0 (0.0%) differed
>> - 0 (0.0%) were inconclusive
>
> This is still a problem:
>
> $ diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check
> diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h
> --- /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h 1970-01-01 01:00:01.000000000 +0100
> +++ /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h 1970-01-01 01:00:01.000000000 +0100
> @@ -1095,7 +1095,7 @@
>
> /* Build signature: compiler-name '_' compiler-version '-' configuration '--'
> platform-name '-' hostname */
> -#define NCBI_SIGNATURE "GCC_1030-DebugMTDLL64--x86_64-unknown-linux5.15.10-gnu2.33-localhost"
> +#define NCBI_SIGNATURE "GCC_1030-DebugMTDLL64--x86_64-unknown-linux5.15.59-gnu2.33-localhost"
>
> /* Define to 1 if SQLColAttribute's last argument is an SQLLEN * */
> #define NCBI_SQLCOLATTRIBUTE_SQLLEN 1
> diff -ru /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
> --- /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h 1970-01-01 01:00:01.000000000 +0100
> +++ /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include-check/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h 1970-01-01 01:00:01.000000000 +0100
> @@ -1,13 +1,13 @@
> #define NCBI_RANDOM_VALUE_TYPE Uint4
> #define NCBI_RANDOM_VALUE_MIN 0
> #define NCBI_RANDOM_VALUE_MAX 0xffffffffu
> -#define NCBI_RANDOM_VALUE_0 3249030781u
> -#define NCBI_RANDOM_VALUE_1 3573796697u
> -#define NCBI_RANDOM_VALUE_2 2130009325u
> -#define NCBI_RANDOM_VALUE_3 4284761029u
> -#define NCBI_RANDOM_VALUE_4 3467737853u
> -#define NCBI_RANDOM_VALUE_5 3267844710u
> -#define NCBI_RANDOM_VALUE_6 4107058373u
> -#define NCBI_RANDOM_VALUE_7 166436459u
> -#define NCBI_RANDOM_VALUE_8 960927418u
> -#define NCBI_RANDOM_VALUE_9 3839848519u
> +#define NCBI_RANDOM_VALUE_0 2845495105u
> +#define NCBI_RANDOM_VALUE_1 2158634051u
> +#define NCBI_RANDOM_VALUE_2 4072202242u
> +#define NCBI_RANDOM_VALUE_3 902228395u
> +#define NCBI_RANDOM_VALUE_4 1353323915u
> +#define NCBI_RANDOM_VALUE_5 574823513u
> +#define NCBI_RANDOM_VALUE_6 4119501261u
> +#define NCBI_RANDOM_VALUE_7 2477640938u
> +#define NCBI_RANDOM_VALUE_8 2776595395u
> +#define NCBI_RANDOM_VALUE_9 270550684u

These values are generated here:

ncbi-blast-2.11.0+-src/c++/scripts/common/impl/define_random_macros.sh

I don’t know if we can just define them to fixed values; it should be
fine.

Debian also has a patch for other problems including the NCBI_SIGNATURE
value:


--
Ricardo
R
R
Ricardo Wurmus wrote on 30 Sep 2022 00:04
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 42141-done@debbugs.gnu.org)
87zgehrg5w.fsf@elephly.net
Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.

--
Ricardo
Closed
M
M
Maxim Cournoyer wrote on 30 Sep 2022 05:09
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 42141-done@debbugs.gnu.org)
87ill5mucy.fsf@gmail.com
Hello,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (2 lines)
> Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.

Yay! Thank you! And for my curiosity, how did I get the two build
farms to agree on an identical build, as reported in 'guix challenge'?

That is odd.

--
Maxim
Closed
R
R
Ricardo Wurmus wrote on 30 Sep 2022 12:04
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 42141-done@debbugs.gnu.org)
87v8p5qiqx.fsf@elephly.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (9 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.
>
> Yay! Thank you! And for my curiosity, how did I get the two build
> farms to agree on an identical build, as reported in 'guix challenge'?
>
> That is odd.

I don’t know. I also got the same result from “guix challenge”, but I
hadn’t built it locally. It was only when I built it on my machine (and
with “--check”) that I confirmed that the issue still existed.

Any way of making “guix challenge” tell us more about what it actually
compared?

--
Ricardo
Closed
Z
Z
zimoun wrote on 30 Sep 2022 16:01
(address . 42141-done@debbugs.gnu.org)
87v8p50xmp.fsf@gmail.com
Hi,

On Thu, 29 Sep 2022 at 23:09, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (9 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.
>
> Yay! Thank you! And for my curiosity, how did I get the two build
> farms to agree on an identical build, as reported in 'guix challenge'?
>
> That is odd.

Because blast+ is multi-outputs and ’out’ is fine contrary to ’include’:

Toggle snippet (16 lines)
$ guix challenge blast+:include
/gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include contents differ:
local hash: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
https://ci.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
https://bordeaux.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0cakizfsqb1lla62cmwnng1h9gvqgf3lyjk0k7lkiaisj713mpzx
differing files:
/include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
/include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h

1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive


Cheers,
simon
Closed
R
R
Ricardo Wurmus wrote on 30 Sep 2022 16:38
(name . zimoun)(address . zimon.toutoune@gmail.com)
87mtahq65i.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (28 lines)
> Hi,
>
> On Thu, 29 Sep 2022 at 23:09, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>> Ricardo Wurmus <rekado@elephly.net> writes:
>>
>>> Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.
>>
>> Yay! Thank you! And for my curiosity, how did I get the two build
>> farms to agree on an identical build, as reported in 'guix challenge'?
>>
>> That is odd.
>
> Because blast+ is multi-outputs and ’out’ is fine contrary to ’include’:
>
> $ guix challenge blast+:include
> /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include contents differ:
> local hash: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
> https://ci.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
> https://bordeaux.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0cakizfsqb1lla62cmwnng1h9gvqgf3lyjk0k7lkiaisj713mpzx
> differing files:
> /include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
> /include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h
>
> 1 store items were analyzed:
> - 0 (0.0%) were identical
> - 1 (100.0%) differed
> - 0 (0.0%) were inconclusive

Ah, thanks for explaining!

--
Ricardo
Closed
M
M
Maxim Cournoyer wrote on 30 Sep 2022 23:20
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87a66glft2.fsf@gmail.com
Hi,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (32 lines)
> zimoun <zimon.toutoune@gmail.com> writes:
>
>> Hi,
>>
>> On Thu, 29 Sep 2022 at 23:09, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>>> Ricardo Wurmus <rekado@elephly.net> writes:
>>>
>>>> Fixed with commit 1ee2d117d8fa9e2e0d4ec46cc5555497bb5e6337.
>>>
>>> Yay! Thank you! And for my curiosity, how did I get the two build
>>> farms to agree on an identical build, as reported in 'guix challenge'?
>>>
>>> That is odd.
>>
>> Because blast+ is multi-outputs and ’out’ is fine contrary to ’include’:
>>
>> $ guix challenge blast+:include
>> /gnu/store/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast+-2.11.0-include contents differ:
>> local hash: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
>> https://ci.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0q4nssknlmc54m8abndn9bhrlwm4m28lkb75i1wnwr0ghbalj02x
>> https://bordeaux.guix.gnu.org/nar/lzip/0kbsdr61qpj0vkc6s8g2kbp4dq936n0p-blast%2B-2.11.0-include: 0cakizfsqb1lla62cmwnng1h9gvqgf3lyjk0k7lkiaisj713mpzx
>> differing files:
>> /include/ncbi-tools++/ncbi-tools++/ncbi_random_macro.h
>> /include/ncbi-tools++/ncbi-tools++/ncbiconf_unix.h
>>
>> 1 store items were analyzed:
>> - 0 (0.0%) were identical
>> - 1 (100.0%) differed
>> - 0 (0.0%) were inconclusive
>
> Ah, thanks for explaining!

Ah! Shouldn't the default be to compare all outputs? It seems that'd
be less surprising and useful.

What do you think?

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42141@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42141
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch