John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
Hi Guix,
psd-ide is an indispensable part of my PureScript workflow.
Thanks!
John
Toggle quote (1 lines)
>From c2001d000ffa61a4d2ae18e1f7db9b0c57923197 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 07:36:28 -0700
Subject: [PATCH] gnu: Add emacs-psc-ide.
* gnu/packages/emacs-xyz.scm (emacs-psc-ide): New variable.
---
gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..0fa43fa4d1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,41 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-psc-ide
+ (package
+ (name "emacs-psc-ide")
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/purescript-emacs/psc-ide-emacs")
+ (commit "7fc2b841be25f5bc5e1eb7d0634436181c38b3fe")))
+ (file-name (git-file-name name "0.0.0"))
+ (sha256
+ (base32
+ "0r0fymyai30jimm34z1cmav4wgij8ci6s1d9y7qigygfbbfrdsmj"))))
+ (inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)
+ ("emacs-s" ,emacs-s)
+ ("emacs-seq" ,emacs-seq)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purescript-emacs/psc-ide-emacs")
+ (synopsis "Emacs integration for PureScript's psc-ide tool")
+ (description
+ "Emacs integration for PureScript's psc-ide tool. Featuring:
+@itemize
+@item Completions
+@item Type at point
+@item Go to definition
+@item Automatic imports
+@item Case split
+@item Build system integration
+@item Flycheck support
+@end itemize")
+ (license license:gpl3+)))
--
2.26.0