gnu: packages: java: Add libantlr3c

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
Blocked by
R
R
Raghav Gururajan wrote on 28 Mar 2020 19:24
(address . guix-patches@gnu.org)
e2db9638cefebba4974a310fdb63334d@disroot.org
Hello Guix!

Please find the attached patch to add "libantlr3c" package.

Regards,
RG.
Attachment: libantlr3c.patch
M
M
Maxim Cournoyer wrote on 31 Mar 2020 04:00
control message for bug #40291
(address . control@debbugs.gnu.org)
87eet9z3jt.fsf@gmail.com
block 40291 by 40307
quit
M
M
Maxim Cournoyer wrote on 31 Mar 2020 06:53
Re: [bug#40291] gnu: packages: java: Add libantlr3c
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40291@debbugs.gnu.org)
87imilxgyg.fsf@gmail.com
Hello Raghav!

You'll find my review of this patch below. For other readers, this is
needed in preparation of Linphone, which requires it through its
belle-sip dependency.

"Raghav Gururajan" <raghavgururajan@disroot.org> writes:

Toggle quote (12 lines)
> Hello Guix!
>
> Please find the attached patch to add "libantlr3c" package.
>
> Regards,
> RG.
>
> From 791e2392aaa9a3202db90c1e50340c38bd001504 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sat, 28 Mar 2020 14:21:35 -0400
> Subject: [PATCH 6/6] gnu: packages: java: Add libantlr3c

This should be: "gnu: Add libantlr3c."

Toggle quote (32 lines)
> * gnu/packages/java.scm (libantlr3c): New variable.
> ---
> gnu/packages/java.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
> index 5154dc124e..400ef8795e 100644
> --- a/gnu/packages/java.scm
> +++ b/gnu/packages/java.scm
> @@ -105,6 +105,35 @@
> ;; build framework. We then build the more recent JDKs Icedtea 2.x and
> ;; Icedtea 3.x.
>
> +(define-public libantlr3c
> + (package
> + (name "libantlr3c")
> + (version "3.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri
> + (string-append "https://www.antlr3.org/download/C/"
> + name "-" version ".tar.gz"))
> + (sha256
> + (base32 "0lpbnb4dq4azmsvlhp6khq1gy42kyqyjv8gww74g5lm2y6blm4fa"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:configure-flags
> + (list
> + "--enable-debuginfo"
> + "--enable-64bit"

Is this really required? The default is "no". If enabled, it probably
needs to be made conditional so that it is only enabled for 64 bits
architectures.

Toggle quote (5 lines)
> + "--enable-abiflags"
> + "--enable-antlrdebug"
> + "--enable-shared"
> + "--enable-static"

If enabled, the static library should go to its own "static" output.

Toggle quote (8 lines)
> + "--enable-fast-install")))
> + (synopsis "ANTLR C Library")
> + (description "LIBANTLR3C provides run-time C libraries for ANTLR3
> +(ANother Tool for Language Recognition v3).")
> + (home-page "https://www.antlr3.org/")
> + (license license:bsd-3)))
> +

The indentation is off. If you don't use Emacs for editing, you can run
the Emacs script provided by Guix like this:

./etc/indent-code.el gnu/packages/java.scm libantlr3c

Thanks!

Maxim
R
R
Raghav Gururajan wrote on 31 Mar 2020 17:52
control message for bug #40264
(address . control@debbugs.gnu.org)
e6b45e27d6ce70ee78a2f27203e1b466@disroot.org
block 40264 by 40291
M
M
Maxim Cournoyer wrote on 1 Apr 2020 04:37
Re: [bug#40291] gnu: packages: java: Add libantlr3c
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40291-done@debbugs.gnu.org)
87lfngvslw.fsf@gmail.com
Hi Raghav,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (58 lines)
> Hello Raghav!
>
> You'll find my review of this patch below. For other readers, this is
> needed in preparation of Linphone, which requires it through its
> belle-sip dependency.
>
> "Raghav Gururajan" <raghavgururajan@disroot.org> writes:
>
>> Hello Guix!
>>
>> Please find the attached patch to add "libantlr3c" package.
>>
>> Regards,
>> RG.
>>
>> From 791e2392aaa9a3202db90c1e50340c38bd001504 Mon Sep 17 00:00:00 2001
>> From: Raghav Gururajan <raghavgururajan@disroot.org>
>> Date: Sat, 28 Mar 2020 14:21:35 -0400
>> Subject: [PATCH 6/6] gnu: packages: java: Add libantlr3c
>
> This should be: "gnu: Add libantlr3c."
>
>> * gnu/packages/java.scm (libantlr3c): New variable.
>> ---
>> gnu/packages/java.scm | 29 +++++++++++++++++++++++++++++
>> 1 file changed, 29 insertions(+)
>>
>> diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
>> index 5154dc124e..400ef8795e 100644
>> --- a/gnu/packages/java.scm
>> +++ b/gnu/packages/java.scm
>> @@ -105,6 +105,35 @@
>> ;; build framework. We then build the more recent JDKs Icedtea 2.x and
>> ;; Icedtea 3.x.
>>
>> +(define-public libantlr3c
>> + (package
>> + (name "libantlr3c")
>> + (version "3.4")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri
>> + (string-append "https://www.antlr3.org/download/C/"
>> + name "-" version ".tar.gz"))
>> + (sha256
>> + (base32 "0lpbnb4dq4azmsvlhp6khq1gy42kyqyjv8gww74g5lm2y6blm4fa"))))
>> + (build-system gnu-build-system)
>> + (arguments
>> + `(#:configure-flags
>> + (list
>> + "--enable-debuginfo"
>> + "--enable-64bit"
>
> Is this really required? The default is "no". If enabled, it probably
> needs to be made conditional so that it is only enabled for 64 bits
> architectures.

I've studied what Debian does, and they do conditionals based on the
host. I could find a way to achieve this with Guix and pushed as commit
f1cf62f5dc.

Toggle quote (8 lines)
>
>> + "--enable-abiflags"
>> + "--enable-antlrdebug"
>> + "--enable-shared"
>> + "--enable-static"
>
> If enabled, the static library should go to its own "static" output.

As discussed in #guix, I've disabled static libraries for now. I've
also only used the flags which are specific to antlr3c and that need to
be changed from their default values, to keep the noise level as low as
possible.

With this, the base for Linphone is now merged and we can attack the
more interesting bits.

Thanks!

Maxim
Closed
R
R
Raghav Gururajan wrote on 2 Apr 2020 06:09
gnu: Add libantlr3c (v2)
(address . 40291@debbugs.gnu.org)
e471618c2ed050e163a5245520546cae@disroot.org

?