[PATCH 6/7] gnu: java-openjfx-controls: Add new variable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Alexey Abramov
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal
Merged with

Debbugs page

Alexey Abramov wrote 5 years ago
(address . guix-patches@gnu.org)
20200222201755.50425-6-levenson@mmer.org
---
gnu/packages/java.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 60f220f873..de7efbb29f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3072,6 +3072,22 @@ distribution.")))
(propagated-inputs
`(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+(define-public java-openjfx-controls
+ (package (inherit java-openjfx-build)
+ (name "java-openjfx-controls")
+ (arguments
+ `(#:jar-name "java-openjfx-controls.jar"
+ #:source-dir "modules/controls/src/main/java"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (let ((resources (string-append (getcwd) "/modules/controls/src/main/resources")))
+ (copy-recursively resources "build/classes")) #t)))))
+ (propagated-inputs
+ `(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+
(define-public java-openjfx-media
(package (inherit java-openjfx-build)
(name "java-openjfx-media")
--
2.24.1
Leo Famulari wrote 5 years ago
(no subject)
(address . control@debbugs.gnu.org)
20200304031442.GA2347@jasmine.lan
merge 39741 39742 39743 39744 39745 39746 39747
Alexey Abramov wrote 5 years ago
[v2] gnu: java-openjfx-controls: Add new variable.
(address . 39743@debbugs.gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)
20200309165409.173672-1-levenson@mmer.org
---
gnu/packages/java.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1625195120..21ff1b4a30 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3110,6 +3110,22 @@ distribution.")))
(propagated-inputs
`(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+(define-public java-openjfx-controls
+ (package (inherit java-openjfx-build)
+ (name "java-openjfx-controls")
+ (arguments
+ `(#:jar-name "java-openjfx-controls.jar"
+ #:source-dir "modules/controls/src/main/java"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (let ((resources (string-append (getcwd) "/modules/controls/src/main/resources")))
+ (copy-recursively resources "build/classes")) #t)))))
+ (propagated-inputs
+ `(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+
(define-public java-openjfx-media
(package (inherit java-openjfx-build)
(name "java-openjfx-media")
--
2.24.1
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39743@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39743
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help