[PATCH 5/7] gnu: java-openjfx-swt: Add new variable.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Alexey Abramov
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal
Merged with

Debbugs page

Alexey Abramov wrote 5 years ago
(address . guix-patches@gnu.org)
20200222201755.50425-5-levenson@mmer.org
---
gnu/packages/java.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f2a3861501..60f220f873 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3059,6 +3059,19 @@ distribution.")))
(propagated-inputs
`(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+(define-public java-openjfx-swt
+ (package (inherit java-openjfx-build)
+ (name "java-openjfx-swt")
+ (arguments
+ `(#:jar-name "java-openjfx-swt.jar"
+ #:source-dir "modules/swt/src/main/java"
+ #:tests? #f))
+ (inputs
+ `(("antlr3" ,antlr3)
+ ("java-stringtemplate" ,java-stringtemplate)))
+ (propagated-inputs
+ `(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+
(define-public java-openjfx-media
(package (inherit java-openjfx-build)
(name "java-openjfx-media")
--
2.24.1
Leo Famulari wrote 5 years ago
(no subject)
(address . control@debbugs.gnu.org)
20200304031442.GA2347@jasmine.lan
merge 39741 39742 39743 39744 39745 39746 39747
Alexey Abramov wrote 5 years ago
[v2] gnu: java-openjfx-swt: Add new variable.
(address . 39741@debbugs.gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)
20200309164146.169942-1-levenson@mmer.org
---
gnu/packages/java.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6d3f0f6771..1625195120 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3097,6 +3097,19 @@ distribution.")))
(propagated-inputs
`(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+(define-public java-openjfx-swt
+ (package (inherit java-openjfx-build)
+ (name "java-openjfx-swt")
+ (arguments
+ `(#:jar-name "java-openjfx-swt.jar"
+ #:source-dir "modules/swt/src/main/java"
+ #:tests? #f))
+ (inputs
+ `(("antlr3" ,antlr3)
+ ("java-stringtemplate" ,java-stringtemplate)))
+ (propagated-inputs
+ `(("java-openjfx-graphics" ,java-openjfx-graphics)))))
+
(define-public java-openjfx-media
(package (inherit java-openjfx-build)
(name "java-openjfx-media")
--
2.24.1
levenson wrote 5 years ago
Re: [bug#39745] [PATCH 4/7] gnu: java-openjfx-swing: Add new variable.
(name . Leo Famulari)(address . leo@famulari.name)(address . 39745@debbugs.gnu.org)(address . 39741@debbugs.gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)
84v9ndp4fl.fsf@delta.i-did-not-set--mail-host-address--so-tickle-me
Thank you!

Leo Famulari <leo@famulari.name> writes:

Toggle quote (8 lines)
> On Sat, Feb 22, 2020 at 09:17:52PM +0100, Alexey Abramov wrote:
>> * gnu/packages/java.scm (java-openjfx-build): Add patch to the base package.
>> * gnu/packages/patches/java-openjfx-build-swing-compile-JFXPanel-with-JDK-8.patch: Fix swing compilation for jdk8.
>
> This commit adds the patch file but also makes a new package
> java-openjfx-swing. Adding the patch to java-openjfx-build and adding
> the new package should be done in separate commits.

I split the change into two separated commits. v3

Toggle quote (12 lines)
> Also remember to add the patch to 'gnu/local.mk'.
>
>> +From 173e65937d9e76872df51f7ba39c9d58986dc38f Mon Sep 17 00:00:00 2001
>> +From: Alexey Abramov <levenson@mmer.org>
>> +Date: Fri, 3 Jan 2020 01:17:45 +0100
>> +Subject: [PATCH] java-openjfx-build: Cannot compile JFXPanel with JDK 8
>> +
>> +For more info please see https://bugs.openjdk.java.net/browse/JDK-8149967
>
> This link is great but please add a brief summary of why we need the
> patch and what it does (one or two sentences is enough).

--
Alexey
levenson wrote 5 years ago
Re: [bug#39746] [PATCH 7/7] gnu: java-openjfx-web: Add new variable.
(name . Leo Famulari)(address . leo@famulari.name)(address . 39746@debbugs.gnu.org)(address . 39741@debbugs.gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)
84r1y1p47i.fsf@delta.i-did-not-set--mail-host-address--so-tickle-me
Leo Famulari <leo@famulari.name> writes:

Toggle quote (9 lines)
> On Sat, Feb 22, 2020 at 09:17:55PM +0100, Alexey Abramov wrote:
>> * gnu/packages/java.scm (java-openjfx-build): Add patch to the base package.
>> * gnu/packages/patches/java-openjfx-build-web-Check-xlocale.h-header-file.patch: New
>> file. Remove hardcoded xlocale definitions.
>
> I have the same comments as previously. We need to fix up the commit
> message, add java-openjfx-web in a separate commit, and add some
> description to the xlocale patch file.

I fixed the comment, add description to the patch and split the change
into two commits.

Toggle quote (6 lines)
> Can you send a revised patch series? You can add the argument
> '--subject-prefix=v2' to your `git send-email` or `git format-patch`
> command to distinguish the new patches from the old ones.
>
> Thanks!

Thank you for subject-prefix tip!

--
Alexey
Tobias Geerinckx-Rice wrote 5 years ago
(address . 39746@debbugs.gnu.org)(address . 39741@debbugs.gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)(name . Leo Famulari)(address . leo@famulari.name)
87blouk4my.fsf@nckx
Alexey,

levenson@mmer.org 写道:
Toggle quote (2 lines)
> Thank you for subject-prefix tip!

The shorter ‘-v2’ will do the right thing too.

(While writing this I found out it's not documented in the man
page, but it works.)

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl5xTIUACgkQ2Imw8BjF
STzJaQ//RU8O67Ug7QrPqaTDhzSzqfD6S6o6mtHynV+mPNcMlIs9XizqLsAyOSfO
FTnjVk78SJfSTL5IifEKm/j3/tpibfiMAqeVkGaUWHhto0XjA1y5OMiAkn/Ua1yJ
8Lme6TpoNdI+qy3Outn+dFmaUKN5Z4a0CZ8zMPNxQ38k2ccn2fRC9cmKaXs9yHDv
9JPbZuIk1CpIVCBhvzM8yMy/AqKprZ/2UNNUzDUBRfpCZYzQbiLqu0ORWbBGXFzE
3xBs7pNSrUN9ZowTZTFz6Zg9yMwoJccRYeZX6kGRBhz9VLFgF/KpzQn3aBpbKre0
Nt+40S9W3oCkH9KGCcDdmqgVR064daNGDbqse6P6UNhn0f+rRBLCo209FbwvMTHO
YTscnYJNtPYM5pfKPtl3uKe2KFJNeFKbB18SYujNK4pqn+Bw7GsGYwa2ETd7tFdT
07Kfd8jVULxDTeYT6BD05tiy0V1+ZMEeluB66RrW13fFsQTmpJ74w/dqDVSyykk5
FlZAKbzMPdoyN5prvQSO+uQDyAy2gtfa3+HnOa2Xlt8Ir1lkdBHOGsV7ZVCePgKd
x3uW/vnZ++shzHuN4/aQXPuSpBVIo3rXRytE6Xrv9u/vKcKvicXmlXv67issRQuh
sTWnNGXi0Fj5kEOGX77zxaljySRkd/KOPmN41mZ72PJ457bcBMw=
=J9L7
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 39741@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39741
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help