Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)(address . 39053@debbugs.gnu.org)
* gnu/services/sound.scm (ladspa-configuration): New record.
(ladspa-environment): New procedure.
(ladspa-service-type): New service type.
(pulseaudio-environment): Remove LADSPA_PATH.
* doc/guix.texi: Adjust documentation.
---
doc/guix.texi | 20 +++++++++++---------
gnu/services/sound.scm | 33 ++++++++++++++++++++++++++++++++-
2 files changed, 43 insertions(+), 10 deletions(-)
Toggle diff (86 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 60491af4d4..431895aa7d 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -15951,19 +15951,21 @@ pcm.!default @{
See @uref{https://www.alsa-project.org/main/index.php/Asoundrc} for the
details.
-@deffn {Scheme Variable} pulseaudio-service-type
-This is the type for the @uref{http://www.pulseaudio.org/, PulseAudio
-sound server}, which sets the @var{LADSPA_PATH} environment variable to
-allow PulseAudio load modules from @code{swh-plugins} package.
+@deffn {Scheme Variable} ladspa-service-type
+This service sets the @var{LADSPA_PATH} variable, so that programs, which
+respect it, e.g. PulseAudio, can load LADSPA plugins.
-See @uref{http://plugin.org.uk/ladspa-swh/docs/ladspa-swh.html} for the
-details.
-
-The following example will setup the service:
+The following example will setup the service to enable modules from the
+@code{swh-plugins} package:
@lisp
-(service pulseaudio-service-type)
+(service ladspa-service-type
+ (ladspa-configuration (plugins (list swh-plugins))))
@end lisp
+
+See @uref{http://plugin.org.uk/ladspa-swh/docs/ladspa-swh.html} for the
+details.
+
@end deffn
@node Database Services
diff --git a/gnu/services/sound.scm b/gnu/services/sound.scm
index 5d72b3ada2..64b45f585f 100644
--- a/gnu/services/sound.scm
+++ b/gnu/services/sound.scm
@@ -35,7 +35,10 @@
alsa-service-type
pulseaudio-configuration
- pulseaudio-service-type))
+ pulseaudio-service-type
+
+ ladspa-configuration
+ ladspa-service-type))
;;; Commentary:
;;;
@@ -162,4 +165,32 @@ ctl.!default {
(default-value (pulseaudio-configuration))
(description "Configure PulseAudio sound support.")))
+
+;;;
+;;; LADSPA
+;;;
+
+(define-record-type* <ladspa-configuration>
+ ladspa-configuration make-ladspa-configuration
+ ladspa-configuration?
+ (plugins ladspa-plugins (default '())))
+
+(define (ladspa-environment config)
+ ;; Define this variable in the global environment such that
+ ;; pulseaudio swh-plugins (and similar LADSPA plugins) work.
+ `(("LADSPA_PATH" .
+ (string-join
+ ',(map (lambda (package) (file-append package "/lib/ladspa"))
+ (ladspa-plugins config))
+ ":"))))
+
+(define ladspa-service-type
+ (service-type
+ (name 'ladspa)
+ (extensions
+ (list (service-extension session-environment-service-type
+ ladspa-environment)))
+ (default-value (ladspa-configuration))
+ (description "Configure LADSPA plugins.")))
+
;;; sound.scm ends here
--
2.24.1