Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
* gnu/services/sound (pulseaudio-environment): Add PULSE_CONFIG and
PULSE_CLIENTCONFIG.
---
gnu/services/sound.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
Toggle diff (19 lines)
diff --git a/gnu/services/sound.scm b/gnu/services/sound.scm
index f01d958ce7..859aa9c16d 100644
--- a/gnu/services/sound.scm
+++ b/gnu/services/sound.scm
@@ -119,8 +119,10 @@ ctl.!default {
(define (pulseaudio-environment config)
;; Define this variable in the global environment such that
;; pulseaudio swh-plugins works.
- `(("LADSPA_PATH"
- . ,(file-append swh-plugins "/lib/ladspa"))))
+ `(("LADSPA_PATH" . ,(file-append swh-plugins "/lib/ladspa"))
+ ;; Define these variables, so that pulseaudio honors /etc.
+ ("PULSE_CONFIG" . "/etc/pulse/daemon.conf")
+ ("PULSE_CLIENTCONFIG" . "/etc/pulse/client.conf")))
(define (pulseaudio-conf-entry arg)
(match arg
--
2.24.1