[PATCH 2/3] services: pulseaudio-service-type: Honor /etc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
Merged with

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200109135746.1993-3-leo.prikler@student.tugraz.at
* gnu/services/sound (pulseaudio-environment): Add PULSE_CONFIG and
PULSE_CLIENTCONFIG.
---
gnu/services/sound.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/services/sound.scm b/gnu/services/sound.scm
index f01d958ce7..859aa9c16d 100644
--- a/gnu/services/sound.scm
+++ b/gnu/services/sound.scm
@@ -119,8 +119,10 @@ ctl.!default {
(define (pulseaudio-environment config)
;; Define this variable in the global environment such that
;; pulseaudio swh-plugins works.
- `(("LADSPA_PATH"
- . ,(file-append swh-plugins "/lib/ladspa"))))
+ `(("LADSPA_PATH" . ,(file-append swh-plugins "/lib/ladspa"))
+ ;; Define these variables, so that pulseaudio honors /etc.
+ ("PULSE_CONFIG" . "/etc/pulse/daemon.conf")
+ ("PULSE_CLIENTCONFIG" . "/etc/pulse/client.conf")))
(define (pulseaudio-conf-entry arg)
(match arg
--
2.24.1
Marius Bakke wrote 5 years ago
(address . control@debbugs.gnu.org)
87v9piyluy.fsf@devup.no
merge 39053 39052 39054 39055 39062 39061 39063 39065 39064
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39054@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39054
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help