[PATCH 2/2] gnu: Add zrythm.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandros Theodotou
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
Merged with

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
cd2281585c5c734929f03fb0e0e9dcc83ba6c03b.camel@zrythm.org
Hi,

Attaching the patch for Zrythm.

Thanks,
Alex
From 008f999d55f995b41de02bdd02de9fb4042653b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jan 2020 14:31:05 +0000
Subject: [PATCH 2/2] gnu: Add zrythm.

* gnu/packages/music.scm (zrythm): New variable.
---
gnu/packages/music.scm | 49 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 48 insertions(+), 1 deletion(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e607306282..a1f297832f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
-;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5113,3 +5113,50 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(description "Helm is a cross-platform polyphonic synthesizer available standalone
and as an LV2 plugin.")
(license license:gpl3+)))
+
+(define-public zrythm
+ (package
+ (name "zrythm")
+ (version "0.7.345")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zrythm.org/releases/zrythm-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ (build-system meson-build-system)
+ (outputs '("out"))
+ (arguments
+ `(#:configure-flags
+ `("-Denable_tests=true" "-Dmanpage=true"
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("font-dseg", font-dseg)
+ ("ffmpeg", ffmpeg)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("gettext", gettext-minimal)
+ ("glibc", glibc)
+ ("gtk+", gtk+)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libyaml" ,libyaml)
+ ("lilv", lilv)
+ ("xdg-utils", xdg-utils)
+ ("rubberband", rubberband)))
+ (native-inputs
+ `(("pkg-config", pkg-config)
+ ("help2man", help2man)
+ ("libaudec" ,libaudec)
+ ("lv2", lv2)
+ ("glib" ,glib "bin"))) ;for 'glib-compile-resources'
+ (synopsis "Digital audio workstation focusing on usability")
+ (description "Zrythm is a digital audio workstation designed to be
+featureful and easy to use. It offers unlimited automation options, LV2
+plugin support, JACK support and chord assistance.")
+ (home-page "https://www.zrythm.org")
+ (license license:agpl3+)))
--
2.24.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl4V6PsACgkQAi6uQjE9
cPNs5Af/fwbfuvrTZniSWfaBWGIm/QkxHiEFZTrpbuGC1AXByjvpW1XzfkTK/VD5
KJHZlkiDzCh/VlPw3rVNRnOi85A2i4+9w0Z7dRCeVb4IpEP7Gx+4DqfM6xq69Xge
OhpfJI8S4fDlYkx/d7kYnwm5jLNltAYryS10DKMYgsPvA6/cDnWCfp53OKWdk5fT
q5+/QaWjpLweXHPvRbsjwujMRia+uDCaYO8v3a6QNZKIKtT3NyAMppzHiZ6BUv4K
O+jkFoolT0RlERVakXlFXhGxkOhnwqzoiZ73u9W8yx7PpRHh8GGe+Lv+F88+hxdl
GHv+67XV4z+GUN4mqUiH1zfzxd8Ofg==
=61jk
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 5 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 39039@debbugs.gnu.org)
20200109233236.61816bcf@scratchpost.org
xdg-utils seems to only contain binaries. Yet, zrythm is not patched to refer
to them. Are you sure they are used?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4XqgQACgkQ5xo1VCww
uqVI/wf+I3slilv0W88o7T1krWh3q8oG91bMELgjJ7HpOkw58ikztdFDSaAzqmSf
MGLmydyb7ypJVVrZCVKGPeocub0PKc1utD44deHbqt+3KFv0TEEHO0uaHKZYaYbG
QLzeugyV1ILhx205obBxt6Mk/j/IptFsX+8sVuH8FoyKIc8TZ4q50zITDthODpuc
idCm0cBntGj9m0gs1wCHf+WPK1gHCWJdNSX2ZU4f2N2OHL+cSEZq7yPI103jopXf
6/CaRJUxpLVYen4UX03phRLXd0z4+h5cO3JUzZyWr218oOXjCXCZbFItzVwUvyCA
RaGjlRQ8wHFvdvclkM0YzrDXCaAllQ==
=CqN1
-----END PGP SIGNATURE-----


Alexandros Theodotou wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 39039@debbugs.gnu.org)
040c93deafda2662ee711fa49aab0c2b5259d51f.camel@zrythm.org
Hi Danny,

It calls xdg-open at runtime using popen(), to open directories in the
user's file browser app. See io_open_directory() in src/utils/io.c.

Thanks,
Alex

On Thu, 2020-01-09 at 23:32 +0100, Danny Milosavljevic wrote:
Toggle quote (3 lines)
> xdg-utils seems to only contain binaries. Yet, zrythm is not patched
> to refer
> to them. Are you sure they are used?
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl4XrM4ACgkQAi6uQjE9
cPOyEQgAnzHgF5VOHrYG7ntV5u9qnrSW9yVCrv7OKiJHmiGozV8sd4lab7p84sFb
W6OyhfvcXWMmD8IDaaRBSpct05XZ2z33QixUmMaDlxZrwcsSlbel0lrqtQb8QFE0
88bD2frezu3InXP1pGTzZo/Y0qYWM8hxwOH+EucDmImYIebLW7XbH333iNdZyggo
FZ2fChppCHCLk6jVZo6NqbVWpxIk08eyyHJG5Eu8YhBgZv6ajAWeCzTOBByYR+qZ
9gkY9fW7Exf9UvrZROqvPW/xacd2Qn0+jRzxBuiEPqSARB+hkwZmzjXpPAoFVPBj
1JTsCHT/vt6UK+IKDIXQv763X/Ni4g==
=OVCt
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 5 years ago
control message for bug #39038
(address . control@debbugs.gnu.org)
878slsftb0.fsf@gnu.org
merge 39038 39039
quit
Ludovic Courtès wrote 5 years ago
Re: [bug#39039] [PATCH 2/2] gnu: Add zrythm.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 39039-done@debbugs.gnu.org)
87y2tsee51.fsf@gnu.org
Hi,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From 008f999d55f995b41de02bdd02de9fb4042653b3 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 8 Jan 2020 14:31:05 +0000
> Subject: [PATCH 2/2] gnu: Add zrythm.
>
> * gnu/packages/music.scm (zrythm): New variable.

I’ve applied the patch.

However, note that zrythm doesn’t keep any run-time reference to
‘xdg-utils’:

guix gc --references \
/gnu/store/6ahg92sk3akaspbvcd8vawkndjq97rf3-zrythm-0.7.345 |grep xdg-
# nothing

That means that, at run time, it won’t find ‘xdg-open’ unless the user
explicitly adds it to their profile. Could you take a look?

Furthermore, I get the usual:

Toggle snippet (8 lines)
$ /gnu/store/6ahg92sk3akaspbvcd8vawkndjq97rf3-zrythm-0.7.345/bin/zrythm
[…]
(zrythm:31567): GLib-GIO-ERROR **: 23:13:27.284: Settings schema 'org.zrythm.Zrythm.preferences' is not installed

(zrythm:31567): GLib-GIO-ERROR **: 23:13:27.284: Settings schema 'org.zrythm.Zrythm' is not installed
Spurumo-/romppunkto-komando

… hence the attached patch, which I applied.

Thanks!

Ludo’.
Toggle diff (16 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 55c66a8081..e378e9880b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5152,9 +5152,9 @@ and as an LV2 plugin.")
(base32
"1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
(build-system meson-build-system)
- (outputs '("out"))
(arguments
- `(#:configure-flags
+ `(#:glib-or-gtk? #t
+ #:configure-flags
`("-Denable_tests=true" "-Dmanpage=true"
"-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
(inputs
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39039@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39039
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help