Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
Attaching the patch for Zrythm.
Thanks,
Alex
From 008f999d55f995b41de02bdd02de9fb4042653b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jan 2020 14:31:05 +0000
Subject: [PATCH 2/2] gnu: Add zrythm.
* gnu/packages/music.scm (zrythm): New variable.
---
gnu/packages/music.scm | 49 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 48 insertions(+), 1 deletion(-)
Toggle diff (66 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e607306282..a1f297832f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
-;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5113,3 +5113,50 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(description "Helm is a cross-platform polyphonic synthesizer available standalone
and as an LV2 plugin.")
(license license:gpl3+)))
+
+(define-public zrythm
+ (package
+ (name "zrythm")
+ (version "0.7.345")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zrythm.org/releases/zrythm-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ (build-system meson-build-system)
+ (outputs '("out"))
+ (arguments
+ `(#:configure-flags
+ `("-Denable_tests=true" "-Dmanpage=true"
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("font-dseg", font-dseg)
+ ("ffmpeg", ffmpeg)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("gettext", gettext-minimal)
+ ("glibc", glibc)
+ ("gtk+", gtk+)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libyaml" ,libyaml)
+ ("lilv", lilv)
+ ("xdg-utils", xdg-utils)
+ ("rubberband", rubberband)))
+ (native-inputs
+ `(("pkg-config", pkg-config)
+ ("help2man", help2man)
+ ("libaudec" ,libaudec)
+ ("lv2", lv2)
+ ("glib" ,glib "bin"))) ;for 'glib-compile-resources'
+ (synopsis "Digital audio workstation focusing on usability")
+ (description "Zrythm is a digital audio workstation designed to be
+featureful and easy to use. It offers unlimited automation options, LV2
+plugin support, JACK support and chord assistance.")
+ (home-page "https://www.zrythm.org")
+ (license license:agpl3+)))
--
2.24.1
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl4V6PsACgkQAi6uQjE9
cPNs5Af/fwbfuvrTZniSWfaBWGIm/QkxHiEFZTrpbuGC1AXByjvpW1XzfkTK/VD5
KJHZlkiDzCh/VlPw3rVNRnOi85A2i4+9w0Z7dRCeVb4IpEP7Gx+4DqfM6xq69Xge
OhpfJI8S4fDlYkx/d7kYnwm5jLNltAYryS10DKMYgsPvA6/cDnWCfp53OKWdk5fT
q5+/QaWjpLweXHPvRbsjwujMRia+uDCaYO8v3a6QNZKIKtT3NyAMppzHiZ6BUv4K
O+jkFoolT0RlERVakXlFXhGxkOhnwqzoiZ73u9W8yx7PpRHh8GGe+Lv+F88+hxdl
GHv+67XV4z+GUN4mqUiH1zfzxd8Ofg==
=61jk
-----END PGP SIGNATURE-----