Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This first patch is a small library statically linked into Zrythm. The
next patch is Zrythm itself.
Thanks,
Alex
From 601bfb7e9c9efb13d8218fc35f09da70649e8513 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jan 2020 14:26:45 +0000
Subject: [PATCH 1/2] gnu: Add libaudec.
* gnu/packages/audio.scm (libaudec): New variable.
---
gnu/packages/audio.scm | 34 +++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)
Toggle diff (56 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cf06732e18..e62b63f0e3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2019 Hartmt Goebel <h.goebel@crazy-compilers.com>
@@ -54,6 +54,7 @@
#:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
@@ -4026,3 +4027,34 @@ in the package.")
;; (see the file 'COPYING.LGPL'). This allows writing ECI applications
;; that are not licensed under GPL.
(license (list license:gpl2 license:lgpl2.1))))
+
+(define-public libaudec
+ (package
+ (name "libaudec")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/libaudec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lfydvs92b0hr72z71ci3yi356rjzi162pgms8dphgg18bz8dazv"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags `("-Denable_tests=true -Denable_ffmpeg=true")))
+ (inputs
+ `(("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("ffmpeg" ,ffmpeg)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Library for reading and resampling audio files")
+ (description "libaudec is a wrapper library over
+ffmpeg, sndfile and libsamplerate for reading and
+resampling audio files, based on Robin Gareus' `audio_decoder`
+code.")
+ (home-page "https://git.zrythm.org/cgit/libaudec")
+ (license license:agpl3+)))
--
2.24.1
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl4V6HgACgkQAi6uQjE9
cPObgwgAoc2DC1sgKvEN/HA7nUY8aZShXfL2jnyYnQMDQLvgcheW4PPEht9aNvUo
vDhQ6zLpgAggmHmAwn+BFE7uKKsiap+XJ+luMDGuI0MMwv50EMEzYUJOtLqnxjjK
nQSOUYmAGVrvPSjIgkegX3uPODKyNYZBCZIRTv4rXe+1nKdJRUeX8lqHXd8aBjJf
r8Kk50B/UIdd85yVRTWzCzHKlJ+rg8tQWP6jmzr2gQg/DPZl2XwCLvIKt8NrpAkm
ZAmOoTy+sMidxJ85hYgwGWATJic7ckfuBuyM6JJ/146nYAbylS+ZJDpuwJVrv1V6
WkY4Rx8yZjKl6agAKeYr9cKrbQxT+g==
=ph09
-----END PGP SIGNATURE-----