(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
* gnu/packages/ci.scm (gitlab-runner): New variable.
---
gnu/packages/ci.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)
Toggle diff (54 lines)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index b49ac0f7c1..c9679c9674 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module ((guix licenses) #:prefix l:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -44,7 +46,8 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system go))
(define-public cuirass
(let ((commit "e20ff86d97f7dd92dad140b5919e3cbdf2fb1ce6")
@@ -152,3 +155,21 @@
intended as a replacement for Hydra.")
(home-page "https://www.gnu.org/software/guix/")
(license l:gpl3+))))
+
+(define-public gitlab-runner
+ (package
+ (name "gitlab-runner")
+ (version "12.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
+ version "/gitlab-runner-v" version ".tar.gz"))
+ (sha256 (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
+ (home-page "https://docs.gitlab.com/runner/")
+ (synopsis "GitLab Runner")
+ (description "GitLab Runner is the open source project that is used
+to run your jobs and send the results back to GitLab.")
+ (license l:expat)))
--
2.23.0