[PATCH] gnu: Add gitlab-runner.

  • Open
  • quality assurance status badge
Details
5 participants
  • Efraim Flashner
  • Ludovic Courtès
  • Mathieu Othacehe
  • Reza Alizadeh Majd
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal

Debbugs page

Reza Alizadeh Majd wrote 5 years ago
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20191231091757.69869-1-r.majd@pantherx.org
* gnu/packages/ci.scm (gitlab-runner): New variable.
---
gnu/packages/ci.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index b49ac0f7c1..c9679c9674 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module ((guix licenses) #:prefix l:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -44,7 +46,8 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system go))
(define-public cuirass
(let ((commit "e20ff86d97f7dd92dad140b5919e3cbdf2fb1ce6")
@@ -152,3 +155,21 @@
intended as a replacement for Hydra.")
(home-page "https://www.gnu.org/software/guix/")
(license l:gpl3+))))
+
+(define-public gitlab-runner
+ (package
+ (name "gitlab-runner")
+ (version "12.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
+ version "/gitlab-runner-v" version ".tar.gz"))
+ (sha256 (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
+ (home-page "https://docs.gitlab.com/runner/")
+ (synopsis "GitLab Runner")
+ (description "GitLab Runner is the open source project that is used
+to run your jobs and send the results back to GitLab.")
+ (license l:expat)))
--
2.23.0
Mathieu Othacehe wrote 5 years ago
(address . guix-patches@gnu.org)(address . 38827@debbugs.gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
87imlwsqir.fsf@gmail.com
Hello!

Toggle quote (2 lines)
> +;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>

You are a bit early :)

Toggle quote (11 lines)
> +(define-public gitlab-runner
> + (package
> + (name "gitlab-runner")
> + (version "12.6.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
> + version "/gitlab-runner-v" version ".tar.gz"))
> + (sha256 (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))

Those lines are above the column limit.

Toggle quote (7 lines)
> + (build-system go-build-system)
> + (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
> + (home-page "https://docs.gitlab.com/runner/")
> + (synopsis "GitLab Runner")
> + (description "GitLab Runner is the open source project that is used
> +to run your jobs and send the results back to GitLab.")

No need to mention it is open source, otherwise, it wouldn't be
here. You could also elaborate a bit.

Could you send an updated version ?

Thanks,

Mathieu
Reza Alizadeh Majd wrote 5 years ago
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . guix-patches@gnu.org)(address . 38827@debbugs.gnu.org)
ec8f68eb-cb11-4946-a6ac-17996489eb2c@www.fastmail.com
Hi,

Toggle quote (4 lines)
>
> Those lines are above the column limit.
>

I checked the package using `guix lint ...` but didn't receive any
warning about the column limit.

Toggle quote (5 lines)
>
> No need to mention it is open source, otherwise, it wouldn't be
> here. You could also elaborate a bit.
>

I use projects default document to fill the description field:

do I need to update description to a custom one?

--
Regards
Reza Alizadeh Majd
PantherX Team
Mathieu Othacehe wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 38827@debbugs.gnu.org)(address . guix-patches@gnu.org)
87d0c4sjam.fsf@gmail.com
Toggle quote (3 lines)
> I checked the package using `guix lint ...` but didn't receive any
> warning about the column limit.

Yup, we would need to improve the linter :) This column limit rule is
mentionned here[1].

Toggle quote (5 lines)
> I use projects default document to fill the description field:
> https://docs.gitlab.com/runner/
>
> do I need to update description to a custom one?

Yes, sometimes the upstream description is too short, uses superlatives
or so. You'll find some guidelines here[2].

Thanks,

Mathieu

Reza Alizadeh Majd wrote 5 years ago
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 38827@debbugs.gnu.org)
c6f32241-012b-4eca-a183-cf0d38df435e@www.fastmail.com
Hi,
Toggle quote (5 lines)
> [1]:
> https://guix.gnu.org/manual/en/html_node/Formatting-Code.html#Formatting-Code
> [2]:
> https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions

I update the package definition following the above guidelines.
could you please check if this updated patch is acceptable?

--
Regards
Reza Alizadeh Majd
PantherX Team
From 3fd96ceea56d6c16036398a96dd9051ce51afe63 Mon Sep 17 00:00:00 2001
From: Reza Alizadeh Majd <r.majd@pantherx.org>
Date: Tue, 31 Dec 2019 12:37:42 +0330
Subject: [PATCH] gnu: Add gitlab-runner.

* gnu/packages/ci.scm (gitlab-runner): New variable.
---
gnu/packages/ci.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index b49ac0f7c1..0515a62481 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module ((guix licenses) #:prefix l:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -44,7 +46,8 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system go))
(define-public cuirass
(let ((commit "e20ff86d97f7dd92dad140b5919e3cbdf2fb1ce6")
@@ -152,3 +155,23 @@
intended as a replacement for Hydra.")
(home-page "https://www.gnu.org/software/guix/")
(license l:gpl3+))))
+
+(define-public gitlab-runner
+ (package
+ (name "gitlab-runner")
+ (version "12.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
+ version "/gitlab-runner-v" version ".tar.gz"))
+ (sha256
+ (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
+ (home-page "https://docs.gitlab.com/runner/")
+ (synopsis "GitLab Runner")
+ (description "Gitlab Runner is used to run Gitlab's CI/CD jobs and send
+back the results to Gitlab instance. It is used in conjunction with Gitlab CI.")
+ (license l:expat)))
--
2.24.1
Mathieu Othacehe wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 38827@debbugs.gnu.org)
87tv5ga341.fsf@gmail.com
Toggle quote (3 lines)
> I update the package definition following the above guidelines.
> could you please check if this updated patch is acceptable?

I fixed the indentation, added one space between the two description
sentences and pushed.

Thanks for your contribution,

Mathieu
Mathieu Othacehe wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 38827-done@debbugs.gnu.org)
87sgl0a33g.fsf@gmail.com
and closing!

Mathieu
Closed
Ludovic Courtès wrote 5 years ago
control message for bug #38827
(address . control@debbugs.gnu.org)
87a778xdaq.fsf@gnu.org
reopen 38827
tags 38827 - fixed patch
quit
Ludovic Courtès wrote 5 years ago
Re: [bug#38827] [PATCH] gnu: Add gitlab-runner.
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 38827@debbugs.gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
878smsxd8i.fsf@gnu.org
Hello!

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

Toggle quote (6 lines)
>> I update the package definition following the above guidelines.
>> could you please check if this updated patch is acceptable?
>
> I fixed the indentation, added one space between the two description
> sentences and pushed.

The ‘vendor’ directory contains a large number of bundled dependencies,
including various bits of Docker and Kubernetes. I’m not comfortable
keeping this package as is.

Reza, could you look into unbundling these, or at least a significant
part of these?

There’s a Go importer at
but it’s for ‘Gopkg.toml’ files, which seem to be out of fashion, so I’m
not sure it’d be useful.

In the meantime, I’d be in favor of reverting the patch. WDYT?

Thanks,
Ludo’.
Efraim Flashner wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38827@debbugs.gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20200101122017.GQ23018@E5400
On Wed, Jan 01, 2020 at 12:54:37AM +0100, Ludovic Courtès wrote:
Toggle quote (25 lines)
> Hello!
>
> Mathieu Othacehe <m.othacehe@gmail.com> skribis:
>
> >> I update the package definition following the above guidelines.
> >> could you please check if this updated patch is acceptable?
> >
> > I fixed the indentation, added one space between the two description
> > sentences and pushed.
>
> The ‘vendor’ directory contains a large number of bundled dependencies,
> including various bits of Docker and Kubernetes. I’m not comfortable
> keeping this package as is.
>
> Reza, could you look into unbundling these, or at least a significant
> part of these?
>
> There’s a Go importer at
> <https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00301.html>,
> but it’s for ‘Gopkg.toml’ files, which seem to be out of fashion, so I’m
> not sure it’d be useful.
>
> In the meantime, I’d be in favor of reverting the patch. WDYT?
>

Unfortunately I'm in agreement. I personally would keep in in a channel
until it's been de-vendored.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4Mjn4ACgkQQarn3Mo9
g1HWeg//d0VQ7asB76iZmsz/m8s6hotP2YrHwZ1MGTZQGXZWwHhUs8wVhpjx8+/6
T/X48wYAkzWZ6MWyutfjMjrYG6qLBwGDajRnviAT45dTwX0iZLCAAtw5GwZf1Ss2
gSNmcP5TL2+UPnstnfiN6L+u3YfnuFbRi9cOhxTVSE7mfCeAfGLOlM8h0mg+VIO6
rKluX6lYqlBZdh1KSSuJF7Z2GsyGveSZCs4oDDEc+rRnMMVjOqe4BsGVivinmgMC
VBj2OIYgw4SdJm2QQo8YnRgT+LrhYArh0JQjigrJtDXLyy4L3US+yoQLucY7pmTT
GnJwXN2bQ497G2yQC6EBp+sIsQpxQv1WhzDYchp++eHhho8pNyom8MF8yXimeWn1
jOo7MIg0KAQMlnL9uo9vNSW70RM+xIzstVzke6Fjyf1YwqSV4fEbBKl/hiFmZRzM
DkH/1u3GcHkstgiQfdgHm0ouJEm4ru4J0wEGekycCGyQYeDN6FH6TIsvOTNfwRPT
N/iW/C+KduoY9VdOViQ49pVR4qJRhMCaibZYNUl9Nx+bKl9PyvTJd/iLgw9aaWBO
asQAtciLFuKoS3Lm1vw46XcFo2ABZ9S+c+LCsrGwjKKQgSNOd56G4/VDt7gH/n+M
41iG3i/WuCsnt7Sm+o9mdm2XLtNt3aM6ejdCGNZi42yx4dTDvlo=
=zKCO
-----END PGP SIGNATURE-----


Mathieu Othacehe wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38827@debbugs.gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
877e2b0zt3.fsf@gmail.com
Hey,

Toggle quote (4 lines)
> The ‘vendor’ directory contains a large number of bundled dependencies,
> including various bits of Docker and Kubernetes. I’m not comfortable
> keeping this package as is.

Oops, that's indeed quite problematic. Sorry for not noticing, reverted
until we can find a better way.

Mathieu
r.majd wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38827@debbugs.gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
0f6c602a-8a83-43e9-a827-ee2be66f42a7@email.android.com
Attachment: file
Sharlatan Hellseher wrote 2 months ago
[PATCH] gnu: Add gitlab-runner.
(address . 38827@debbugs.gnu.org)
CAO+9K5rq9mB_XF2yGL+rPtbUe5t5Cfw3xagE04EfLefU=ad8CQ@mail.gmail.com
Hi,

I've started adding each missing dependencies on go-team branch.
They are about 600 to cover the full tree.
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 38827@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38827
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help