gparted segfaults

  • Done
  • quality assurance status badge
Details
5 participants
  • Gábor Boskovits
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • raingloom
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 9 Dec 2019 11:10
(address . bug-guix@gnu.org)
87muc16c8x.fsf@elephly.net
This segfaults:

sudo /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted

Toggle snippet (20 lines)
(gpartedbin:5364): Gdk-CRITICAL **: 11:06:10.219: gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(gpartedbin:5364): GLib-GObject-CRITICAL **: 11:06:10.219: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme icon 'drive-harddisk' for stock: Icon 'drive-harddisk' not present in theme Adwaita

(gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme icon 'image-missing' for stock: Failed to load /org/gtk/libgtk/icons/24x24/status/image-missing.png: Unrecognized image file format
/gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted: line 202: 5364 Segmentation fault $BASE_CMD--8<---------------cut here---------------end--------------->8---

This does not segfault:

sudo -E /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted

The problem here is that when run as root but without the environment of
the current user gparted fails to find the image loader modules.

--
Ricardo
G
G
Gábor Boskovits wrote on 10 Dec 2019 08:38
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 38544@debbugs.gnu.org)
CAE4v=pj5WLKUBD9vJMq_d5LDmeBS48vGmr+LtRr69xq78WVgdg@mail.gmail.com
Hello,

Ricardo Wurmus <rekado@elephly.net> ezt írta (id?pont: 2019. dec. 9., H, 11:11):
Toggle quote (23 lines)
>
> This segfaults:
>
> sudo /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted
>
> --8<---------------cut here---------------start------------->8---
> …
> (gpartedbin:5364): Gdk-CRITICAL **: 11:06:10.219: gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed
>
> (gpartedbin:5364): GLib-GObject-CRITICAL **: 11:06:10.219: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
>
> (gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme icon 'drive-harddisk' for stock: Icon 'drive-harddisk' not present in theme Adwaita
>
> (gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme icon 'image-missing' for stock: Failed to load /org/gtk/libgtk/icons/24x24/status/image-missing.png: Unrecognized image file format
> /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted: line 202: 5364 Segmentation fault $BASE_CMD--8<---------------cut here---------------end--------------->8---
>
> This does not segfault:
>
> sudo -E /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-1.0.0/bin/gparted
>
> The problem here is that when run as root but without the environment of
> the current user gparted fails to find the image loader modules.

Yes, I concur.

I believe this affects multiple packages, but as it is rarely needed
to run them with sudo this did not become apparent. Question is what
needs to be done here. I would say if it is ok to run these with sudo
-E, then we could work it around by documenting this, but the proper
solution would be to ensure that these modules are found.

Toggle quote (8 lines)
>
> --
> Ricardo
>
>
>
>

Best regards,
g_bor
--
OpenPGP Key Fingerprint: 7988:3B9F:7D6A:4DBF:3719:0367:2506:A96C:CF63:0B21
R
R
raingloom wrote on 4 Jan 2020 19:35
f3c34fa9e28cd9543bd148ae32d6cb9b7fdbdd2f.camel@riseup.net
On Mon, 2019-12-09 at 11:10 +0100, Ricardo Wurmus wrote:
Toggle quote (39 lines)
> This segfaults:
>
> sudo /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-
> 1.0.0/bin/gparted
>
> --8<---------------cut here---------------start------------->8---
> …
> (gpartedbin:5364): Gdk-CRITICAL **: 11:06:10.219:
> gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF
> (pixbuf)' failed
>
> (gpartedbin:5364): GLib-GObject-CRITICAL **: 11:06:10.219:
> g_object_unref: assertion 'G_IS_OBJECT (object)' failed
>
> (gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme
> icon 'drive-harddisk' for stock: Icon 'drive-harddisk' not present in
> theme Adwaita
>
> (gpartedbin:5364): Gtk-WARNING **: 11:06:10.273: Error loading theme
> icon 'image-missing' for stock: Failed to load
> /org/gtk/libgtk/icons/24x24/status/image-missing.png: Unrecognized
> image file format
> /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-
> 1.0.0/bin/gparted: line 202: 5364 Segmentation fault $BASE_CMD-
> -8<---------------cut here---------------end--------------->8---
>
> This does not segfault:
>
> sudo -E /gnu/store/yzxyxnxja4y1riwh3mrqrvb7h4vhxlqb-gparted-
> 1.0.0/bin/gparted
>
> The problem here is that when run as root but without the environment
> of
> the current user gparted fails to find the image loader modules.
>
> --
> Ricardo


I tried fixing this by adding the wrapper step from glib-or-gtk but
that didn't do anything.
T
T
Tobias Geerinckx-Rice wrote on 14 Jul 2020 15:50
[PATCH] gnu: gparted: Use the Glib-or-GTK build system.
(address . 38544@debbugs.gnu.org)
20200714135019.25283-1-me@tobias.gr

* gnu/packages/disk.scm (gparted)[build-system]: Use
glib-or-gtk-build-system.
---

raingloom ???
Toggle quote (3 lines)
> I tried fixing this by adding the wrapper step from glib-or-gtk but
> that didn't do anything.

Strange, this works for me (after a pointless detour writing a custom wrap phase with shared-mime-info et al):

gnu/packages/disk.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index a5278d8c8c..6d812f560c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
@@ -432,7 +433,7 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
version "/gparted-" version ".tar.gz"))
(sha256
(base32 "092rgwjh1825fal6v3yafq2wr0i61hh0a2n0j4296zn0zdx7pzp2"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(arguments
;; Tests require access to paths outside the build container, such
;; as '/dev/disk/by-id'
--
2.27.0
L
L
Ludovic Courtès wrote on 16 Jul 2020 12:07
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
87eepb7oy4.fsf@gnu.org
Hi,

Tobias Geerinckx-Rice via Bug reports for GNU Guix <bug-guix@gnu.org>
skribis:

Toggle quote (5 lines)
>
> * gnu/packages/disk.scm (gparted)[build-system]: Use
> glib-or-gtk-build-system.

Makes sense, LGTM!

Ludo’.
T
T
Tobias Geerinckx-Rice wrote on 16 Jul 2020 20:18
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38544-done@debbugs.gnu.org)
874kq7pbm0.fsf@nckx
Ludovic Courtès ???
Toggle quote (7 lines)
>>
>> * gnu/packages/disk.scm (gparted)[build-system]: Use
>> glib-or-gtk-build-system.
>
> Makes sense, LGTM!

Thanks! Pushed.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXxCZ9wAKCRANsP+IT1Vt
eQYyAP9aGyipgiB5IgWHfzWrABWW+QEJm9SUZeViw00Czv6luAD/ZuGFClafE5qh
q7TcYh0M9t18Bx2QuSzCaTasqvTKUgY=
=jt5n
-----END PGP SIGNATURE-----

Closed
?