(address . bug-guix@gnu.org)
I just had `guix package` crash while downloading substitutes from an
nginx mirror. The command succeeded when I ran it again.
------
$ guix describe
Generation 106 Dec 04 2019 10:41:03 (current)
guix 8548b3d
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 8548b3dd87a795f850a97add59fd87ec5f49f092
GUIX_PACKAGE_PATH="/home/leo/pkgs"
------
------
$ guix package -u . --do-not-upgrade=blender --do-not-upgrade=audacity
substitution of /gnu/store/gfpiq0nnv7wrbq5mdydyj5lkwa4hbbxk-ghc-8.6.5 complete
substitution of /gnu/store/5lxzblrjzaw5rmjcb263zszvzx46bdw5-mono-4.4.1.0 complete
openjdk-12.33-jdk 157.2MiB 784KiB/s 01:36 [######## ] 46.9%Backtrace:
In ice-9/boot-9.scm:
829:9 19 (catch _ _ #<procedure 7f903cb97380 at guix/ui.scm:650…> …)
829:9 18 (catch _ _ #<procedure 7f903cb97398 at guix/ui.scm:773…> …)
In guix/scripts/package.scm:
943:10 17 (_)
In guix/status.scm:
768:4 16 (call-with-status-report _ _)
In guix/scripts/package.scm:
951:14 15 (_)
In guix/build/syscalls.scm:
1142:4 14 (call-with-file-lock/no-wait _ _ _)
In guix/scripts/package.scm:
889:21 13 (_)
601:4 12 (options->installable ((do-not-upgrade . "audacity") …) …)
In srfi/srfi-1.scm:
466:18 11 (fold #<procedure 7f903ac7ff60 at guix/scripts/package…> …)
In guix/scripts/package.scm:
245:39 10 (transaction-upgrade-entry _ #<<manifest-transaction> i…>)
In guix/packages.scm:
948:16 9 (cache! #<weak-table 1709/3517> #<package diffoscope@1…> …)
In guix/grafts.scm:
323:4 8 (graft-derivation #<store-connection 256.99 7f903e80fa…> …)
172:4 7 (references-oracle #<store-connection 256.99 7f903e80f…> …)
182:20 6 (_ _ _)
In guix/store.scm:
1222:15 5 (_ #<store-connection 256.99 7f903e80fae0> _ _)
718:13 4 (process-stderr _ _)
In unknown file:
3 (display "@ substituter-succeeded /gnu/store/azd3rg350…" …)
In guix/status.scm:
691:16 2 (write! _ _ _)
605:6 1 (_ (download-progress "/gnu/store/7i0vxbrjcrib4aw20…" …) …)
In guix/progress.scm:
219:14 0 (display-download-progress "7i0vxbrjcrib4aw20bdawz4q96…" …)
guix/progress.scm:219:14: In procedure display-download-progress:
In procedure =: Wrong type: #f
------