reposurgeon build is broken

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 4 Dec 2018 17:47
(address . bug-guix@gnu.org)
20181204174737.13f89fda@scratchpost.org
class OrderedSet(collections.MutableSet):
=== Testing mailbox-out/mailbox-in roundtripping:
authormatch.fi
/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon:13680: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working
class OrderedSet(collections.MutableSet):
Traceback (most recent call last):
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 1585, in f
if len(cache) <= pos: cache.append(next(it))
StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 13800, in <module>
main()
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 13790, in main
cmd.Cmd.onecmd(interpreter, interpreter.precmd(arg))
File "/gnu/store/b7fqhszxl02g6pfm3vw6b3cjz472qrly-python-3.7.0/lib/python3.7/cmd.py", line 217, in onecmd
return func(arg)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 10761, in do_edit
self.edit(self.selection, line)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 9339, in edit
self.do_mailbox_in("<" + tfname)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 10580, in do_mailbox_in
for commit in self.chosen().commits():
RuntimeError: generator raised StopIteration
make[2]: *** [Makefile:90: mailboxing] Error 1
make[1]: *** [Makefile:24: default] Error 2
make: *** [Makefile:120: check] Error 2

Test suite failed, dumping logs.
Backtrace:
4 (primitive-load "/gnu/store/k4qpksv3j8yljcb89lc228h78l6â¦")
In ice-9/eval.scm:
191:35 3 (_ _)
In srfi/srfi-1.scm:
863:16 2 (every1 #<procedure 80f2c0 at /gnu/store/gfprsx2m62cvqâ¦> â¦)
In /gnu/store/gfprsx2m62cvqbh7ysc9ay9slhijvmal-module-import/guix/build/gnu-build-system.scm:
799:28 1 (_ _)
369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)

/gnu/store/gfprsx2m62cvqbh7ysc9ay9slhijvmal-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("check" "-j" "4" "ECHO=echo" "target=/gnu/store/0n2bv0yajwi7a8p3dg390i974ja2ldhl-reposurgeon-3.43") exit-status: 2 term-signal: #f stop-signal: #f] 96ca80>)'.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlwGr6kACgkQ5xo1VCww
uqVJPwf6AoFVDgIkAVBJ4a+QllQBxJ8YhF7D126KpHSiyaHb6XC3bs3IZbauJ1kO
t+0rOw40vTn3DZi1IpzmxeHVIXXuG/uXI3FrPX+KCvP62A/hkNQH+6/NAETGp+O4
Mw309x82bbs17jfPwgddR/OLLJRJl1QKUp8pnfukC5JWQaXt0ZTEcHX0FcUp5tAa
znLloqkJHk/7xJuPMiXQvL++4YK1tiknW3w0brlaB+Kzvl1iO5BMhTxWwK10aRee
04bjT3Qiz/j4R7gKLCDArHw4d3JqLqaHt0AaPsRh/pOXjrGmhUAeU7Wv9vrqRQWs
ebu5eAlyrjuc2cB6Wt7dOfsYcxE+pQ==
=aydu
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 3 Dec 2021 11:11
control message for bug #33614
(address . control@debbugs.gnu.org)
86a6him20c.fsf@gmail.com
tags 33614 + easy
quit
M
M
Maxim Cournoyer wrote on 13 Jul 2022 15:22
Re: bug#33614: reposurgeon build is broken
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 33614@debbugs.gnu.org)
87v8s1170z.fsf@gmail.com
Hi,

I tried updating reposurgeon to see if I could get that resolved, but
reposurgeon is now a Go module, so we'd need to change the build system
and perhaps add a couple supporting Go modules.

Would you like to take a look?

Thanks,

Maxim
Z
Z
zimoun wrote on 17 Oct 2022 22:09
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
8635bm1ab0.fsf@gmail.com
Hi,

On Wed, 13 Jul 2022 at 09:22, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (6 lines)
> I tried updating reposurgeon to see if I could get that resolved, but
> reposurgeon is now a Go module, so we'd need to change the build system
> and perhaps add a couple supporting Go modules.
>
> Would you like to take a look?

reposurgeon is broken since a while; [1] is reported on Dec. 2018.

Since no one care enough this package, I am propose to close this issue
by simply removing the package. WDYT?




Cheers,
simon
M
M
Maxim Cournoyer wrote on 17 Oct 2022 23:16
(name . zimoun)(address . zimon.toutoune@gmail.com)
87pmeqxi9r.fsf@gmail.com
Hi,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (15 lines)
> Hi,
>
> On Wed, 13 Jul 2022 at 09:22, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> I tried updating reposurgeon to see if I could get that resolved, but
>> reposurgeon is now a Go module, so we'd need to change the build system
>> and perhaps add a couple supporting Go modules.
>>
>> Would you like to take a look?
>
> reposurgeon is broken since a while; [1] is reported on Dec. 2018.
>
> Since no one care enough this package, I am propose to close this issue
> by simply removing the package. WDYT?

I'm fine with it. I tried updating it, but it is now written in Go and
would require packaging a few new Go packages; the list is here [0].


--
Thanks,
Maxim
Z
Z
zimoun wrote on 21 Jan 2023 17:01
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
86ilgz3mhn.fsf@gmail.com
Hi Maxim,

On Mon, 17 Oct 2022 at 17:16, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (7 lines)
>> Since no one care enough this package, I am propose to close this issue
>> by simply removing the package. WDYT?
>
> I'm fine with it. I tried updating it, but it is now written in Go and
> would require packaging a few new Go packages; the list is here [0].


Please find attach the removal. Once applied, feel free to close this
report.

Cheers,
simon
From d10833d01e9d19595ad186ff434f8dd4889d018d Mon Sep 17 00:00:00 2001
From: Simon Tournier <zimon.toutoune@gmail.com>
Date: Sat, 21 Jan 2023 16:56:46 +0100
Subject: [PATCH] gnu: Remove reposurgeon.

This package is broken since 2018 and an update requires Go modules.

* gnu/packages/version-control.scm (reposurgeon): Delete variable.
---
gnu/packages/version-control.scm | 76 --------------------------------
1 file changed, 76 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ff2fccef0c..78a89cfd5b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2399,82 +2399,6 @@ (define-public aegis
any project with more than one developer, is one of Aegis's major functions.")
(license license:gpl3+)))
-(define-public reposurgeon
- (package
- (name "reposurgeon")
- (version "3.43")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.catb.org/~esr/" name "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1af0z14wcm4bk5a9ysinbwq2fp3lf5f7i8mvwh7286hr3fnagcaz"))
- (patches (search-patches
- "reposurgeon-add-missing-docbook-files.patch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags
- (list "ECHO=echo"
- (string-append "target=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-inputs
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- (substitute* "reposurgeon"
- (("/usr/share/zoneinfo")
- (string-append tzdata "/share/zoneinfo")))
- (substitute* "test/svn-to-svn"
- (("/bin/echo") "echo"))
- #t)))
- (delete 'configure) ; no configure script
- (add-before 'build 'fix-docbook
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "." "\\.xml$")
- (("docbook/docbookx.dtd")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/docbookx.dtd")))
- #t))
- (add-before 'check 'set-up-test-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- (setenv "TZDIR" (string-append tzdata "/share/zoneinfo"))
- #t)))
- (add-after 'install 'install-emacs-data
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "reposurgeon-mode.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
- #t)))))
- (inputs
- `(("python" ,python-wrapper)
- ("tzdata" ,tzdata)))
- (native-inputs
- (list ;; For building documentation.
- asciidoc
- docbook-xml
- docbook-xsl
- libxml2
- xmlto
- ;; For tests.
- cvs
- git
- mercurial
- subversion))
- (home-page "http://www.catb.org/~esr/reposurgeon/")
- (synopsis "Edit version-control repository history")
- (description "Reposurgeon enables risky operations that version-control
-systems don't want to let you do, such as editing past comments and metadata
-and removing commits. It works with any version control system that can
-export and import Git fast-import streams, including Git, Mercurial, Fossil,
-Bazaar, CVS, RCS, and Src. It can also read Subversion dump files directly
-and can thus be used to script production of very high-quality conversions
-from Subversion to any supported Distributed Version Control System (DVCS).")
- ;; Most files are distributed under bsd-2, except 'repocutter' which is
- ;; under bsd-3.
- (license (list license:bsd-2 license:bsd-3))))
-
(define-public tig
(package
(name "tig")
--
2.38.1
M
M
Maxim Cournoyer wrote on 21 Jan 2023 21:08
(name . zimoun)(address . zimon.toutoune@gmail.com)
87v8kz1why.fsf@gmail.com
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (14 lines)
> Hi Maxim,
>
> On Mon, 17 Oct 2022 at 17:16, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>>> Since no one care enough this package, I am propose to close this issue
>>> by simply removing the package. WDYT?
>>
>> I'm fine with it. I tried updating it, but it is now written in Go and
>> would require packaging a few new Go packages; the list is here [0].
>
>
> Please find attach the removal. Once applied, feel free to close this
> report.

Applied!

--
Thanks,
Maxim
Closed
?