(address . bug-guix@gnu.org)
class OrderedSet(collections.MutableSet):
=== Testing mailbox-out/mailbox-in roundtripping:
authormatch.fi
/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon:13680: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working
class OrderedSet(collections.MutableSet):
Traceback (most recent call last):
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 1585, in f
if len(cache) <= pos: cache.append(next(it))
StopIteration
The above exception was the direct cause of the following exception:
Traceback (most recent call last):
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 13800, in <module>
main()
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 13790, in main
cmd.Cmd.onecmd(interpreter, interpreter.precmd(arg))
File "/gnu/store/b7fqhszxl02g6pfm3vw6b3cjz472qrly-python-3.7.0/lib/python3.7/cmd.py", line 217, in onecmd
return func(arg)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 10761, in do_edit
self.edit(self.selection, line)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 9339, in edit
self.do_mailbox_in("<" + tfname)
File "/tmp/guix-build-reposurgeon-3.43.drv-0/reposurgeon-3.43/reposurgeon", line 10580, in do_mailbox_in
for commit in self.chosen().commits():
RuntimeError: generator raised StopIteration
make[2]: *** [Makefile:90: mailboxing] Error 1
make[1]: *** [Makefile:24: default] Error 2
make: *** [Makefile:120: check] Error 2
Test suite failed, dumping logs.
Backtrace:
4 (primitive-load "/gnu/store/k4qpksv3j8yljcb89lc228h78l6â¦")
In ice-9/eval.scm:
191:35 3 (_ _)
In srfi/srfi-1.scm:
863:16 2 (every1 #<procedure 80f2c0 at /gnu/store/gfprsx2m62cvqâ¦> â¦)
In /gnu/store/gfprsx2m62cvqbh7ysc9ay9slhijvmal-module-import/guix/build/gnu-build-system.scm:
799:28 1 (_ _)
369:6 0 (check #:target _ #:make-flags _ #:tests? _ # _ # _ # _)
/gnu/store/gfprsx2m62cvqbh7ysc9ay9slhijvmal-module-import/guix/build/gnu-build-system.scm:369:6: In procedure check:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("check" "-j" "4" "ECHO=echo" "target=/gnu/store/0n2bv0yajwi7a8p3dg390i974ja2ldhl-reposurgeon-3.43") exit-status: 2 term-signal: #f stop-signal: #f] 96ca80>)'.
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlwGr6kACgkQ5xo1VCww
uqVJPwf6AoFVDgIkAVBJ4a+QllQBxJ8YhF7D126KpHSiyaHb6XC3bs3IZbauJ1kO
t+0rOw40vTn3DZi1IpzmxeHVIXXuG/uXI3FrPX+KCvP62A/hkNQH+6/NAETGp+O4
Mw309x82bbs17jfPwgddR/OLLJRJl1QKUp8pnfukC5JWQaXt0ZTEcHX0FcUp5tAa
znLloqkJHk/7xJuPMiXQvL++4YK1tiknW3w0brlaB+Kzvl1iO5BMhTxWwK10aRee
04bjT3Qiz/j4R7gKLCDArHw4d3JqLqaHt0AaPsRh/pOXjrGmhUAeU7Wv9vrqRQWs
ebu5eAlyrjuc2cB6Wt7dOfsYcxE+pQ==
=aydu
-----END PGP SIGNATURE-----