pypi importer uses incorrect package names

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
Merged with
J
J
Julien Lepiller wrote on 15 Oct 2018 15:43
(address . bug-guix@gnu.org)
e5965fe7462e7825cfe61169762a3562@lepiller.eu
Hi,

I found that sometimes the pypi importer had trouble importing packages
correctly. For instance, running "guix import pypi txaio" gave me this
list of dependencies:

(propagated-inputs
`(("python-[all]" ,#{python-\x5b;all\x5d;}#)
("python-[asyncio]"
,#{python-\x5b;asyncio\x5d;}#)
...))

guix import pypi magic-wormhole had this:

(propagated-inputs
("python-autobahn[twisted]"
,#{python-autobahn\x5b;twisted\x5d;}#)
...))

Of course, they break the recursive importer, which makes it difficult
to import these packages correctly.
M
M
Maxim Cournoyer wrote on 21 Mar 2019 19:41
control message for bug #34266
(address . control@debbugs.gnu.org)
87mulo9ikg.fsf@gmail.com
forcemerge 34266 33047
T
T
T460s laptop wrote on 28 Mar 2019 05:32
control message for bug #33047
(address . control@debbugs.gnu.org)
871s2r7h68.fsf@kwak.i-did-not-set--mail-host-address--so-tickle-me
merge 33047 24450
M
M
Maxim Cournoyer wrote on 28 Mar 2019 05:37
control message for bug #33569
(address . control@debbugs.gnu.org)
875zs362dt.fsf@gmail.com
forcemerge 33569 24450
M
M
Maxim Cournoyer wrote on 29 Mar 2019 05:23
Re: bug#33047: pypi importer uses incorrect package names
(name . Julien Lepiller)(address . julien@lepiller.eu)
87mule2tso.fsf@gmail.com
Julien Lepiller <julien@lepiller.eu> writes:

Toggle quote (22 lines)
> Hi,
>
> I found that sometimes the pypi importer had trouble importing
> packages correctly. For instance, running "guix import pypi txaio"
> gave me this list of dependencies:
>
> (propagated-inputs
> `(("python-[all]" ,#{python-\x5b;all\x5d;}#)
> ("python-[asyncio]"
> ,#{python-\x5b;asyncio\x5d;}#)
> ...))
>
> guix import pypi magic-wormhole had this:
>
> (propagated-inputs
> ("python-autobahn[twisted]"
> ,#{python-autobahn\x5b;twisted\x5d;}#)
> ...))
>
> Of course, they break the recursive importer, which makes it difficult
> to import these packages correctly.

Testing local branch:

./pre-inst-env guix import pypi txaio

Starting download of /tmp/guix-file.jTNBQz
…8.1.tar.gz 50KiB 894KiB/s 00:00 [##################] 100.0%

Starting download of /tmp/guix-file.ZB3Q2n
….py3-none-any.whl 27KiB 746KiB/s 00:00 [##################] 100.0%
(package
(name "python-txaio")
(version "18.8.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "txaio" version))
(sha256
(base32
"1zmpdph6zddgrnkkcykh6qk5s46l7s5mzfqrh82m4b5iffn61qv7"))))
(build-system python-build-system)
(propagated-inputs `(("python-six" ,python-six)))
(native-inputs
`(("python-mock" ,python-mock)
("python-pep8" ,python-pep8)
("python-pyenchant" ,python-pyenchant)
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-sphinx" ,python-sphinx)
("python-sphinx-rtd-theme"
,python-sphinx-rtd-theme)
("python-sphinxcontrib-spelling"
,python-sphinxcontrib-spelling)
("python-tox" ,python-tox)
("python-twine" ,python-twine)
("python-wheel" ,python-wheel)))
(synopsis
"Compatibility API between asyncio/Twisted/Trollius")
(description
"Compatibility API between asyncio/Twisted/Trollius")
(license #f))

and

./pre-inst-env guix import pypi magic-wormhole

Starting download of /tmp/guix-file.80RRqk
…-0.11.2.tar.gz 193KiB 911KiB/s 00:00 [##################] 100.0%

Starting download of /tmp/guix-file.mRGAx3
…-py2.py3-none-any.whl 128KiB 1009KiB/s 00:00 [##################] 100.0%
(package
(name "python-magic-wormhole")
(version "0.11.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "magic-wormhole" version))
(sha256
(base32
"01fr4bi6kc6fz9n3c4qq892inrc3nf6p2djy65yvm7xkvdxncydf"))))
(build-system python-build-system)
(propagated-inputs
`(("python-attrs" ,python-attrs)
("python-autobahn" ,python-autobahn)
("python-automat" ,python-automat)
("python-click" ,python-click)
("python-hkdf" ,python-hkdf)
("python-humanize" ,python-humanize)
("python-pynacl" ,python-pynacl)
("python-pywin32" ,python-pywin32)
("python-six" ,python-six)
("python-spake2" ,python-spake2)
("python-tqdm" ,python-tqdm)
("python-twisted" ,python-twisted)
("python-txtorcon" ,python-txtorcon)))
(native-inputs
`(("python-magic-wormhole-mailbox-server"
,python-magic-wormhole-mailbox-server)
("python-magic-wormhole-transit-relay"
,python-magic-wormhole-transit-relay)
("python-mock" ,python-mock)
("python-pyflakes" ,python-pyflakes)
("python-tox" ,python-tox)))
(home-page
(synopsis
"Securely transfer data between computers")
(description
"Securely transfer data between computers")
(license license:expat))
T
T
T460s laptop wrote on 30 Mar 2019 03:15
control message for bug #24450
(address . control@debbugs.gnu.org)
875zs15cq0.fsf@kwak.i-did-not-set--mail-host-address--so-tickle-me
forcemerge 24450 24557
M
M
Maxim Cournoyer wrote on 31 Mar 2019 16:41
(address . control@debbugs.gnu.org)
87ef6n2jiz.fsf@gmail.com
tags 24450 patch
?