pypi importer cannot handle [ and ] correctly

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • swedebugia
Owner
unassigned
Submitted by
swedebugia
Severity
normal
Merged with
S
S
swedebugia wrote on 31 Jan 2019 19:25
(name . Report new Guix bug)(address . bug-guix@gnu.org)
b67ec137-b642-2e1c-7648-702ae7a2cf4f@riseup.net
$ ./pre-inst-env guix import pypi beaker

following redirection to `https://pypi.org/pypi/Beaker/json'...

Starting download of /tmp/guix-file.p15GJZ
From
...0.0.tar.gz 40KiB 521KiB/s 00:00
[##################] 100.0%
(package
(name "python-beaker")
(version "1.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beaker" version))
(sha256
(base32
"0l047yl3n9b3w7ba0wrqdb5fpww5y8pjy20kah2mlpr230lqjwk0"))))
(build-system python-build-system)
(propagated-inputs
`(("python-[crypto]" ,#{python-\x5b;crypto\x5d;}#)
("python-[cryptography]"
,#{python-\x5b;cryptography\x5d;}#)
("python-[pycrypto]"
,#{python-\x5b;pycrypto\x5d;}#)
("python-[pycryptodome]"
,#{python-\x5b;pycryptodome\x5d;}#)
("python-[testsuite]"
,#{python-\x5b;testsuite\x5d;}#)
("python-coverage" ,python-coverage)
("python-cryptography" ,python-cryptography)
("python-cryptography" ,python-cryptography)
("python-funcsigs" ,python-funcsigs)
("python-memcached" ,python-memcached)
("python-mock" ,python-mock)
("python-nose" ,python-nose)
("python-pycrypto" ,python-pycrypto)
("python-pycryptodome" ,python-pycryptodome)
("python-pycryptodome" ,python-pycryptodome)
("python-pycryptopp" ,python-pycryptopp)
("python-pylibmc" ,python-pylibmc)
("python-pymongo" ,python-pymongo)
("python-redis" ,python-redis)
("python-sqlalchemy" ,python-sqlalchemy)
("python-webtest" ,python-webtest)))
(synopsis
"A Session and Caching library with WSGI Middleware")
(description
"A Session and Caching library with WSGI Middleware")
(license license:bsd-3))
M
M
Maxim Cournoyer wrote on 21 Mar 2019 19:35
control message for bug #34266
(address . control@debbugs.gnu.org)
87o9649itj.fsf@gmail.com
forcemerge 34266 33569
M
M
Maxim Cournoyer wrote on 21 Mar 2019 19:41
(address . control@debbugs.gnu.org)
87mulo9ikg.fsf@gmail.com
forcemerge 34266 33047
T
T
T460s laptop wrote on 28 Mar 2019 05:32
control message for bug #33047
(address . control@debbugs.gnu.org)
871s2r7h68.fsf@kwak.i-did-not-set--mail-host-address--so-tickle-me
merge 33047 24450
M
M
Maxim Cournoyer wrote on 28 Mar 2019 05:37
control message for bug #33569
(address . control@debbugs.gnu.org)
875zs362dt.fsf@gmail.com
forcemerge 33569 24450
M
M
Maxim Cournoyer wrote on 29 Mar 2019 05:19
Re: bug#34266: pypi importer cannot handle [ and ] correctly
(name . swedebugia)(address . swedebugia@riseup.net)
87va022tz3.fsf@gmail.com
swedebugia <swedebugia@riseup.net> writes:

Toggle quote (53 lines)
> $ ./pre-inst-env guix import pypi beaker
>
> following redirection to `https://pypi.org/pypi/Beaker/json'...
>
> Starting download of /tmp/guix-file.p15GJZ
> From
> https://files.pythonhosted.org/packages/c2/21/b052b2fbfee3def06670923d5d34b0d353d4c278013e4a714c3fb663f150/Beaker-1.10.0.tar.gz...
> ...0.0.tar.gz 40KiB 521KiB/s 00:00
> [##################] 100.0%
> (package
> (name "python-beaker")
> (version "1.10.0")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "beaker" version))
> (sha256
> (base32
> "0l047yl3n9b3w7ba0wrqdb5fpww5y8pjy20kah2mlpr230lqjwk0"))))
> (build-system python-build-system)
> (propagated-inputs
> `(("python-[crypto]" ,#{python-\x5b;crypto\x5d;}#)
> ("python-[cryptography]"
> ,#{python-\x5b;cryptography\x5d;}#)
> ("python-[pycrypto]"
> ,#{python-\x5b;pycrypto\x5d;}#)
> ("python-[pycryptodome]"
> ,#{python-\x5b;pycryptodome\x5d;}#)
> ("python-[testsuite]"
> ,#{python-\x5b;testsuite\x5d;}#)
> ("python-coverage" ,python-coverage)
> ("python-cryptography" ,python-cryptography)
> ("python-cryptography" ,python-cryptography)
> ("python-funcsigs" ,python-funcsigs)
> ("python-memcached" ,python-memcached)
> ("python-mock" ,python-mock)
> ("python-nose" ,python-nose)
> ("python-pycrypto" ,python-pycrypto)
> ("python-pycryptodome" ,python-pycryptodome)
> ("python-pycryptodome" ,python-pycryptodome)
> ("python-pycryptopp" ,python-pycryptopp)
> ("python-pylibmc" ,python-pylibmc)
> ("python-pymongo" ,python-pymongo)
> ("python-redis" ,python-redis)
> ("python-sqlalchemy" ,python-sqlalchemy)
> ("python-webtest" ,python-webtest)))
> (home-page "https://beaker.readthedocs.io/")
> (synopsis
> "A Session and Caching library with WSGI Middleware")
> (description
> "A Session and Caching library with WSGI Middleware")
> (license license:bsd-3))

Testing with my soon-to-be sent for review changes:

Toggle snippet (37 lines)
./pre-inst-env guix import pypi beaker
following redirection to `https://pypi.org/pypi/Beaker/json'...

Starting download of /tmp/guix-file.0MWu4B
From https://files.pythonhosted.org/packages/76/87/ecc1a222f0caaa7ba7b8928737e89b2e91b8c22450c12b8a51ee625a4d87/Beaker-1.10.1.tar.gz...
…0.1.tar.gz 40KiB 487KiB/s 00:00 [##################] 100.0%
(package
(name "python-beaker")
(version "1.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beaker" version))
(sha256
(base32
"16zdjfl8v73yl1capph0n371vd26c7zpzb48n505ip32ffgmvc4f"))))
(build-system python-build-system)
(native-inputs
`(("python-coverage" ,python-coverage)
("python-cryptography" ,python-cryptography)
("python-memcached" ,python-memcached)
("python-mock" ,python-mock)
("python-nose" ,python-nose)
("python-pycryptodome" ,python-pycryptodome)
("python-pylibmc" ,python-pylibmc)
("python-pymongo" ,python-pymongo)
("python-redis" ,python-redis)
("python-sqlalchemy" ,python-sqlalchemy)
("python-webtest" ,python-webtest)))
(home-page "https://beaker.readthedocs.io/")
(synopsis
"A Session and Caching library with WSGI Middleware")
(description
"A Session and Caching library with WSGI Middleware")
(license license:bsd-3))

Looking better?

Maxim
T
T
T460s laptop wrote on 30 Mar 2019 03:15
control message for bug #24450
(address . control@debbugs.gnu.org)
875zs15cq0.fsf@kwak.i-did-not-set--mail-host-address--so-tickle-me
forcemerge 24450 24557
S
S
swedebugia wrote on 30 Mar 2019 08:59
Re: bug#34266: pypi importer cannot handle [ and ] correctly
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
991a432d-e5b8-88cd-ee47-bb60af1a8dbe@riseup.net
On 2019-03-29 05:19, Maxim Cournoyer wrote:
Toggle quote (97 lines)
> swedebugia <swedebugia@riseup.net> writes:
>
>> $ ./pre-inst-env guix import pypi beaker
>>
>> following redirection to `https://pypi.org/pypi/Beaker/json'...
>>
>> Starting download of /tmp/guix-file.p15GJZ
>> From
>> https://files.pythonhosted.org/packages/c2/21/b052b2fbfee3def06670923d5d34b0d353d4c278013e4a714c3fb663f150/Beaker-1.10.0.tar.gz...
>> ...0.0.tar.gz 40KiB 521KiB/s 00:00
>> [##################] 100.0%
>> (package
>> (name "python-beaker")
>> (version "1.10.0")
>> (source
>> (origin
>> (method url-fetch)
>> (uri (pypi-uri "beaker" version))
>> (sha256
>> (base32
>> "0l047yl3n9b3w7ba0wrqdb5fpww5y8pjy20kah2mlpr230lqjwk0"))))
>> (build-system python-build-system)
>> (propagated-inputs
>> `(("python-[crypto]" ,#{python-\x5b;crypto\x5d;}#)
>> ("python-[cryptography]"
>> ,#{python-\x5b;cryptography\x5d;}#)
>> ("python-[pycrypto]"
>> ,#{python-\x5b;pycrypto\x5d;}#)
>> ("python-[pycryptodome]"
>> ,#{python-\x5b;pycryptodome\x5d;}#)
>> ("python-[testsuite]"
>> ,#{python-\x5b;testsuite\x5d;}#)
>> ("python-coverage" ,python-coverage)
>> ("python-cryptography" ,python-cryptography)
>> ("python-cryptography" ,python-cryptography)
>> ("python-funcsigs" ,python-funcsigs)
>> ("python-memcached" ,python-memcached)
>> ("python-mock" ,python-mock)
>> ("python-nose" ,python-nose)
>> ("python-pycrypto" ,python-pycrypto)
>> ("python-pycryptodome" ,python-pycryptodome)
>> ("python-pycryptodome" ,python-pycryptodome)
>> ("python-pycryptopp" ,python-pycryptopp)
>> ("python-pylibmc" ,python-pylibmc)
>> ("python-pymongo" ,python-pymongo)
>> ("python-redis" ,python-redis)
>> ("python-sqlalchemy" ,python-sqlalchemy)
>> ("python-webtest" ,python-webtest)))
>> (home-page "https://beaker.readthedocs.io/")
>> (synopsis
>> "A Session and Caching library with WSGI Middleware")
>> (description
>> "A Session and Caching library with WSGI Middleware")
>> (license license:bsd-3))
>
> Testing with my soon-to-be sent for review changes:
>
> --8<---------------cut here---------------start------------->8---
> ./pre-inst-env guix import pypi beaker
> following redirection to `https://pypi.org/pypi/Beaker/json'...
>
> Starting download of /tmp/guix-file.0MWu4B
> From https://files.pythonhosted.org/packages/76/87/ecc1a222f0caaa7ba7b8928737e89b2e91b8c22450c12b8a51ee625a4d87/Beaker-1.10.1.tar.gz...
> …0.1.tar.gz 40KiB 487KiB/s 00:00 [##################] 100.0%
> (package
> (name "python-beaker")
> (version "1.10.1")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "beaker" version))
> (sha256
> (base32
> "16zdjfl8v73yl1capph0n371vd26c7zpzb48n505ip32ffgmvc4f"))))
> (build-system python-build-system)
> (native-inputs
> `(("python-coverage" ,python-coverage)
> ("python-cryptography" ,python-cryptography)
> ("python-memcached" ,python-memcached)
> ("python-mock" ,python-mock)
> ("python-nose" ,python-nose)
> ("python-pycryptodome" ,python-pycryptodome)
> ("python-pylibmc" ,python-pylibmc)
> ("python-pymongo" ,python-pymongo)
> ("python-redis" ,python-redis)
> ("python-sqlalchemy" ,python-sqlalchemy)
> ("python-webtest" ,python-webtest)))
> (home-page "https://beaker.readthedocs.io/")
> (synopsis
> "A Session and Caching library with WSGI Middleware")
> (description
> "A Session and Caching library with WSGI Middleware")
> (license license:bsd-3))
> --8<---------------cut here---------------end--------------->8---
>
> Looking better?

Perfect!

--
Cheers Swedebugia
Attachment: signature.asc
M
M
Maxim Cournoyer wrote on 31 Mar 2019 16:41
control message for bug #24450
(address . control@debbugs.gnu.org)
87ef6n2jiz.fsf@gmail.com
tags 24450 patch
?