(address . bug-guix@gnu.org)
I noticed this a while ago but probably won't get around to fixing it, so I'm just posting a bug report.
-------------------------------------
b@ui ~$ sudo mount -t ecryptfs encrypted-dir mount-dir
Passphrase:
Select cipher:
[...]
Selection [aes]:
Select key bytes:
1) 16
2) 32
3) 24
Selection [16]:
Enable plaintext passthrough (y/n) [n]:
Enable filename encryption (y/n) [n]: y
Filename Encryption Key (FNEK) Signature [...]:
Attempting to mount with the following options:
ecryptfs_unlink_sigs
ecryptfs_fnek_sig=[...]
ecryptfs_key_bytes=16
ecryptfs_cipher=aes
ecryptfs_sig=[...]
Failed to execute /bin/mount command: No such file or directory
Error mounting eCryptfs: [-2] No such file or directory
Check your system logs; visit http://ecryptfs.org/support.html
-------------------------------------
There are many references to /bin/ in the ecryptfs source code, even including /bin/umount. for example:
-------------------------------------
b@ui ~/temp/ecryptfs-utils-111$ ag exec.*bin/
src/utils/mount.ecryptfs.c
417: execl("/bin/mount", "mount", "-i", "--no-canonicalize", "-t", "ecryptfs", fullpath_source, fullpath_target, "-o", opts, NULL);
421: perror("Failed to execute /bin/mount command");
src/desktop/ecryptfs-mount-private.desktop.in
4:Exec=/usr/bin/ecryptfs-mount-private
src/desktop/ecryptfs-setup-private.desktop.in
4:Exec=/usr/bin/ecryptfs-setup-private
src/utils/mount.ecryptfs_private.c
833: execl("/bin/umount", "umount", "-i", "-l", ".", NULL);
src/pam_ecryptfs/pam_ecryptfs.c
375: execl("/sbin/mount.ecryptfs_private",
389: execl("/sbin/umount.ecryptfs_private",
-------------------------------------