[PATCH 3/5] guix package: Disable profile hooks on dry runs.

  • Done
  • quality assurance status badge
Details
5 participants
  • Danny Milosavljevic
  • ???
  • ???
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
???
Severity
normal
Merged with
?
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
20180101103336.8613-4-iyzsong@member.fsf.org
Profile hooks will access the content of manifest inputs before return the
profile derivation, disable them so we don't get inputs bulit on dry runs.

* guix/scripts/package.scm (build-and-use-profile): Disable profile hooks when
a dry-run parameter is given.
---
guix/scripts/package.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/scripts/package.scm b/guix/scripts/package.scm
index 617e102d9..ce0031551 100644
--- a/guix/scripts/package.scm
+++ b/guix/scripts/package.scm
@@ -203,7 +203,7 @@ specified in MANIFEST, a manifest object."
(let* ((prof-drv (run-with-store store
(profile-derivation manifest
- #:hooks (if bootstrap?
+ #:hooks (if (or bootstrap? dry-run?)
'()
%default-profile-hooks)
#:locales? (not bootstrap?))))
--
2.13.3
D
D
Danny Milosavljevic wrote on 1 Jan 2018 14:36
(name . ???)(address . iyzsong@member.fsf.org)(address . 29925@debbugs.gnu.org)
20180101143634.4d22a8b8@scratchpost.org
LGTM!
L
L
Ludovic Courtès wrote on 7 Mar 2018 15:04
control message for bug #29925
(address . control@debbugs.gnu.org)
87lgf4rngy.fsf@gnu.org
merge 29925 29926
L
L
Ludovic Courtès wrote on 7 Mar 2018 15:04
control message for bug #29929
(address . control@debbugs.gnu.org)
87k1uorngl.fsf@gnu.org
merge 29929 29926
L
L
Ludovic Courtès wrote on 7 Mar 2018 15:04
control message for bug #29930
(address . control@debbugs.gnu.org)
87ina8rnga.fsf@gnu.org
merge 29930 29926
L
L
Leo Prikler wrote on 11 May 2021 15:34
Re: [PATCH 0/5] Optimize profile hooks
(name . ???)(address . iyzsong@member.fsf.org)
65a2d7596fb69e0d139b4e2b7a63b354a8f6bf48.camel@student.tugraz.at
merge 29928 29926
merge 29928 29927
thanks

This series (29928 29926 29927 29925 29929 29930) has by now slept on
the mailing list for more than three years.
Should we still try to merge it? If so, could you send an updated
version, that is not spread across six threads?

Thanks,
Leo
?
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
OSZP286MB06646499F30864E598E5BBF1A3529@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (9 lines)
> merge 29928 29926
> merge 29928 29927
> thanks
>
> This series (29928 29926 29927 29925 29929 29930) has by now slept on
> the mailing list for more than three years.
> Should we still try to merge it? If so, could you send an updated
> version, that is not spread across six threads?

Hello, thoes patches are obsoleted, should be rewrite to use
`with-build-handler` (I haven't figure it out how yet).

Look like they were all merged as #29925, I think we can close it for
now, thank you!
Closed
?