[PATCH 5/5] profiles: Sort manifest inputs for profile hooks.

  • Done
  • quality assurance status badge
Details
4 participants
  • Danny Milosavljevic
  • ???
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
???
Severity
normal
Merged with
?
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
20180101103336.8613-6-iyzsong@member.fsf.org
* guix/profiles.scm (info-dir-file, manual-database, fonts-dir-file)
(ghc-package-cache-file, ca-certificate-bundle, gtk-icon-themes)
(gtk-im-modules, xdg-desktop-database, xdg-mime-database): Sort the result of
'manifest-inputs'.
---
guix/profiles.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (87 lines)
diff --git a/guix/profiles.scm b/guix/profiles.scm
index 7d69d1a53..5da4807ad 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -691,7 +691,7 @@ MANIFEST."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/info")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
;; XXX: We have to pass paths of inputs instead of paths of info files,
;; because 'gexp-inputs' only adds inputs for strings which satisfies
@@ -739,7 +739,7 @@ entries of MANIFEST, or #f if MANIFEST does not have any GHC packages."
(lambda (input)
(file-exists? (string-append input "/lib/ghc-"
#$(package-version ghc))))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define (build inputs)
(with-imported-modules '((guix build utils))
@@ -799,7 +799,7 @@ MANIFEST. Single-file bundles are required by programs such as Git and Lynx."
#~(filter
(lambda (input)
(file-exists? (string-append input "/etc/ssl/certs")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define glibc-utf8-locales ;lazy reference
(module-ref (resolve-interface '(gnu packages base)) 'glibc-utf8-locales))
@@ -872,7 +872,7 @@ creates the GTK+ 'icon-theme.cache' file for each theme."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/icons")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(mlet %store-monad ((inputs interested)
(%gtk+ (manifest-lookup-package manifest "gtk+"))
@@ -935,7 +935,7 @@ for both major versions of GTK+."
(filter
(lambda (input)
(not (null? (find-files input "^immodules$" #:directories? #t))))
- '#$(manifest-inputs manifest))))))
+ (sort '#$(manifest-inputs manifest) string<))))))
(mlet %store-monad ((inputs interested)
(gtk+ (manifest-lookup-package manifest "gtk+" "3"))
@@ -1015,7 +1015,7 @@ MIME type."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/applications")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define desktop-file-utils ; lazy reference
(module-ref (resolve-interface '(gnu packages freedesktop))
@@ -1059,7 +1059,7 @@ entries. It's used to query the MIME type of a given file."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/mime/packages")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define shared-mime-info ; lazy reference
(module-ref (resolve-interface '(gnu packages gnome)) 'shared-mime-info))
@@ -1108,7 +1108,7 @@ files for the fonts of the @var{manifest} entries."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/fonts")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define mkfontscale
(module-ref (resolve-interface '(gnu packages xorg)) 'mkfontscale))
@@ -1182,7 +1182,7 @@ the entries in MANIFEST."
#~(filter
(lambda (input)
(file-exists? (string-append input "/share/man")))
- '#$(manifest-inputs manifest))))
+ (sort '#$(manifest-inputs manifest) string<))))
(define gdbm-ffi
(module-ref (resolve-interface '(gnu packages guile))
--
2.13.3
D
D
Danny Milosavljevic wrote on 1 Jan 2018 14:38
(name . ???)(address . iyzsong@member.fsf.org)(address . 29929@debbugs.gnu.org)
20180101143816.19a4f147@scratchpost.org
LGTM!
L
L
Ludovic Courtès wrote on 7 Mar 2018 15:04
control message for bug #29929
(address . control@debbugs.gnu.org)
87k1uorngl.fsf@gnu.org
merge 29929 29926
L
L
Ludovic Courtès wrote on 7 Mar 2018 15:04
control message for bug #29930
(address . control@debbugs.gnu.org)
87ina8rnga.fsf@gnu.org
merge 29930 29926
L
L
Leo Prikler wrote on 11 May 2021 15:34
Re: [PATCH 0/5] Optimize profile hooks
(name . ???)(address . iyzsong@member.fsf.org)
65a2d7596fb69e0d139b4e2b7a63b354a8f6bf48.camel@student.tugraz.at
merge 29928 29926
merge 29928 29927
thanks

This series (29928 29926 29927 29925 29929 29930) has by now slept on
the mailing list for more than three years.
Should we still try to merge it? If so, could you send an updated
version, that is not spread across six threads?

Thanks,
Leo
?