[PATCH] gnu: Add LLVM and CLANG 3.9.1.

  • Done
  • quality assurance status badge
Details
6 participants
  • Catonano
  • Eric Bavier
  • Ludovic Courtès
  • Pjotr Prins
  • Ricardo Wurmus
  • Roel Janssen
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 26 Feb 2017 12:01
(address . guix-patches@gnu.org)
87shn12p2i.fsf@gnu.org
From aaef88b2ab14fd0c631ae7fec296fd899ebf42dd Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Sun, 26 Feb 2017 11:57:34 +0100
Subject: [PATCH] gnu: Add LLVM and CLANG 3.9.1.

* gnu/packages/llvm.scm (llvm-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.
---
gnu/packages/llvm.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 04a2b39af..f525bdc09 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Dennis Mungai <dmngaie@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -218,6 +219,29 @@ code analysis tools.")
"1prc72xmkgx8wrzmrr337776676nhsp1qd3mw2bvb22bzdnq7lsc"
#:patches '("clang-3.8-libc-search-path.patch")))
+(define-public llvm-3.9.1
+ (package (inherit llvm)
+ (name "llvm")
+ (version "3.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "1vi9sf7rx1q04wj479rsvxayb6z740iaz3qniwp266fgp5a07n8z"))))))
+
+(define-public clang-runtime-3.9.1
+ (clang-runtime-from-llvm
+ llvm-3.9.1
+ "16gc2gdmp5c800qvydrdhsp0bzb97s8wrakl6i8a4lgslnqnf2fk"))
+
+(define-public clang-3.9.1
+ (clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
+ "0qsyyb40iwifhhlx9a3drf8z6ni6zwyk3bvh0kx2gs6yjsxwxi76"
+ #:patches '()))
+
(define-public llvm-3.7
(package (inherit llvm)
(version "3.7.1")
--
2.11.0
Dear Guix,

Here's a patch to add LLVM and CLANG 3.9.1. I need these to add
Darktable. It could be that I messed up the commit message. If I did,
please let me know the correct form.

Thanks!

Kind regards,
Roel Janssen
C
C
Catonano wrote on 4 Mar 2017 21:18
(name . Roel Janssen)(address . roel@gnu.org)(address . 25879@debbugs.gnu.org)
CAJ98PDy=52mpLBb8iMCOCX7CYEtw0b9USKGLHySz9NHCY_Z+Rg@mail.gmail.com
2017-02-26 12:01 GMT+01:00 Roel Janssen <roel@gnu.org>:

Toggle quote (13 lines)
> Dear Guix,
>
> Here's a patch to add LLVM and CLANG 3.9.1. I need these to add
> Darktable. It could be that I messed up the commit message. If I did,
> please let me know the correct form.
>
> Thanks!
>
> Kind regards,
> Roel Janssen
>


Ok, this has been sitting here or 6 days now, so even though I'm a
beginner, I'll attempt an answer

I consulted the gnu standard, here

and based on that, I would say that the lines
* gnu/packages/llvm.scm (llvm-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.

are ok

What leaves me dubious is the "and" in the subject line

The gnu standard doesn't mention anything about it but in the guix git repo
log I can't see a single occurrence of an "and", probably because the habit
is one patch per package

So I would suggest you to break this into a patchset of 2 parts: one with
llvm-3.9.1 with subject
"[PATCH] gnu: Add LLVM"

* gnu/packages/llvm.scm (llvm-3.9.1): New variable.

and another one with subect
Subject: [PATCH] gnu: Add CLANG 3.9.1

* gnu/packages/llvm.scm (clang-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.

the sencond one will have clang-runtime-3.9.1 and clang-3.9.1 in it

That should do

As for if it builds and run, I'd leave that to someone else. My laptop
overheats easily

HTH !
Attachment: file
C
C
Catonano wrote on 4 Mar 2017 21:39
(name . Roel Janssen)(address . roel@gnu.org)(address . 25879@debbugs.gnu.org)
CAJ98PDzecb68nzvBmbBG3t_51d29RAvD5eF28bjORvQXaYTWig@mail.gmail.com
Let me amend:

in the log I see an occurrence with a comma, rather than an "and", like this

commit 3b175eab84f9899804b466506a57b5807285150a
Author: Marius Bakke <mbakke@fastmail.com>
Commit: Marius Bakke <mbakke@fastmail.com>

gnu: nss, nss-certs: Update to 3.29.2.

* gnu/packages/certs.scm (nss-certs): Update to 3.29.2.
* gnu/packages/gnuzilla.scm (nss): Update to 3.29.2.
* gnu/packages/patches/nss-pkgconfig.patch: Adapt to context changes.


You could probably do like this

Subject: [PATCH] gnu: Add LLVM, CLANG 3.9.1.

* gnu/packages/llvm.scm (llvm-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-3.9.1): New variable.
* gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.
Attachment: file
L
L
Ludovic Courtès wrote on 7 Mar 2017 18:19
(name . Roel Janssen)(address . roel@gnu.org)(address . 25879@debbugs.gnu.org)
87k28180ob.fsf@gnu.org
Hi Roel!

Roel Janssen <roel@gnu.org> skribis:

Toggle quote (9 lines)
>>From aaef88b2ab14fd0c631ae7fec296fd899ebf42dd Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Sun, 26 Feb 2017 11:57:34 +0100
> Subject: [PATCH] gnu: Add LLVM and CLANG 3.9.1.
>
> * gnu/packages/llvm.scm (llvm-3.9.1): New variable.
> * gnu/packages/llvm.scm (clang-3.9.1): New variable.
> * gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.

I agree with Catonano here, no need to repeat the file name. :-)

Toggle quote (23 lines)
> +(define-public llvm-3.9.1
> + (package (inherit llvm)
> + (name "llvm")
> + (version "3.9.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://llvm.org/releases/"
> + version "/llvm-" version ".src.tar.xz"))
> + (sha256
> + (base32
> + "1vi9sf7rx1q04wj479rsvxayb6z740iaz3qniwp266fgp5a07n8z"))))))
> +
> +(define-public clang-runtime-3.9.1
> + (clang-runtime-from-llvm
> + llvm-3.9.1
> + "16gc2gdmp5c800qvydrdhsp0bzb97s8wrakl6i8a4lgslnqnf2fk"))
> +
> +(define-public clang-3.9.1
> + (clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
> + "0qsyyb40iwifhhlx9a3drf8z6ni6zwyk3bvh0kx2gs6yjsxwxi76"
> + #:patches '()))

Could you add a comment explaining why we need to keep this version
specifically?

Other than that LGTM.

Thanks!

Ludo’.
R
R
Roel Janssen wrote on 7 Mar 2017 19:54
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 25879@debbugs.gnu.org)
87d1dskjdh.fsf@gnu.org
Ludovic Courtès writes:

Toggle quote (43 lines)
> Hi Roel!
>
> Roel Janssen <roel@gnu.org> skribis:
>
>>>From aaef88b2ab14fd0c631ae7fec296fd899ebf42dd Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Sun, 26 Feb 2017 11:57:34 +0100
>> Subject: [PATCH] gnu: Add LLVM and CLANG 3.9.1.
>>
>> * gnu/packages/llvm.scm (llvm-3.9.1): New variable.
>> * gnu/packages/llvm.scm (clang-3.9.1): New variable.
>> * gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.
>
> I agree with Catonano here, no need to repeat the file name. :-)
>
>> +(define-public llvm-3.9.1
>> + (package (inherit llvm)
>> + (name "llvm")
>> + (version "3.9.1")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append "http://llvm.org/releases/"
>> + version "/llvm-" version ".src.tar.xz"))
>> + (sha256
>> + (base32
>> + "1vi9sf7rx1q04wj479rsvxayb6z740iaz3qniwp266fgp5a07n8z"))))))
>> +
>> +(define-public clang-runtime-3.9.1
>> + (clang-runtime-from-llvm
>> + llvm-3.9.1
>> + "16gc2gdmp5c800qvydrdhsp0bzb97s8wrakl6i8a4lgslnqnf2fk"))
>> +
>> +(define-public clang-3.9.1
>> + (clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
>> + "0qsyyb40iwifhhlx9a3drf8z6ni6zwyk3bvh0kx2gs6yjsxwxi76"
>> + #:patches '()))
>
> Could you add a comment explaining why we need to keep this version
> specifically?
>
> Other than that LGTM.

Well, actually, this is just the latest release, so maybe I should
update the 3.8.1 recipe to3.9.1 instead. WDYT?

Kind regards,
Roel Janssen
L
L
Ludovic Courtès wrote on 7 Mar 2017 21:06
(name . Roel Janssen)(address . roel@gnu.org)(address . 25879@debbugs.gnu.org)
8737eosvgb.fsf@gnu.org
Roel Janssen <roel@gnu.org> skribis:

Toggle quote (48 lines)
> Ludovic Courtès writes:
>
>> Hi Roel!
>>
>> Roel Janssen <roel@gnu.org> skribis:
>>
>>>>From aaef88b2ab14fd0c631ae7fec296fd899ebf42dd Mon Sep 17 00:00:00 2001
>>> From: Roel Janssen <roel@gnu.org>
>>> Date: Sun, 26 Feb 2017 11:57:34 +0100
>>> Subject: [PATCH] gnu: Add LLVM and CLANG 3.9.1.
>>>
>>> * gnu/packages/llvm.scm (llvm-3.9.1): New variable.
>>> * gnu/packages/llvm.scm (clang-3.9.1): New variable.
>>> * gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.
>>
>> I agree with Catonano here, no need to repeat the file name. :-)
>>
>>> +(define-public llvm-3.9.1
>>> + (package (inherit llvm)
>>> + (name "llvm")
>>> + (version "3.9.1")
>>> + (source
>>> + (origin
>>> + (method url-fetch)
>>> + (uri (string-append "http://llvm.org/releases/"
>>> + version "/llvm-" version ".src.tar.xz"))
>>> + (sha256
>>> + (base32
>>> + "1vi9sf7rx1q04wj479rsvxayb6z740iaz3qniwp266fgp5a07n8z"))))))
>>> +
>>> +(define-public clang-runtime-3.9.1
>>> + (clang-runtime-from-llvm
>>> + llvm-3.9.1
>>> + "16gc2gdmp5c800qvydrdhsp0bzb97s8wrakl6i8a4lgslnqnf2fk"))
>>> +
>>> +(define-public clang-3.9.1
>>> + (clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
>>> + "0qsyyb40iwifhhlx9a3drf8z6ni6zwyk3bvh0kx2gs6yjsxwxi76"
>>> + #:patches '()))
>>
>> Could you add a comment explaining why we need to keep this version
>> specifically?
>>
>> Other than that LGTM.
>
> Well, actually, this is just the latest release, so maybe I should
> update the 3.8.1 recipe to3.9.1 instead. WDYT?

If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
cope with it, upgrading sounds better indeed. Could you check if that
is the case?

Thanks,
Ludo’.
P
P
Pjotr Prins wrote on 7 Mar 2017 22:24
(name . Ludovic Courtès)(address . ludo@gnu.org)
20170307212411.GA29363@mail.thebird.nl
On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
Toggle quote (7 lines)
> > Well, actually, this is just the latest release, so maybe I should
> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>
> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
> cope with it, upgrading sounds better indeed. Could you check if that
> is the case?

With LLVM it is probably a good idea to keep the major versions as
packages tend to lag after latest. Many compiler writers are a bit
behind and sometimes people want to use older compilers (like with
Julia).

Pj.
--
E
E
Eric Bavier wrote on 15 Mar 2017 03:31
(address . roel@gnu.org)(address . 25879@debbugs.gnu.org)
20170314213122.44f5afb3@centurylink.net
Thanks for the patch!

I have another package that needs 3.9 in its latest version, so I'm
interested in getting it merged. Just one comment/question:

Roel Janssen <roel@gnu.org> writes:

Toggle quote (14 lines)
>>From aaef88b2ab14fd0c631ae7fec296fd899ebf42dd Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Sun, 26 Feb 2017 11:57:34 +0100
> Subject: [PATCH] gnu: Add LLVM and CLANG 3.9.1.
>
> * gnu/packages/llvm.scm (llvm-3.9.1): New variable.
> * gnu/packages/llvm.scm (clang-3.9.1): New variable.
> * gnu/packages/llvm.scm (clang-runtime-3.9.1): New variable.
> ---
> +(define-public clang-3.9.1
> + (clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
> + "0qsyyb40iwifhhlx9a3drf8z6ni6zwyk3bvh0kx2gs6yjsxwxi76"
> + #:patches '()))

Does clang 3.9 not need the libc-search-path patch that is applied in
other versions?

`~Eric
R
R
Ricardo Wurmus wrote on 10 May 2017 08:11
(name . Pjotr Prins)(address . pjotr.public12@thebird.nl)
87bmr1i6l3.fsf@elephly.net
Pjotr Prins <pjotr.public12@thebird.nl> writes:

Toggle quote (13 lines)
> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>> > Well, actually, this is just the latest release, so maybe I should
>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>
>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>> cope with it, upgrading sounds better indeed. Could you check if that
>> is the case?
>
> With LLVM it is probably a good idea to keep the major versions as
> packages tend to lag after latest. Many compiler writers are a bit
> behind and sometimes people want to use older compilers (like with
> Julia).

I agree.

@Roel: I see that this patch hasn’t been pushed yet. Is there anything
missing or was it just forgotten?

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 10 May 2017 08:12
control message for bug #25879
(address . control@debbugs.gnu.org)
E1d8KrL-0002ix-H5@debbugs.gnu.org
tags 25879 moreinfo
R
R
Roel Janssen wrote on 10 May 2017 08:57
Re: bug#25879: [PATCH] gnu: Add LLVM and CLANG 3.9.1.
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87inl9gpvu.fsf@gnu.org
Ricardo Wurmus writes:

Toggle quote (20 lines)
> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>
>> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>>> > Well, actually, this is just the latest release, so maybe I should
>>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>>
>>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>>> cope with it, upgrading sounds better indeed. Could you check if that
>>> is the case?
>>
>> With LLVM it is probably a good idea to keep the major versions as
>> packages tend to lag after latest. Many compiler writers are a bit
>> behind and sometimes people want to use older compilers (like with
>> Julia).
>
> I agree.
>
> @Roel: I see that this patch hasn’t been pushed yet. Is there anything
> missing or was it just forgotten?

I think the idea was to upgrade, instead of have this newer version next
to the current version. The upgrade involves a lot of rebuilding, and I
am stuck at compiling 'dub' with 3.9.1.

If we can instead apply this patch as (having both 3.8.1 and 3.9.1), we
can push it, and after that add the darktable patch as well.

Kind regards,
Roel Janssen
R
R
Ricardo Wurmus wrote on 10 May 2017 12:07
(name . Roel Janssen)(address . roel@gnu.org)
877f1phvox.fsf@elephly.net
Roel Janssen <roel@gnu.org> writes:

Toggle quote (29 lines)
> Ricardo Wurmus writes:
>
>> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>>
>>> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>>>> > Well, actually, this is just the latest release, so maybe I should
>>>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>>>
>>>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>>>> cope with it, upgrading sounds better indeed. Could you check if that
>>>> is the case?
>>>
>>> With LLVM it is probably a good idea to keep the major versions as
>>> packages tend to lag after latest. Many compiler writers are a bit
>>> behind and sometimes people want to use older compilers (like with
>>> Julia).
>>
>> I agree.
>>
>> @Roel: I see that this patch hasn’t been pushed yet. Is there anything
>> missing or was it just forgotten?
>
> I think the idea was to upgrade, instead of have this newer version next
> to the current version. The upgrade involves a lot of rebuilding, and I
> am stuck at compiling 'dub' with 3.9.1.
>
> If we can instead apply this patch as (having both 3.8.1 and 3.9.1), we
> can push it, and after that add the darktable patch as well.

I think it’s fine to have multiple versions of LLVM + Clang around,
especially considering that in my experience many dependent projects
won’t build with later versions without adjustments. (RStudio, for
example, still insists on the oldest version of Clang that we offer, and
it crashes with later versions.)

It would be good to keep an eye on this, though, to make sure that we
don’t provide outdated versions that have no users and no maintainer.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Roel Janssen wrote on 10 May 2017 12:17
(name . Ricardo Wurmus)(address . rekado@elephly.net)
rbuefvxqalq.fsf@gnu.org
Ricardo Wurmus writes:

Toggle quote (40 lines)
> Roel Janssen <roel@gnu.org> writes:
>
>> Ricardo Wurmus writes:
>>
>>> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>>>
>>>> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>>>>> > Well, actually, this is just the latest release, so maybe I should
>>>>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>>>>
>>>>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>>>>> cope with it, upgrading sounds better indeed. Could you check if that
>>>>> is the case?
>>>>
>>>> With LLVM it is probably a good idea to keep the major versions as
>>>> packages tend to lag after latest. Many compiler writers are a bit
>>>> behind and sometimes people want to use older compilers (like with
>>>> Julia).
>>>
>>> I agree.
>>>
>>> @Roel: I see that this patch hasn’t been pushed yet. Is there anything
>>> missing or was it just forgotten?
>>
>> I think the idea was to upgrade, instead of have this newer version next
>> to the current version. The upgrade involves a lot of rebuilding, and I
>> am stuck at compiling 'dub' with 3.9.1.
>>
>> If we can instead apply this patch as (having both 3.8.1 and 3.9.1), we
>> can push it, and after that add the darktable patch as well.
>
> I think it’s fine to have multiple versions of LLVM + Clang around,
> especially considering that in my experience many dependent projects
> won’t build with later versions without adjustments. (RStudio, for
> example, still insists on the oldest version of Clang that we offer, and
> it crashes with later versions.)
>
> It would be good to keep an eye on this, though, to make sure that we
> don’t provide outdated versions that have no users and no maintainer.

So, is it OK to push the patch as-is then?

Kind regards,
Roel Janssen
R
R
Ricardo Wurmus wrote on 10 May 2017 12:23
(name . Roel Janssen)(address . roel@gnu.org)
874lwthuxu.fsf@elephly.net
Roel Janssen <roel@gnu.org> writes:

Toggle quote (44 lines)
> Ricardo Wurmus writes:
>
>> Roel Janssen <roel@gnu.org> writes:
>>
>>> Ricardo Wurmus writes:
>>>
>>>> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>>>>
>>>>> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>>>>>> > Well, actually, this is just the latest release, so maybe I should
>>>>>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>>>>>
>>>>>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>>>>>> cope with it, upgrading sounds better indeed. Could you check if that
>>>>>> is the case?
>>>>>
>>>>> With LLVM it is probably a good idea to keep the major versions as
>>>>> packages tend to lag after latest. Many compiler writers are a bit
>>>>> behind and sometimes people want to use older compilers (like with
>>>>> Julia).
>>>>
>>>> I agree.
>>>>
>>>> @Roel: I see that this patch hasn’t been pushed yet. Is there anything
>>>> missing or was it just forgotten?
>>>
>>> I think the idea was to upgrade, instead of have this newer version next
>>> to the current version. The upgrade involves a lot of rebuilding, and I
>>> am stuck at compiling 'dub' with 3.9.1.
>>>
>>> If we can instead apply this patch as (having both 3.8.1 and 3.9.1), we
>>> can push it, and after that add the darktable patch as well.
>>
>> I think it’s fine to have multiple versions of LLVM + Clang around,
>> especially considering that in my experience many dependent projects
>> won’t build with later versions without adjustments. (RStudio, for
>> example, still insists on the oldest version of Clang that we offer, and
>> it crashes with later versions.)
>>
>> It would be good to keep an eye on this, though, to make sure that we
>> don’t provide outdated versions that have no users and no maintainer.
>
> So, is it OK to push the patch as-is then?

Yes, please! :)

If you can, it would be good to investigate if current users of 3.8
could be built with 3.9, but this doesn’t have to block this patch in my
opinion.

If in fact all users of 3.8 can be built with 3.9 without problems you
can make the change in a follow-up commit.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Roel Janssen wrote on 10 May 2017 15:44
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87wp9okeqt.fsf@gnu.org
Ricardo Wurmus writes:

Toggle quote (48 lines)
> Roel Janssen <roel@gnu.org> writes:
>
>> Ricardo Wurmus writes:
>>
>>> Roel Janssen <roel@gnu.org> writes:
>>>
>>>> Ricardo Wurmus writes:
>>>>
>>>>> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>>>>>
>>>>>> On Tue, Mar 07, 2017 at 09:06:28PM +0100, Ludovic Courtès wrote:
>>>>>>> > Well, actually, this is just the latest release, so maybe I should
>>>>>>> > update the 3.8.1 recipe to3.9.1 instead. WDYT?
>>>>>>>
>>>>>>> If the other users of LLVM and Clang (as per ‘guix refresh -l llvm’) can
>>>>>>> cope with it, upgrading sounds better indeed. Could you check if that
>>>>>>> is the case?
>>>>>>
>>>>>> With LLVM it is probably a good idea to keep the major versions as
>>>>>> packages tend to lag after latest. Many compiler writers are a bit
>>>>>> behind and sometimes people want to use older compilers (like with
>>>>>> Julia).
>>>>>
>>>>> I agree.
>>>>>
>>>>> @Roel: I see that this patch hasn’t been pushed yet. Is there anything
>>>>> missing or was it just forgotten?
>>>>
>>>> I think the idea was to upgrade, instead of have this newer version next
>>>> to the current version. The upgrade involves a lot of rebuilding, and I
>>>> am stuck at compiling 'dub' with 3.9.1.
>>>>
>>>> If we can instead apply this patch as (having both 3.8.1 and 3.9.1), we
>>>> can push it, and after that add the darktable patch as well.
>>>
>>> I think it’s fine to have multiple versions of LLVM + Clang around,
>>> especially considering that in my experience many dependent projects
>>> won’t build with later versions without adjustments. (RStudio, for
>>> example, still insists on the oldest version of Clang that we offer, and
>>> it crashes with later versions.)
>>>
>>> It would be good to keep an eye on this, though, to make sure that we
>>> don’t provide outdated versions that have no users and no maintainer.
>>
>> So, is it OK to push the patch as-is then?
>
> Yes, please! :)

Pushed in 584da12dc71da745edb13bf748e832b77a0193d7.

Toggle quote (7 lines)
> If you can, it would be good to investigate if current users of 3.8
> could be built with 3.9, but this doesn’t have to block this patch in my
> opinion.
>
> If in fact all users of 3.8 can be built with 3.9 without problems you
> can make the change in a follow-up commit.

I am sure that at least 'c-reduce' does not build with 3.9.1. So I
think we'll need to take this on a per-program basis. I'll see which
ones can be built with 3.9.1.

Thanks!

Kind regards,
Roel Janssen
R
R
Ricardo Wurmus wrote on 10 May 2017 15:54
(name . Roel Janssen)(address . roel@gnu.org)
87wp9ohl5n.fsf@elephly.net
Roel Janssen <roel@gnu.org> writes:

Toggle quote (6 lines)
>>> So, is it OK to push the patch as-is then?
>>
>> Yes, please! :)
>
> Pushed in 584da12dc71da745edb13bf748e832b77a0193d7.

Great! Closing this bug.

Toggle quote (11 lines)
>> If you can, it would be good to investigate if current users of 3.8
>> could be built with 3.9, but this doesn’t have to block this patch in my
>> opinion.
>>
>> If in fact all users of 3.8 can be built with 3.9 without problems you
>> can make the change in a follow-up commit.
>
> I am sure that at least 'c-reduce' does not build with 3.9.1. So I
> think we'll need to take this on a per-program basis. I'll see which
> ones can be built with 3.9.1.

Thanks for taking care of this!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?