KHolidays is part of frameworks since version 5.43 already.
* gnu/packages/kde.scm(kholidays): Move to …
* gnu/packages/kde-frameworks.scm(kholidays) … here, update to 5.63.0 and
[source]: Update path.
(attica, baloo, bluez-qt, breeze- icons,
extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive,
kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kcoreaddons,
kcrash, kdbusaddons, kde-frameworkintegration, kdeclarative, kded,
kdelibs4support, kdesu, kdnssd, kdoctools, kemoticons, kglobalaccel,
kguiaddons, khtml, ki18n, kidletime, kimageformats, kinit, kirigami,
kitemmodels, kitemviews, kjobwidgets, kjs, kjsembed, kmediaplayer,
knewstuff, knotifications, knotifyconfig, kpackage, kparts, kpeople, kpty,
kross, krunner, kservice, ksyntaxhighlighting, ktexteditor, kunitconversion,
kwallet, kwidgetsaddons, kxmlrpcclient, modemmanager-qt, networkmanager-qt,
oxygen-icons, plasma-framework, prison, qqc2-desktop-style, solid, sonnet,
threadweaver): Update to 5.63.0.
(kconfigwidgets): Update to 5.63.0; [inputs]: Add qttools.
(kdesignerplugin): Update to 5.63.0; [source]: Update path.
(kdewebkit): Update to 5.63.0; [source]: Update path.;
[inputs]: Add qttools.
(kfilemetadata): Update to 5.63.0; [inputs]: Add kcoreaddons;
[arguments]<#pahses>: Add a test-case to the blacklist
(kiconthemes): Update to 5.63.0; [inputs]: Add qttools.
(kio): Update to 5.63.0; [inputs]: Add qttools.
(kplotting): Update to 5.63.0; [inputs]: Add qttools.
(ktextwidgets): Update to 5.63.0; [inputs]: Add qttools.
(kwayland): Update to 5.63.0; [inputs]: Add wayland-protocols.
(kwindowsystem): Update to 5.63.0, update blacklist or tests,
explicitly set XDG_RUNTIME_DIR; [inputs]: Add xcb-util-wm.
(kxmlgui): Update to 5.63.0; [inputs]: Add qttools.
* gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Adjust.
* gnu/packages/patches/kwindowsystem-qt-compat.patch: Remove obsolete patch.
---
gnu/packages/kde-frameworks.scm | 370 ++++++++++--------
gnu/packages/kde.scm | 35 --
.../patches/kinit-kdeinit-extra_libs.patch | 4 +-
.../patches/kwindowsystem-qt-compat.patch | 97 -----
4 files changed, 209 insertions(+), 297 deletions(-)
delete mode 100644 gnu/packages/patches/kwindowsystem-qt-compat.patch
Toggle diff (463 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 613a1a9734..85c3736669 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -78,7 +78,7 @@
(define-public extra-cmake-modules
(package
(name "extra-cmake-modules")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -87,7 +87,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1x868hs9jiqzkqx7gld4mdm5dzfxc5kann22y15a4f7g5a957534"))))
+ "14h7519bfkwzh58lxgxrj5jlfhfnrakhjcm6lmhafnkg5h56m4kr"))))
(build-system cmake-build-system)
(native-inputs
`(("qtbase" ,qtbase))) ; For tests (needs qmake)
@@ -254,7 +254,7 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
(define-public attica
(package
(name "attica")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -263,7 +263,7 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0bsn9mi3nj23k2r3mfgjm9i1mp8qnwf08xn9x757wk3xas0cx98v"))))
+ "0dvsjwl2c3liiicv2m8p1m7hlc3fcapsj5pfirmdm1l38wcayr60"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -294,7 +294,7 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
(define-public bluez-qt
(package
(name "bluez-qt")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -303,7 +303,7 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
name "-" version ".tar.xz"))
(sha256
(base32
- "1ixad1ya3c339c675w8nwmbga8ydq16db9fk2az3gjm68z3dch8a"))))
+ "179am9czhb9mcirmja5bxjmqil3qg81v56n8rmkkp5q50qpln4dh"))))
(build-system cmake-build-system)
(native-inputs
`(("dbus" ,dbus)
@@ -327,7 +327,7 @@ Bluetooth stack. It is used by the KDE Bluetooth stack, BlueDevil.")
(define-public breeze-icons
(package
(name "breeze-icons")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -336,7 +336,7 @@ Bluetooth stack. It is used by the KDE Bluetooth stack, BlueDevil.")
name "-" version ".tar.xz"))
(sha256
(base32
- "03mb7x8mc2h6cjb4mrifrbkbpj3lv9c0mg4m619rqiydg0p1yf49"))))
+ "17kil9dlh8w5r29arrjbv47b7jxz45kqzpg06zw3vz70bdgbb995"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -356,7 +356,7 @@ It is the default icon theme for the KDE Plasma 5 desktop.")
(define-public kapidox
(package
(name "kapidox")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -365,7 +365,7 @@ It is the default icon theme for the KDE Plasma 5 desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0x41adp3rnvr6njc57ffdyh6d5i5aw13xcjdr4p6kacw9pk63ajf"))))
+ "0cwprhpz731bqqhr6vra6lc76k5i4pm3m9j0q21km9wm2djfmk19"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; has no test target
@@ -398,7 +398,7 @@ documentation.")
(define-public karchive
(package
(name "karchive")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -407,7 +407,7 @@ documentation.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1llznxc5wjjnmbjx8iwi3a93gc2z0z344viknsgls1fwdjjfyxc4"))))
+ "0ypykybxl9dz57rgsfihx4rfhzhphidypb2f5nwrw1f6vlqkawzs"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
@@ -432,7 +432,7 @@ GZip format, via a subclass of QIODevice.")
(define-public kcodecs
(package
(name "kcodecs")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -441,7 +441,7 @@ GZip format, via a subclass of QIODevice.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0491j6l28jwfpgaqs2816qpyggnra2df33iw3fgvb0wd4r4gvmjb"))))
+ "0w5q37lqdzyl84723kg9sh9xxn2g2wv0xfxpy3218hmc9364s89h"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -468,7 +468,7 @@ Internet).")
(define-public kconfig
(package
(name "kconfig")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -477,7 +477,7 @@ Internet).")
name "-" version ".tar.xz"))
(sha256
(base32
- "06gscipc3914gwiswhp1xx4sy74bpy645ykq2i6r1sb6sm16hmja"))))
+ "1ya0fvrrfiw4a5wkydcjpnkkyq3ampxy5h210dm04qim6a9x8rb1"))))
(build-system cmake-build-system)
(native-inputs
`(("dbus" ,dbus)
@@ -533,7 +533,7 @@ propagate their changes to their respective configuration files.")
(define-public kcoreaddons
(package
(name "kcoreaddons")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -542,7 +542,7 @@ propagate their changes to their respective configuration files.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1j7bc5fhak8db3vdfslbjdffbdclakhfwsni2a855d08yfrl1n1w"))))
+ "1w658wfksxglr0fjpa2p8gmjbvpd2knzhk3byk2s9dwil7i7cvjd"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -590,7 +590,7 @@ many more.")
(define-public kdbusaddons
(package
(name "kdbusaddons")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -599,7 +599,7 @@ many more.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1sj3cycgci3ih65bkh7bsvbzyp7r654ppcryj4azpcsxqhy5gc7l"))
+ "11zwr89v0k4m1235rzr39z4cbfdwn5zg34abs62nfnr8vmba62qv"))
(patches (search-patches "kdbusaddons-kinit-file-name.patch"))))
(build-system cmake-build-system)
(native-inputs
@@ -635,7 +635,7 @@ as well as an API to create KDED modules.")
(define-public kdnssd
(package
(name "kdnssd")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -644,7 +644,7 @@ as well as an API to create KDED modules.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0lljj7mxmqm60kfzr37zb7z58mfyfh7zgykf7a5is1k0lxpgk6zc"))))
+ "1bn9c6ii1n6ns478i3lp7yzga7dbcqvdb43rfzmz7gndnmh853gm"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -663,7 +663,7 @@ infrastructure.")
(define-public kguiaddons
(package
(name "kguiaddons")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -672,7 +672,7 @@ infrastructure.")
name "-" version ".tar.xz"))
(sha256
(base32
- "190jwhvq2fi8g03saszlaslzxmcbqrbwli9f9vm6h5j9nnc0z6h3"))))
+ "0k22kargqxf0j09wzk1x90b526npj8a0210ilk0n1k6spc8xa6mr"))))
(build-system cmake-build-system)
;; TODO: Build packages for the Python bindings. Ideally this will be
;; done for all versions of python guix supports. Requires python,
@@ -698,10 +698,45 @@ infrastructure.")
interfaces in the areas of colors, fonts, text, images, keyboard input.")
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public kholidays
+ (package
+ (name "kholidays")
+ (version "5.63.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1035kh0na4hwp4pnsi8p1nd7r114d4bgdnjr0g2hwmy868vx0a67"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; blacklist a failing test function TODO: make it pass
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ (display "[testDefaultRegions]\n*\n")))
+ #t)))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://cgit.kde.org/kholidays.git")
+ (synopsis "Library for regional holiday information")
+ (description "This library provides a C++ API that determines holiday and
+other special events for a geographical region.")
+ (license license:lgpl2.0+)))
+
(define-public ki18n
(package
(name "ki18n")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -710,7 +745,7 @@ interfaces in the areas of colors, fonts, text, images, keyboard input.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0kvwjzqibby9fawyfb8bd81abjhsjlyi8xy9mcapnih5x2gx3z92"))))
+ "1fdp0bdvqbqzbxynbg3bcdridr8j3qnm9spyrrdg5q95sz99a4s9"))))
(build-system cmake-build-system)
(propagated-inputs
`(("gettext" ,gettext-minimal)
@@ -744,7 +779,7 @@ translation scripting.")
(define-public kidletime
(package
(name "kidletime")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -753,7 +788,7 @@ translation scripting.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1kq6zh6cjhzffjhxnc7l1pw6g38swxyspp8xl8c860zdhc9xfd1g"))))
+ "0zd51lsz23rqwk4lnzs5653sanprgr80p33yk8gmgsihgyfbjv0r"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -775,7 +810,7 @@ or user activity.")
;; plasma-framework which is tier 3.
(package
(name "kirigami")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -784,7 +819,7 @@ or user activity.")
"kirigami2-" version ".tar.xz"))
(sha256
(base32
- "11djxli5cq7pn19lmjz2y7z39mhlr98jskasfzyax546j47v973k"))))
+ "1v76d1xgmi9kkxiwq4y6rzaxs1hwwm95pw490m09rgqhli7180yv"))))
(properties `((upstream-name . "kirigami2")))
(build-system cmake-build-system)
(native-inputs
@@ -811,7 +846,7 @@ of applications that follow the Kirigami Human Interface Guidelines.")
(define-public kitemmodels
(package
(name "kitemmodels")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -820,7 +855,7 @@ of applications that follow the Kirigami Human Interface Guidelines.")
name "-" version ".tar.xz"))
(sha256
(base32
- "13609avkqrfi79zyr737662nr8bwcfdya9dxc6gzyqx5i0l2nbw6"))))
+ "10bhg0db9gdg2hlc02ngg1i2q7a99862d5973hxqzf620d28p5rd"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
@@ -870,7 +905,7 @@ model to observers
(define-public kitemviews
(package
(name "kitemviews")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -879,7 +914,7 @@ model to observers
name "-" version ".tar.xz"))
(sha256
(base32
- "1mgh7z5xcbhc7a2qq8mqfp7j4amk93hypkpy2zc3rdhc60ps94ad"))))
+ "15h0w16wgj94kxz4vgjb34i3pyx5w1f2npj86j4d2sa0mxxpmqyz"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -905,7 +940,7 @@ to flat and hierarchical lists.")
(define-public kplotting
(package
(name "kplotting")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -914,12 +949,13 @@ to flat and hierarchical lists.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0nn2v1yvvpzpi1y1pm47zvmwsa942c7d9n8iqymqihnp0fqjr8y7"))))
+ "11kpq34j37c1gsvj5nxhkc31bw8gw2n7nkqsfx87jw9f4v2vhmr9"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
- `(("qtbase" ,qtbase)))
+ `(("qtbase" ,qtbase)
+ ("qttools" ,qttools)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -940,7 +976,7 @@ pixel units.")
(define-public ksyntaxhighlighting
(package
(name "ksyntaxhighlighting")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -949,7 +985,7 @@ pixel units.")
"syntax-highlighting-" version ".tar.xz"))
(sha256
(base32
- "00w5nmz9l70znv8q7q1zw3f7gngwfgf41iwbs53zqcv1z7wmrz6m"))))
+ "08y0m4wcq1sbxvlga3w72waj5xckh5jra5x7rvnp87dl38qxhacs"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -989,7 +1025,7 @@ integration with a custom editor as well as a ready-to-use
(define-public kwayland
(package
(name "kwayland")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -998,14 +1034,15 @@ integration with a custom editor as well as a ready-to-use
name "-" version ".tar.xz"))
(sha256
(base32
- "0m9q13qzgvp03jrsyc59l6pp7jf0dvhx768p21drs46qxw6wla7l"))))
+ "03z8hiw0mrhl3f0y7ypc46ic0w5vlp56prbqbk448jin5hakkkdg"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)))
(inputs
`(("qtbase" ,qtbase)
- ("wayland" ,wayland)))
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
(arguments
`(#:tests? #f ; FIXME tests require weston to run
; weston requires wayland flags in mesa
@@ -1028,7 +1065,7 @@ represented by a QPoint or a QSize.")
(define-public kwidgetsaddons
(package
(name "kwidgetsaddons")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1037,7 +1074,7 @@ represented by a QPoint or a QSize.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0kpbvvmjrhxxjqc0cb63zlq06a3xspq43xv3wdingcn28zypynzc"))))
+ "1nzgv3v3kyq5jm2b9xri6qjawspr9ycxhskfvj8kkgr46dr35qyc"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -1075,17 +1112,16 @@ configuration pages, message boxes, and password requests.")
(define-public kwindowsystem
(package
(name "kwindowsystem")
- (version "5.55.0")
+ (version "5.63.0")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://kde/stable/frameworks/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
- (patches (search-patches "kwindowsystem-qt-compat.patch"))
(sha256
(base32
- "10zdxm08d758zbwlrbsn0ghxjpf39ids2s5pnca072gbrbrxv656"))))
+ "0nbkb8pkrbbp1s892ndzhakzri3qxpw48kibgb0rqz6i0azfxrz8"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -1108,12 +1144,13 @@ configuration pages, message boxes, and password requests.")
;; Blacklist a failing test-functions. FIXME: Make it pass.
(with-output-to-file "autotests/BLACKLIST"
(lambda _
- (display "[testState]\n*\n")
- (display "[testSupported]\n*\n")))
+ (display "[testGroupLeader]\n*\n"