[PATCH 0/3] Upate kdevelop to 5.4.4 and deprecate kdevplatform package

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 7 Nov 2019 11:21
(address . guix-patches@gnu.org)
20191107102126.3519-1-h.goebel@crazy-compilers.com
Also update siblings.

kdevplatform was merged into kdevelop as of 5.2.x.

Hartmut Goebel (3):
gnu: kdevelop-pg-qt: Update to 2.2.0.
gnu: kdevelop: Update to 5.4.4.
gnu: Deprecate kdevplatform package.

gnu/packages/kde.scm | 152 ++++++++++++++++---------------------------
1 file changed, 55 insertions(+), 97 deletions(-)

--
2.21.0
H
H
Hartmut Goebel wrote on 7 Nov 2019 11:25
Mot info
(address . 38099@debbugs.gnu.org)
9f460aee-2e8e-2abb-8d27-a69c76d754e0@crazy-compilers.com
I forgot to mention:

* requires http://issues.guix.gnu.org/issue/38098 (Fix astyle building)

* requires QT 5.12 and recent KDE frameworks, thus  should go to staging.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
H
H
Hartmut Goebel wrote on 7 Nov 2019 11:25
[PATCH 1/3] gnu: kdevelop-pg-qt: Update to 2.2.0.
(address . 38099@debbugs.gnu.org)
20191107102550.3721-1-h.goebel@crazy-compilers.com
* gnu/packages/kde.scm(kdevelop-pg-qt): Update to 2.2.0.
---
gnu/packages/kde.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 162eebe331..6afc2c5eba 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -228,7 +228,7 @@ software (Git, Subversion, Mercurial, CVS and Bazaar).")
(define-public kdevelop-pg-qt
(package
(name "kdevelop-pg-qt")
- (version "2.0.0")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
@@ -236,7 +236,7 @@ software (Git, Subversion, Mercurial, CVS and Bazaar).")
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
+ (base32 "15ja19gg6x7gww4ch12hy585x55ghbkpsiyr8fqiyjk0j6v07hh5"))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
--
2.21.0
H
H
Hartmut Goebel wrote on 7 Nov 2019 11:25
[PATCH 2/3] gnu: kdevelop: Update to 5.4.4.
(address . 38099@debbugs.gnu.org)
20191107102550.3721-2-h.goebel@crazy-compilers.com
* gnu/packages/kde.scm(kdevelop): Update to 5.4.4.
[inputs] Remove kconfig, kdevplatform, libepoxy; Add apr, apr-util, astyle,
attica, boost, kconfigwidgets, kservice, libkomparediff2, sonnet,
subversion; structure and sort.
[arguments]<phases>{add-include-path}: New phase.
{wrap-executable}: Remove references to kdevplatform.
---
gnu/packages/kde.scm | 74 ++++++++++++++++++++++++++++++--------------
1 file changed, 50 insertions(+), 24 deletions(-)

Toggle diff (140 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6afc2c5eba..923af4381d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
@@ -140,7 +141,7 @@ projects.")
(define-public kdevelop
(package
(name "kdevelop")
- (version "5.1.2")
+ (version "5.4.4")
(source
(origin
(method url-fetch)
@@ -149,55 +150,80 @@ projects.")
version ".tar.xz"))
(sha256
(base32
- "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
+ "1cangz3ghz39sxxggp2p7kqy2ncgs0r3i19c341b5xbkcxw2y20h"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(inputs
- `(("kdevplatform" ,kdevplatform)
- ("kdevelop-pg-qt" ,kdevelop-pg-qt)
- ("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("qtquickcontrols" ,qtquickcontrols)
- ("qtwebkit" ,qtwebkit)
+ `(("boost" ,boost)
+ ("clang" ,clang)
+ ("grantlee" ,grantlee)
("karchive" ,karchive)
("kcmutils" ,kcmutils)
- ("kconfig" ,kconfig)
+ ("kcrash" ,kcrash)
("kdeclarative" ,kdeclarative)
("kdoctools" ,kdoctools)
("kguiaddons" ,kguiaddons)
("ki18n" ,ki18n)
- ("kio" ,kio)
("kiconthemes" ,kiconthemes)
+ ("kio" ,kio) ;; not checked as requirement
("kitemmodels" ,kitemmodels)
("kitemviews" ,kitemviews)
("kjobwidgets" ,kjobwidgets)
- ("knotifyconfig" ,knotifyconfig)
("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
("kparts" ,kparts)
- ("kcrash" ,kcrash)
- ("knewstuff" ,knewstuff)
- ("krunner" ,krunner)
- ("kxmlgui" ,kxmlgui)
- ("libksysguard" ,libksysguard)
- ("threadweaver" ,threadweaver)
+ ("kservice" ,kservice)
("ktexteditor" ,ktexteditor)
("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("libkomparediff2" ,libkomparediff2)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
+ ("qtwebkit" ,qtwebkit)
+ ("shared-mime-info" ,shared-mime-info)
+ ("threadweaver" ,threadweaver)
+
+ ;; recommendes
+ ("astyle" ,astyle)
+ ("kdevelop-pg-qt" ,kdevelop-pg-qt)
+ ("libksysguard" ,libksysguard)
+
+ ;; optional
+ ("apr" ,apr) ; required for subversion support
+ ("apr-util" ,apr-util) ; required for subversion support
+ ("attica" ,attica)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("knewstuff" ,knewstuff)
+ ("krunner" ,krunner)
("plasma" ,plasma-framework)
- ("grantlee" ,grantlee)
- ("libepoxy" ,libepoxy)
- ("clang" ,clang)
- ("shared-mime-info" ,shared-mime-info)))
+ ("sonnet" ,sonnet)
+ ("subversion" ,subversion)
+ ;; TODO: OktetaGui, OktetaKastenControllers
+ ;; TODO: purpose
+
+ ;; run-time packages - TODO
+ ;; ClazyStandalone
+ ;; Cppcheck
+ ;; heaptrack
+ ;; heaptrack_gui
+ ;; meson
+ ))
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'add-include-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cmake/modules/FindClang.cmake"
+ (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
+ (string-append line " " (assoc-ref inputs "clang") "/lib")))))
(delete 'check) ;; there are some issues with the test suite
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (kdevplatform (assoc-ref inputs "kdevplatform"))
(kio (assoc-ref inputs "kio"))
(kcmutils (assoc-ref inputs "kcmutils"))
(qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
@@ -207,12 +233,12 @@ projects.")
(wrap-program (string-append out "/bin/kdevelop")
`("XDG_DATA_DIRS" ":" prefix
,(map (lambda (s) (string-append s "/share"))
- (list out kdevplatform kcmutils)))
+ (list out kcmutils)))
`("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
(,(string-append qtbase "/plugins/platforms")))
`("QT_PLUGIN_PATH" ":" prefix
,(map (lambda (s) (string-append s "/lib/plugins"))
- (list out kdevplatform kio)))
+ (list out kio)))
`("QML2_IMPORT_PATH" ":" prefix
(,(string-append qtquickcontrols qml)
,(string-append qtdeclarative qml))))))))))
--
2.21.0
H
H
Hartmut Goebel wrote on 7 Nov 2019 11:25
[PATCH 3/3] gnu: Deprecate kdevplatform package.
(address . 38099@debbugs.gnu.org)
20191107102550.3721-3-h.goebel@crazy-compilers.com
* gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
for 'kdevelop`.
---
gnu/packages/kde.scm | 74 ++------------------------------------------
1 file changed, 3 insertions(+), 71 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 923af4381d..8ae8d5b3ca 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -25,6 +25,7 @@
(define-module (gnu packages kde)
#:use-module (guix build-system cmake)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -274,77 +275,8 @@ software (Git, Subversion, Mercurial, CVS and Bazaar).")
for some KDevelop language plugins (Ruby, PHP, CSS...).")
(license license:lgpl2.0+)))
-(define-public kdevplatform
- (package
- (name "kdevplatform")
- (version "5.1.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/kdevelop"
- "/" version "/src/kdevplatform-"
- version ".tar.xz"))
- (sha256
- (base32
- "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("apr" ,apr)
- ("apr-util" ,apr-util)
- ("boost" ,boost)
- ("karchive" ,karchive)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcmutils" ,kcmutils)
- ("kiconthemes" ,kiconthemes)
- ("kdeclarative" ,kdeclarative)
- ("kdoctools" ,kdoctools)
- ("kguiaddons" ,kguiaddons)
- ("kinit" ,kinit)
- ("kitemmodels" ,kitemmodels)
- ("knewstuff" ,knewstuff)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kwindowsystem" ,kwindowsystem)
- ("kio" ,kio)
- ("ki18n" ,ki18n)
- ("kparts" ,kparts)
- ("kservice" ,kservice)
- ("grantlee" ,grantlee)
- ("libkomparediff2" ,libkomparediff2)
- ("sonnet" ,sonnet)
- ("threadweaver" ,threadweaver)
- ("ktexteditor" ,ktexteditor)
- ("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("qtscript" ,qtscript)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("plasma" ,plasma-framework)
- ("subversion" ,subversion)
- ("zlib" ,zlib)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
- (setenv "QT_PLUGIN_PATH"
- (string-append out "/lib/plugins:"
- (getenv "QT_PLUGIN_PATH")))
- (setenv "XDG_DATA_DIRS"
- (string-append out "/share:"
- (getenv "XDG_DATA_DIRS")))
- (invoke "ctest" "-R" ; almost all tests require a display
- "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
- (home-page "https://github.com/KDE/kdevplatform")
- (synopsis "Framework to build integrated development environments (IDEs)")
- (description "KDevPlatform is the basis of KDevelop and contains some
-plugins, as well as code to create plugins, or complete applications.")
- (license license:gpl3+)))
+;; kdevplatform was merged into kdevelop as of 5.2.x
+(define-deprecated kdevplatform `kdevelop kdevelop)
(define-public krita
(package
--
2.21.0
E
E
Efraim Flashner wrote on 7 Nov 2019 13:36
Re: [bug#38099] [PATCH 2/3] gnu: kdevelop: Update to 5.4.4.
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 38099@debbugs.gnu.org)
20191107123613.GM14453@E5400
I suggest you try out swapping out the majority of wrap-program and take
a look at wrap-qt-program from (guix build qt-utils), which should take
care of the different qt variables.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3ED70ACgkQQarn3Mo9
g1HpTxAAuVCwEHQqkhlu9RF8GdiLrtuQDr1h9At75+a/4xW9GVfskUWykZ42l9i1
gbqEG15/MHiCfD0xg6/OcirJHUmWeSymB2Eg2awIUEYRwjwWu89rTUrfWnG/Y6Z3
C7xDOSqprj+qbxjpI+FVHtkiFHLRi/ETFwbbfc6ZLWu9lzbeXxNDEox0FagmYXrP
u2zkysq/izNV9932UDDeD0G8dI/kjLHv/Zg+/4PPczV02cqABSA/CbLvDReerTGW
rcR0fRHd131bxTBFEYA/oAbKBjyKWeJpKoW4jTqMdAI4NDSimOyhexZ7y0dIhOL3
/3HlHFUgIg06knmglHSJ+sXIMs7prEw0+gxf+0+a46GokyBubaPp/UidaxIzqyCm
kvfcdL84ZJd7BnJN5Sy6EwLsAi8/CgYZqUUjS0zgEOFwcmYtA4v+UqsrdRNipEdY
l9Zw+4RW6pypSnk9h59LcdaGfwEiZLH7G41AbvYW9FqgCkU/rrCXUDhFAquGzvxI
RGp6YzPrBpSQnEqfTqqzI3RWDwHsxW/XMV9rV/Ec3K0gDyaY5kkxzF/h13j+/rL5
Kd60tTsqGJodqUtfkjIG0HtY9hIB7QSQ5N7i8OXXdpdkc/h4J9ozAoyFWuf46nO/
aRetK82j0vWCtCyZ0WDC+RPWh1Swusl03R2XOt4v0Neunh1xRaQ=
=ZfY9
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 7 Nov 2019 13:37
Re: [bug#38099] [PATCH 3/3] gnu: Deprecate kdevplatform package.
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 38099@debbugs.gnu.org)
20191107123758.GN14453@E5400
On Thu, Nov 07, 2019 at 11:25:50AM +0100, Hartmut Goebel wrote:
Toggle quote (4 lines)
> * gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
> for 'kdevelop`.
> ---

qt-4kdevplatform looks like a typo

Toggle quote (3 lines)
> +;; kdevplatform was merged into kdevelop as of 5.2.x
> +(define-deprecated kdevplatform `kdevelop kdevelop)
>
should probably be
(define-deprecated kdevplatform kdevelop kdevelop)


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3EECYACgkQQarn3Mo9
g1GwgBAAvNpMF28K+XhhsAaLyhL5KubzYIChAD/IgCVxkL9CV7FdORjT5jIA+iLE
j/C3sMTwHHQ/JLxKSnHSanIFNQXsjhIolpFWeI3MilEvbEGEQCMRXUiM0QM7DNuV
P6SCoJYqU/oLgeQLyGLjpqg8I08tC5hcxAsde6gzLBnAtTkVSrsm9ULQ7MC9KyLN
KAOcHVXHPIZL1uypUkNJEmn0nZLqlXWJBDkcsWUQK95UU5WYMZ54ZtrdGYzBi19t
uSzzsVwyE0miVVKzz+7hzMzJ+7qCq4SIBzx09wO/boSSkatZPlCgMM7RRL9fEdIK
qqXXKOZHgs25Xeql48Ko8q3Z6k4T/Bvyfit2q3noRdzie/nWRdk8A5OTNqr3G5qh
VYbj75voJfZ/eHzoMBeu0y2QqkY5BPbza1MypkH0j50kTWjDI4U212hebpTDAUnF
Mk2U/Yj0atQdAxqWbnFGIVFpDcgozIKuSkUfaDe3nAhHAccpv9rIMH1qHEe9orYz
PstkSvdMXj7YplAHjb5lqCIytma4DnMxxIpCwfh2zZGqXFR/rp3UAZSFfby4WT6O
ygiIG2LDQtHEw9XA08cFkyxTF41tcAgURHfnRokC47RBmy8vQNGk6oFbf1Ne5/cX
mIPzgSPGUj6a04bIFHeg+cT/wT9PAAaKwKWZrVq6bNhEzaoqEiE=
=ZCjl
-----END PGP SIGNATURE-----


H
H
Hartmut Goebel wrote on 7 Nov 2019 17:53
Re: [bug#38099] [PATCH 2/3] gnu: kdevelop: Update to 5.4.4.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38099@debbugs.gnu.org)
3dcfbbeb-0abd-d6c2-9c9e-34a409f1e091@crazy-compilers.com
Am 07.11.19 um 13:36 schrieb Efraim Flashner:
Toggle quote (4 lines)
> I suggest you try out swapping out the majority of wrap-program and take
> a look at wrap-qt-program from (guix build qt-utils), which should take
> care of the different qt variables.

wrap-qt-program sound good, but I#m afraid, it is

a) insufficient in this case, since it does not cover
QT_QPA_PLATFORM_PLUGIN_PATH, which seems to require

b) looks faulty, since it adds paths $out/qml and $out/plugins, which
are wrong (even if they exit in e.g. sddm)

But I will model the code here along the lines of wrap-qt-program, thus
easing migration to wrap-qt-program somewhen later.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
H
H
Hartmut Goebel wrote on 7 Nov 2019 18:03
Re: [bug#38099] [PATCH 3/3] gnu: Deprecate kdevplatform package.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38099@debbugs.gnu.org)
26dd81ba-85f3-d4fd-81db-debecdd406a8@crazy-compilers.com
Am 07.11.19 um 13:37 schrieb Efraim Flashner:
Toggle quote (6 lines)
> On Thu, Nov 07, 2019 at 11:25:50AM +0100, Hartmut Goebel wrote:
>> * gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
>> for 'kdevelop`.
>> ---
> qt-4kdevplatform looks like a typo

ACK


Toggle quote (6 lines)
>> +;; kdevplatform was merged into kdevelop as of 5.2.x
>> +(define-deprecated kdevplatform `kdevelop kdevelop)
>>
> should probably be
> (define-deprecated kdevplatform kdevelop kdevelop)

Ups, I inherited this from 02511196d99ebc5e385e9dc7f733ffbe848e25ca.
Going to fix that, too.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
H
H
Hartmut Goebel wrote on 8 Nov 2019 11:41
Re: [bug#38099] [PATCH 2/3] gnu: kdevelop: Update to 5.4.4.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38099@debbugs.gnu.org)
30098a45-b243-2c71-ef6c-4a69fa53baf8@crazy-compilers.com
kdevelop has some other issues, too, which inhibits testing it. Thus
completing the patch will take some time.

qtwebkit: Use sqlite-with-column-metadata.

--

Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
H
H
Hartmut Goebel wrote on 11 Dec 2019 11:57
Re: [bug#38099] gnu: kdevelop: Update to 5.4.4.
(address . 38099-close@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
fb0daea1-7ce4-68b5-fed8-d81dbab04586@crazy-compilers.com
Thanks for the review.

I finally push this as e87b83b62c2d21e0efc4ae62a115405aeef756a6.

I fixed the errors Efrain reported and also based kdevelop on the (new)
qt-build-system) - which avoids `wrap-program` here,

I also took the change and updated to 5.4.5


--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38099@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38099
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch