[PATCH 08/11] gnu: Add r-flowpeaks.

  • Done
  • quality assurance status badge
Details
3 participants
  • Tobias Geerinckx-Rice
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Merged with
Z
Z
zimoun wrote on 24 Jul 2019 20:22
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20190724182204.6818-9-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-flowpeaks): New variable.
---
gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0f023665c2..ab4d9f4075 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4907,3 +4907,26 @@ and to both short and long sequence reads.")
(description
"Identifies cell populations in Flow Cytometry data using non-parametric clustering and segmented-regression-based change point detection. Note: R 2.11.0 or newer is required.")
(license license:artistic2.0)))
+
+(define-public r-flowpeaks
+ (package
+ (name "r-flowpeaks")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "flowPeaks" version))
+ (sha256
+ (base32
+ "1ncz7n6n39svi444yy29ip53398392s3m6z0h2a77rhcnzg456wy"))))
+ (properties `((upstream-name . "flowPeaks")))
+ (build-system r-build-system)
+ (inputs `(("gsl" ,gsl)))
+ (home-page
+ "https://bioconductor.org/packages/flowPeaks")
+ (synopsis
+ "An R package for flow data clustering")
+ (description
+ "This package provides a fast and automatic clustering to classify the cells into subpopulations based on finding the peaks from the overall density function generated by K-means.")
+ (license license:artistic2.0))) ;TODO: artistic1.0 does not exist
+
--
2.21.0
T
T
Tobias Geerinckx-Rice wrote on 24 Jul 2019 20:36
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lfwni8k4.fsf@nckx
merge 36789 36790
merge 36789 36791
merge 36789 36792
merge 36789 36793
merge 36789 36794
merge 36789 36795
merge 36789 36796
merge 36789 36797
merge 36789 36798
merge 36789 36799
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXTilKwAKCRANsP+IT1Vt
efwCAPwMFfiT2lvcwMNzzwkToDSGCWdwSxssz16tTMeFjdOR8QEA/0yecSJc7Tlg
WzetWDVAWg15OT5glks97g4iaGnfGQE=
=Lk9Y
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jul 2019 21:17
Merge 36789 36790
CAJ3okZ2J2BW+HmW+K6ziyED4x4NQb80ucCuf9Mpb+nuVBFT7Qg@mail.gmail.com
merge 36789 36790
thanks
R
R
Ricardo Wurmus wrote on 24 Jul 2019 22:51
Re: [bug#36797] [PATCH 08/11] gnu: Add r-flowpeaks.
(address . zimon.toutoune@gmail.com)(address . 36797@debbugs.gnu.org)
87tvbb9mx3.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (1 lines)
> * gnu/packages/bioconductor.scm (r-flowpeaks): New variable.
[…]
Toggle quote (2 lines)
> + (license license:artistic2.0))) ;TODO: artistic1.0 does not exist

Unfortunately, version 1.0 of the Artistic License is too unclear to be
considered a free license. I have excluded this package from the
set of patches that I’ll apply to the master branch.

--
Ricardo
Z
Z
zimoun wrote on 21 Feb 2020 18:07
patches merged
(address . 36797-done@debbugs.gnu.org)
CAJ3okZ2GnkOKAPNwz8FwmRbZ+W+pYHiwB=xD4qocRuuwEgtM4w@mail.gmail.com
Dear,

All the patches are merged now; except r-flowpeaks. Because this
package use Artistic1.0 which is not enough clear to be considered
"free" [1,2] (GNU's point of view [3]) and upstream are not
responsive, let clean the bug tracker. :-)


All the best,
simon
Closed
?