[PATCH 10/11] gnu: Add r-mixomics.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Merged with
Z
Z
zimoun wrote on 24 Jul 2019 20:22
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20190724182204.6818-11-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-mixomics): New variable.
---
gnu/packages/bioconductor.scm | 54 +++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index dd6570ed17..64625aedd4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4959,3 +4959,57 @@ and to both short and long sequence reads.")
"FlowSOM offers visualization options for cytometry data, by using Self-Organizing Map clustering and Minimal Spanning Trees.")
(license license:gpl2+)))
+(define-public r-mixomics
+ (package
+ (name "r-mixomics")
+ (version "6.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "mixOmics" version))
+ (sha256
+ (base32
+ "1f08jx35amn3sfcmqb96mjxxsm6dnpzhff625z758x1992wj4zsk"))))
+ (properties `((upstream-name . "mixOmics")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-corpcor" ,r-corpcor)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ellipse" ,r-ellipse)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-igraph" ,r-igraph)
+ ("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-rarpack" ,r-rarpack)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-reshape2" ,r-reshape2)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "http://www.mixOmics.org")
+ (synopsis "Omics Data Integration Project")
+ (description
+ "Multivariate methods are well suited to large omics data sets where the
+number of variables (e.g. genes, proteins, metabolites) is much larger than
+the number of samples (patients, cells, mice). They have the appealing
+properties of reducing the dimension of the data by using instrumental
+variables (components), which are defined as combinations of all variables.
+Those components are then used to produce useful graphical outputs that enable
+better understanding of the relationships and correlation structures between
+the different data sets that are integrated. mixOmics offers a wide range of
+multivariate methods for the exploration and integration of biological
+datasets with a particular focus on variable selection. The package proposes
+several sparse multivariate models we have developed to identify the key
+variables that are highly correlated, and/or explain the biological outcome of
+interest. The data that can be analysed with mixOmics may come from high
+throughput sequencing technologies, such as omics data (transcriptomics,
+metabolomics, proteomics, metagenomics etc) but also beyond the realm of
+omics (e.g. spectral imaging). The methods implemented in mixOmics can also
+handle missing values without having to delete entire rows with missing data.
+A non exhaustive list of methods include variants of generalised Canonical
+Correlation Analysis, sparse Partial Least Squares and sparse Discriminant
+Analysis. Recently we implemented integrative methods to combine multiple
+data sets: N-integration with variants of Generalised Canonical Correlation
+Analysis and P-integration with variants of multi-group Partial Least
+Squares.")
+ (license license:gpl2+)))
--
2.21.0
T
T
Tobias Geerinckx-Rice wrote on 24 Jul 2019 20:36
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lfwni8k4.fsf@nckx
merge 36789 36790
merge 36789 36791
merge 36789 36792
merge 36789 36793
merge 36789 36794
merge 36789 36795
merge 36789 36796
merge 36789 36797
merge 36789 36798
merge 36789 36799
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXTilKwAKCRANsP+IT1Vt
efwCAPwMFfiT2lvcwMNzzwkToDSGCWdwSxssz16tTMeFjdOR8QEA/0yecSJc7Tlg
WzetWDVAWg15OT5glks97g4iaGnfGQE=
=Lk9Y
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jul 2019 21:17
Merge 36789 36790
CAJ3okZ2J2BW+HmW+K6ziyED4x4NQb80ucCuf9Mpb+nuVBFT7Qg@mail.gmail.com
merge 36789 36790
thanks
?