[PATCH 02/11] gnu: Add r-kableextra.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Merged with
Z
Z
zimoun wrote on 24 Jul 2019 20:21
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20190724182204.6818-3-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-kableextra): New variable.
---
gnu/packages/cran.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 768a7d09c5..7349a9513e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14557,3 +14557,43 @@ in <arXiv:1802.03426>. This package provides an interface to the UMAP
algorithm in R, including a translation of the original algorithm into R with
minimal dependencies.")
(license license:expat)))
+
+(define-public r-kableextra
+ (package
+ (name "r-kableextra")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "kableExtra" version))
+ (sha256
+ (base32
+ "1nicvw06xsf3a1f5c10mih07b76m2v5s5h165vmz0qx6n1a3492i"))))
+ (properties `((upstream-name . "kableExtra")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-glue" ,r-glue)
+ ("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-readr" ,r-readr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-rvest" ,r-rvest)
+ ("r-scales" ,r-scales)
+ ("r-stringr" ,r-stringr)
+ ("r-viridislite" ,r-viridislite)
+ ("r-webshot" ,r-webshot)
+ ("r-xml2" ,r-xml2)))
+ (home-page
+ "http://haozhu233.github.io/kableExtra/")
+ (synopsis
+ "Construct Complex Table with 'kable' and Pipe Syntax")
+ (description
+ "Build complex HTML or 'LaTeX' tables using 'kable()' from 'knitr' and
+the piping syntax from 'magrittr'. Function 'kable()' is a light weight table
+generator coming from 'knitr'. This package simplifies the way to manipulate
+the HTML or 'LaTeX' codes generated by 'kable()' and allows users to construct
+complex tables and customize styles using a readable syntax.")
+ (license license:expat)))
--
2.21.0
T
T
Tobias Geerinckx-Rice wrote on 24 Jul 2019 20:36
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lfwni8k4.fsf@nckx
merge 36789 36790
merge 36789 36791
merge 36789 36792
merge 36789 36793
merge 36789 36794
merge 36789 36795
merge 36789 36796
merge 36789 36797
merge 36789 36798
merge 36789 36799
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXTilKwAKCRANsP+IT1Vt
efwCAPwMFfiT2lvcwMNzzwkToDSGCWdwSxssz16tTMeFjdOR8QEA/0yecSJc7Tlg
WzetWDVAWg15OT5glks97g4iaGnfGQE=
=Lk9Y
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jul 2019 21:17
Merge 36789 36790
CAJ3okZ2J2BW+HmW+K6ziyED4x4NQb80ucCuf9Mpb+nuVBFT7Qg@mail.gmail.com
merge 36789 36790
thanks
?