[PATCH 0/4] gnu: bap, python-glcontext: Fix hash and update.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
S
S
Simon Tournier wrote on 15 Sep 2023 20:38
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
cover.1694800551.git.zimon.toutoune@gmail.com
Hi,

The package “bap” and “python-glcontext” have hash mismatches. In both cases,
it is because upstream changed the lable tag. The Git tag pointed some
content and now the same Git tag points another content.

The path I follow for fixing this issue: The first patch of each package does
not modify the checksum hash that had been introduced in Guix; the patch just
restore the correspondance with the immutable content.

Since we are here :-) the second patch of each update them to the last version
available – keeping the explicit commit because there is no reason that
upstream will not replace the Git tag again.

*Please note*. Because of the referencing to mutable Git tag as reference for
Guix source package, the packages “bap” and “python-glcontext” for all the
Guix revisions containing the first tag reference (now wrong; pointing to past
content) are now broken forever. They are still installable because they are
still available as substitutes in the build farms but they can vanish at the
next garbage collection of the substitute farms.

Upstream applies the policy they want for their mutable Git tags. They want
to append ’-alpha’ for some pre-release and do not version the pre-release
candidates. Fine. They want to replace the content tagged as a release by
another content and rewrite the tag. Fine.

However, must we know what is the upstream policy when packaging? No.

Therefore, rely on mutable Git tag leads to troubles when it is easy to avoid
them: explicity refer to the commit hash in the Guix definition of the
package. I will open again a discussion about that.

For the record, here some more explanations.

* About bap
===========

If I read correctly, “bap” had been updated to 2.5.0-alpha in Guix with:

404df667e3b06f1e9a416c956e53c03ca3642140
AuthorDate: Sun Jun 19 08:43:00 2022 +0200
CommitDate: Tue Jun 28 19:34:50 2022 +0200

Today, an user gets the source of “bap” because the Guix project still
stores the checkout substitute. But we cannot predict when the store of
the build farms will be garbage collected and this checkout substitute
will disappear, so making this package broken for many Guix revisions.

To be precise, this source of the package “bap” are unreachable by the Guix
recipe since Jul 8 2022! Other said, the source of “bap” was correct only few
days and broken since more than one year, it is unsatisfactory.

Toggle snippet (62 lines)
$ guix build -S bap
/gnu/store/axrfwjm357glpn02dil5zfis8ma51z6w-bap-2.5.0-alpha-checkout

$ guix build -S bap --check
The following derivation will be built:
/gnu/store/931x0yxqr800alglvc3gkqaqkfrgwh1b-bap-2.5.0-alpha-checkout.drv
building /gnu/store/931x0yxqr800alglvc3gkqaqkfrgwh1b-bap-2.5.0-alpha-checkout.drv...
guile: warning: failed to install locale
environment variable `PATH' set to `/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/bin:/gnu/store/78rf44kf4xf6lc01jjy9ci5905j2344l-gzip-1.12/bin:/gnu/store/z45rrcnvcw31h1wbl1zh8hh79jkwv0gs-tar-1.34/bin'
Initialized empty Git repository in /gnu/store/axrfwjm357glpn02dil5zfis8ma51z6w-bap-2.5.0-alpha-checkout/.git/
From https://github.com/BinaryAnalysisPlatform/bap
* tag v2.5.0-alpha -> FETCH_HEAD

[...]

HEAD is now at baa9022 prevents knowledge conflicts on mangled names (#1535)
r:sha256 hash mismatch for /gnu/store/axrfwjm357glpn02dil5zfis8ma51z6w-bap-2.5.0-alpha-checkout:
expected hash: 1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5
actual hash: 0lywz6ld9jmbryf8m4fnq793ylwh34kf5qws6w60ibkhg8wkjhlz
hash mismatch for store item '/gnu/store/axrfwjm357glpn02dil5zfis8ma51z6w-bap-2.5.0-alpha-checkout'
build of /gnu/store/931x0yxqr800alglvc3gkqaqkfrgwh1b-bap-2.5.0-alpha-checkout.drv failed
View build log at '/var/log/guix/drvs/93/1x0yxqr800alglvc3gkqaqkfrgwh1b-bap-2.5.0-alpha-checkout.drv.gz'.
guix build: error: build of `/gnu/store/931x0yxqr800alglvc3gkqaqkfrgwh1b-bap-2.5.0-alpha-checkout.drv' failed

$ git clone https://github.com/BinaryAnalysisPlatform/bap

$ git -C bap checkout v2.5.0-alpha
$ guix hash -rx bap
0lywz6ld9jmbryf8m4fnq793ylwh34kf5qws6w60ibkhg8wkjhlz

$ git -C bap checkout a972f8a419294dfb21847db5172ba58c5d7767eb
$ guix hash -rx bap
1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5

$ git -C bap log --oneline a972f8a419294dfb21847db5172ba58c5d7767eb..v2.5.0-alpha
baa902209ee4 (tag: v2.5.0-alpha) prevents knowledge conflicts on mangled names (#1535)
46c93ca54bba fixes calling convention for ms64 (#1533)
2b789c446e45 improves the main subroutine discovery within glibc runtime (#1532)
c100c28d6a71 makes the ABI processors usable programmatically (#1529)
7e3d4066e98d adds patterns to recognize certain x86 endbr as function starts (#1531)
411c73306e28 turns x86 endbr instructions into nops by default (#1530)
02c953ba034e fixes armv4t name that was missing the arm prefix (#1528)
2af9d9199a6e restructures powerpc targets and reimplements ppc32 eabi (#1526)
4b9932b0612e enables passing arguments by reference (#1525)
5a71fb10683f adds c layouts (#1524)
4d019ce6f267 rewrites mips targets and abi (#1523)
1054959144c0 reimplements ARM ABI specification (#1522)
acbb6d512d4b reimplements x86 targets using the new infrastructure (#1521)
f26063f9b895 adds the high-level calling convention specification language (#1520)
b1f5784684df extends Core Theory with target registration and lookup (#1519)
28e4d883d4e0 uses signed casts for promoting arguments (#1518)
ce62b09cf059 publishes Theory.Target.nicknames and extends Primus Contexts (#1517)
63c79e5b43f2 adds armv8 BFM instructions (#1516)
f07b27040d2c allows target overriding (#1515)
6ef5e3d86259 x86_disasm: support padd instructions (#1513)
577ef721fe21 adds the mmap dependency (#1514)
43b0dcf473d7 Adds more missing Thumb instructions (#1511)
5730f5c21274 adds an example on how to create a monad transformer stack (#1354) (#1510)
096e41eab0d5 restores the old bitvector order, changes the Primus Value order (#1509)


* About python-glcontext
=======================

Toggle snippet (41 lines)
$ guix build -S python-glcontext --check
The following derivation will be built:
/gnu/store/j05qbsnlak0xff4k6dd34yyn20q630w3-python-glcontext-2.4.0-checkout.drv
building /gnu/store/j05qbsnlak0xff4k6dd34yyn20q630w3-python-glcontext-2.4.0-checkout.drv...
guile: warning: failed to install locale
environment variable `PATH' set to `/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/bin:/gnu/store/78rf44kf4xf6lc01jjy9ci5905j2344l-gzip-1.12/bin:/gnu/store/z45rrcnvcw31h1wbl1zh8hh79jkwv0gs-tar-1.34/bin'
Initialized empty Git repository in /gnu/store/iixrcir0g1kidxzwnhbvcmc1l5psyyp7-python-glcontext-2.4.0-checkout/.git/
From https://github.com/moderngl/glcontext
* tag 2.4.0 -> FETCH_HEAD
Note: switching to 'FETCH_HEAD'.

[...]

HEAD is now at 0af21b7 bump to 2.4.0
r:sha256 hash mismatch for /gnu/store/iixrcir0g1kidxzwnhbvcmc1l5psyyp7-python-glcontext-2.4.0-checkout:
expected hash: 0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac
actual hash: 03xpw776pvv8c5n58049yczlkgcqdh9vfcpjlghh3p6cal3yiq8a
hash mismatch for store item '/gnu/store/iixrcir0g1kidxzwnhbvcmc1l5psyyp7-python-glcontext-2.4.0-checkout'
build of /gnu/store/j05qbsnlak0xff4k6dd34yyn20q630w3-python-glcontext-2.4.0-checkout.drv failed
View build log at '/var/log/guix/drvs/j0/5qbsnlak0xff4k6dd34yyn20q630w3-python-glcontext-2.4.0-checkout.drv.gz'.
guix build: error: build of `/gnu/store/j05qbsnlak0xff4k6dd34yyn20q630w3-python-glcontext-2.4.0-checkout.drv' failed

$ git clone https://github.com/moderngl/glcontext

$ for ci in $(git -C glcontext log --format=%H); \
do
git -C glcontext checkout $ci 2>/dev/null ;\
echo $ci $(guix hash -rx glcontext)
done | grep 0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac
beebc1fd08ee850f06f4390be4b280824e383074 0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac

$ git -C glcontext log --oneline beebc1fd08ee850f06f4390be4b280824e383074..0af21b7
0af21b7c8a8c (tag: 2.4.0) bump to 2.4.0
e962e631067d Update build.yml
c6c1b38a3e28 Update publish.yml
8b2d89cd31e6 disable experimental backends
8a6918336869 fix some platform specific typecast issues
001178af0c7d Update publish.yml


Cheers,
simon


Simon Tournier (4):
gnu: bap: Update to 2.5.0-alpha-0.a972f8a.
gnu: bap: Update to 2.6.0-alpha-0.f995d28.
gnu: python-glcontext: Update to 2.4.0-0.beebc1f.
gnu: python-glcontext: Update to 2.4.0-1.0af21b7.

gnu/packages/ocaml.scm | 148 ++++++++++++++++++------------------
gnu/packages/python-xyz.scm | 100 ++++++++++++------------
2 files changed, 128 insertions(+), 120 deletions(-)


base-commit: b696fb41bc0dfcb7130a5aa6d69aff2ae191c283
prerequisite-patch-id: 62fc21d64477426edaa901fdf00d27556cb3ce68
prerequisite-patch-id: 01fbfb50e705a21f272c328e67a682868c52087d
--
2.38.1
S
S
Simon Tournier wrote on 15 Sep 2023 21:10
[PATCH 1/4] gnu: bap: Update to 2.5.0-alpha-0.a972f8a.
(address . 66013@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
89bb3fe4dbd60e640d2614b4e26711fd63c9a669.1694800551.git.zimon.toutoune@gmail.com
* gnu/packages/ocaml.scm (bap): Explicitly refer to commit instead of mutable
Git tag.
---
gnu/packages/ocaml.scm | 147 +++++++++++++++++++++--------------------
1 file changed, 75 insertions(+), 72 deletions(-)

Toggle diff (164 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ff755aea9fb..c026433b0ef1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5324,82 +5324,85 @@ (define-public ocaml-ppx-bap
(license license:expat)))
(define-public bap
- (package
- (name "bap")
- (version "2.5.0-alpha")
- (home-page "https://github.com/BinaryAnalysisPlatform/bap")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5"))))
- (build-system ocaml-build-system)
- (arguments
- (list
- #:use-make? #t
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'configure 'fix-ncurses
- (lambda _
- (substitute* "oasis/llvm"
- (("-lcurses") "-lncurses"))
- #t))
- (replace 'configure
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (for-each make-file-writable (find-files "." "."))
- ;; Package name changed
- (substitute* "oasis/elf-loader"
- (("bitstring.ppx") "ppx_bitstring"))
- ;; We don't have a monolithic llvm
- (substitute* "oasis/llvm.setup.ml.in"
- (("llvm_static = \"true\"") "true"))
- (invoke "./configure" "--prefix"
- (assoc-ref outputs "out")
- "--libdir"
- (string-append
+ (let (;; Let pin one commit because -alpha is subject to change.
+ (revision "0")
+ (commit "a972f8a419294dfb21847db5172ba58c5d7767eb"))
+ (package
+ (name "bap")
+ (version (git-version "2.5.0-alpha" revision commit))
+ (home-page "https://github.com/BinaryAnalysisPlatform/bap")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5"))))
+ (build-system ocaml-build-system)
+ (arguments
+ (list
+ #:use-make? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'fix-ncurses
+ (lambda _
+ (substitute* "oasis/llvm"
+ (("-lcurses") "-lncurses"))
+ #t))
+ (replace 'configure
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (for-each make-file-writable (find-files "." "."))
+ ;; Package name changed
+ (substitute* "oasis/elf-loader"
+ (("bitstring.ppx") "ppx_bitstring"))
+ ;; We don't have a monolithic llvm
+ (substitute* "oasis/llvm.setup.ml.in"
+ (("llvm_static = \"true\"") "true"))
+ (invoke "./configure" "--prefix"
(assoc-ref outputs "out")
- "/lib/ocaml/site-lib")
- (string-append "--with-llvm-version=" #$(package-version llvm))
- "--with-llvm-config=llvm-config"
- "--disable-ghidra"
- "--disable-llvm-static"
- "--enable-llvm"
- "--enable-everything"))))))
- (native-inputs (list clang ocaml-oasis ocaml-ounit))
- (propagated-inputs
- (list
- camlzip
- ocaml-bitstring
- ocaml-cmdliner
- ocaml-core-kernel
- ocaml-ezjsonm
- ocaml-fileutils
- ocaml-frontc
- ocaml-graph
- ocaml-linenoise
- ocaml-ocurl
- ocaml-piqi
- ocaml-ppx-bap
- ocaml-ppx-bitstring
- ocaml-re
- ocaml-uri
- ocaml-utop
- ocaml-uuidm
- ocaml-yojson
- ocaml-z3
- ocaml-zarith))
- (inputs
- (list gmp llvm ncurses))
- (synopsis "Binary Analysis Platform")
- (description "Binary Analysis Platform is a framework for writing program
+ "--libdir"
+ (string-append
+ (assoc-ref outputs "out")
+ "/lib/ocaml/site-lib")
+ (string-append "--with-llvm-version=" #$(package-version llvm))
+ "--with-llvm-config=llvm-config"
+ "--disable-ghidra"
+ "--disable-llvm-static"
+ "--enable-llvm"
+ "--enable-everything"))))))
+ (native-inputs (list clang ocaml-oasis ocaml-ounit))
+ (propagated-inputs
+ (list
+ camlzip
+ ocaml-bitstring
+ ocaml-cmdliner
+ ocaml-core-kernel
+ ocaml-ezjsonm
+ ocaml-fileutils
+ ocaml-frontc
+ ocaml-graph
+ ocaml-linenoise
+ ocaml-ocurl
+ ocaml-piqi
+ ocaml-ppx-bap
+ ocaml-ppx-bitstring
+ ocaml-re
+ ocaml-uri
+ ocaml-utop
+ ocaml-uuidm
+ ocaml-yojson
+ ocaml-z3
+ ocaml-zarith))
+ (inputs
+ (list gmp llvm ncurses))
+ (synopsis "Binary Analysis Platform")
+ (description "Binary Analysis Platform is a framework for writing program
analysis tools, that target binary files. The framework consists of a plethora
of libraries, plugins, and frontends. The libraries provide code reusability,
the plugins facilitate extensibility, and the frontends serve as entry points.")
- (license license:expat)))
+ (license license:expat))))
(define-public ocaml-camomile
(package
--
2.38.1
S
S
Simon Tournier wrote on 15 Sep 2023 21:10
[PATCH 3/4] gnu: python-glcontext: Update to 2.4.0-0.beebc1f.
(address . 66013@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
375535045b489ea3432fe79940db0f36d18021aa.1694800551.git.zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python-glcontext): Explicitly refer to commit
instead of mutable Git tag.
---
gnu/packages/python-xyz.scm | 100 +++++++++++++++++++-----------------
1 file changed, 52 insertions(+), 48 deletions(-)

Toggle diff (114 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2230310a0350..481326b8e162 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22986,55 +22986,59 @@ (define-public python-pyopengl-accelerate
"This is the Cython-coded accelerator module for PyOpenGL.")))
(define-public python-glcontext
- (package
- (name "python-glcontext")
- (version "2.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/moderngl/glcontext")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac"))))
- (build-system pyproject-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-before 'build 'fix-lib-paths
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((mesa (assoc-ref inputs "mesa"))
- (libx11 (assoc-ref inputs "libx11")))
- (substitute* '("glcontext/x11.cpp"
- "glcontext/egl.cpp")
- (("\"libGL.so\"")
- (string-append "\"" mesa "/lib/libGL.so\""))
- (("\"libEGL.so\"")
- (string-append "\"" mesa "/lib/libEGL.so\""))
- (("\"libX11.so\"")
- (string-append "\"" libx11 "/lib/libX11.so\"")))
- (substitute* '("glcontext/__init__.py")
- (("find_library\\('GL'\\)")
- (string-append "'" mesa "/lib/libGL.so'"))
- (("find_library\\('EGL'\\)")
- (string-append "'" mesa "/lib/libEGL.so'"))
- (("find_library\\(\"X11\"\\)")
- (string-append "'" libx11 "/lib/libX11.so'"))))))
- (replace 'check
- (lambda* (#:key inputs outputs tests?
- #:allow-other-keys)
- (when tests?
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "tests")))))))
- (inputs (list libx11 mesa))
- (native-inputs (list xorg-server-for-tests python-pytest python-psutil))
- (home-page "https://github.com/moderngl/glcontext")
- (synopsis "Portable OpenGL Context for ModernGL")
- (description "Python-glcontext is a library providing an OpenGL
+ (let (;; Upstream is known for abusing mutable tag, hence pinpoint the
+ ;; relevant commit.
+ (revision "0")
+ (commit "beebc1fd08ee850f06f4390be4b280824e383074"))
+ (package
+ (name "python-glcontext")
+ (version (git-version "2.4.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moderngl/glcontext")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'fix-lib-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((mesa (assoc-ref inputs "mesa"))
+ (libx11 (assoc-ref inputs "libx11")))
+ (substitute* '("glcontext/x11.cpp"
+ "glcontext/egl.cpp")
+ (("\"libGL.so\"")
+ (string-append "\"" mesa "/lib/libGL.so\""))
+ (("\"libEGL.so\"")
+ (string-append "\"" mesa "/lib/libEGL.so\""))
+ (("\"libX11.so\"")
+ (string-append "\"" libx11 "/lib/libX11.so\"")))
+ (substitute* '("glcontext/__init__.py")
+ (("find_library\\('GL'\\)")
+ (string-append "'" mesa "/lib/libGL.so'"))
+ (("find_library\\('EGL'\\)")
+ (string-append "'" mesa "/lib/libEGL.so'"))
+ (("find_library\\(\"X11\"\\)")
+ (string-append "'" libx11 "/lib/libX11.so'"))))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests?
+ #:allow-other-keys)
+ (when tests?
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "tests")))))))
+ (inputs (list libx11 mesa))
+ (native-inputs (list xorg-server-for-tests python-pytest python-psutil))
+ (home-page "https://github.com/moderngl/glcontext")
+ (synopsis "Portable OpenGL Context for ModernGL")
+ (description "Python-glcontext is a library providing an OpenGL
implementation for ModernGL on multiple platforms.")
- (license license:expat)))
+ (license license:expat))))
(define-public python-rencode
(package
--
2.38.1
S
S
Simon Tournier wrote on 15 Sep 2023 21:10
[PATCH 2/4] gnu: bap: Update to 2.6.0-alpha-0.f995d28.
(address . 66013@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
f9dd88f1bc31dc362e504fe55fb318bf4fbcfec8.1694800551.git.zimon.toutoune@gmail.com
* gnu/packages/ocaml.scm (bap): Update to 2.6.0-alpha-0.f995d28.
---
gnu/packages/ocaml.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c026433b0ef1..0f4b72e29799 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5325,11 +5325,12 @@ (define-public ocaml-ppx-bap
(define-public bap
(let (;; Let pin one commit because -alpha is subject to change.
+ ;; The last stable release v2.5.0 is from July 2022.
(revision "0")
- (commit "a972f8a419294dfb21847db5172ba58c5d7767eb"))
+ (commit "f995d28a4a34abb4cef8e0b3bd3c41cd710ccf1a"))
(package
(name "bap")
- (version (git-version "2.5.0-alpha" revision commit))
+ (version (git-version "2.6.0-alpha" revision commit))
(home-page "https://github.com/BinaryAnalysisPlatform/bap")
(source (origin
(method git-fetch)
@@ -5339,7 +5340,7 @@ (define-public bap
(file-name (git-file-name name version))
(sha256
(base32
- "1fw9pp0xnssc08qqfkcafffap4f46hw7zmk80gif5yc4nazga8w5"))))
+ "1zfkc8nagf8kvxbypalbhf6gs0c7i48zx53hlpak2ipjwhvm5im5"))))
(build-system ocaml-build-system)
(arguments
(list
--
2.38.1
S
S
Simon Tournier wrote on 15 Sep 2023 21:10
[PATCH 4/4] gnu: python-glcontext: Update to 2.4.0-1.0af21b7.
(address . 66013@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
4413530e2475d4e37194e87cf983c883ef2ad3a1.1694800551.git.zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python-glcontext): Update to 2.4.0-1.0af21b7.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 481326b8e162..fc6caf93912c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22988,8 +22988,8 @@ (define-public python-pyopengl-accelerate
(define-public python-glcontext
(let (;; Upstream is known for abusing mutable tag, hence pinpoint the
;; relevant commit.
- (revision "0")
- (commit "beebc1fd08ee850f06f4390be4b280824e383074"))
+ (revision "1")
+ (commit "0af21b7c8a8cc0e76f4d9aff6a4f156f43d37333"))
(package
(name "python-glcontext")
(version (git-version "2.4.0" revision commit))
@@ -23001,7 +23001,7 @@ (define-public python-glcontext
(file-name (git-file-name name version))
(sha256
(base32
- "0zzpwyqg19y600n09xz07cxk4jimh9vjraszda7g7ipijq6iasac"))))
+ "03xpw776pvv8c5n58049yczlkgcqdh9vfcpjlghh3p6cal3yiq8a"))))
(build-system pyproject-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
--
2.38.1
S
S
Simon Tournier wrote on 22 Sep 2023 16:00
Re: [bug#66013] [PATCH 0/4] gnu: bap, python-glcontext: Fix hash and update.
(address . 66013-done@debbugs.gnu.org)
87pm2a8g0v.fsf@gmail.com
Hi,

On Fri, 15 Sep 2023 at 20:38, Simon Tournier <zimon.toutoune@gmail.com> wrote:

Toggle quote (10 lines)
> Simon Tournier (4):
> gnu: bap: Update to 2.5.0-alpha-0.a972f8a.
> gnu: bap: Update to 2.6.0-alpha-0.f995d28.
> gnu: python-glcontext: Update to 2.4.0-0.beebc1f.
> gnu: python-glcontext: Update to 2.4.0-1.0af21b7.
>
> gnu/packages/ocaml.scm | 148 ++++++++++++++++++------------------
> gnu/packages/python-xyz.scm | 100 ++++++++++++------------
> 2 files changed, 128 insertions(+), 120 deletions(-)

After one week waiting after QA, the series was not moving in the queue,
seeing patches sent after this one but processed before, asked on #guix
[1] why, then I am applying this series.

Done with 47ba771548b50914895448552b7f85973694d579 to
ec130e1a1b7f3b87b1a6e626754f7e7a07f6b717.


Cheers,
simon
Closed
?