(address . guix-patches@gnu.org)(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
Magit has a strong dependency on Git so it should directly reference the
git executable rather than expect it to be available in the profile or
environment.
This also fixes a build failure in emacs-forge.
* gnu/packages/emacs-xyz.scm (emacs-magit)[arguments]<#:phases>: Substitute
git path in the ‘magit-git-executable’ variable.
---
gnu/packages/emacs-xyz.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ff6275bad96..1406f8a715f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -117,6 +117,7 @@
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1031,7 +1032,11 @@ (define-public emacs-magit
("magit-version" #$version))))
(add-after 'set-magit-version 'patch-exec-paths
(lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "lisp/magit-sequence.el")
+ (for-each make-file-writable
+ (list "lisp/magit-git.el" "lisp/magit-sequence.el"))
+ (emacs-substitute-variables "lisp/magit-git.el"
+ ("magit-git-executable"
+ (search-input-file inputs "/bin/git")))
(emacs-substitute-variables "lisp/magit-sequence.el"
("magit-perl-executable"
(search-input-file inputs "/bin/perl")))))