[PATCH master 0/3] Add Tilda with D-Bus support (necessary for Wayland)

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Suhail
Owner
unassigned
Submitted by
Suhail
Severity
normal
S
S
Suhail wrote on 19 Oct 2023 22:39
(name . guix patches mailing list)(address . guix-patches@gnu.org)
cover.1697744965.git.suhail@bayesians.ca
Hi Guix,

The last official release of Tilda (1.5.4) is almost 3 years old and
notably doesn't include D-Bus support (which is necessary on Wayland).
D-Bus support was added to upstream (main branch) in 2021, however,
there hasn't been a release, since, that has included it.

This series adds version 1.6-alpha with D-Bus support to Guix. There
are some changes in 1.5.4 that aren't (yet?) included in the 1.6-alpha
branch. As such, a new package definition is created for 1.6-alpha (as
opposed to only updating the 1.5.4 version).

Additionally, some issues pointed out by 'guix lint' and 'guix style'
for tilda@1.5.4 are fixed.

Cheers

Suhail (3):
gnu: tilda: Add version 1.6-alpha with D-Bus support
gnu: tilda: Fix lint error by updating input list format for v1.5.4
gnu: tilda: Run guix style on tilda@1.5.4

gnu/packages/terminals.scm | 64 ++++++++++++++++++++++++--------------
1 file changed, 41 insertions(+), 23 deletions(-)


base-commit: c065da01ff956d3c2bdfc45a33d910e509a211d9
--
2.42.0
S
S
Suhail wrote on 20 Oct 2023 21:51
[PATCH master 1/3] gnu: tilda: Add version 1.6-alpha with D-Bus support
(address . 66644@debbugs.gnu.org)
a309f174b07e259eaf2f4af5cdc747f0a9123a5b.1697747918.git.suhail@bayesians.ca
* gnu/packages/terminals.scm (tilda-dbus): New variable.
---
gnu/packages/terminals.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 989fd00e61..0c06a42213 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -187,6 +187,29 @@ (define-public tilda
(home-page "https://github.com/lanoxx/tilda")
(license license:gpl2+)))
+(define-public tilda-dbus
+ (package
+ (inherit tilda)
+ (name "tilda")
+ (version "1.6-alpha")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lanoxx/tilda")
+ (commit "51a980a55ad6d750daa21d43a66d44577dad277b")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pdarmlxkap9v689s88b89l5hi4vspsrrysh7pbm9rhdjmzk5m2c"))))
+ (synopsis "GTK+-based drop-down terminal with experimental D-Bus support")
+ (description
+ "Tilda is a terminal emulator similar to normal terminals like
+gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
+from the edge of a screen when a certain configurable hotkey is pressed. This
+is similar to the built-in consoles in some applications. Tilda is highly
+configurable through a graphical wizard. This version enables D-Bus support
+which is necessary for using Tilda on Wayland.")))
+
(define-public termite
(package
(name "termite")
--
2.42.0
S
S
Suhail wrote on 20 Oct 2023 21:53
[PATCH master 2/3] gnu: tilda: Fix lint error by updating input list format for v1.5.4
(address . 66644@debbugs.gnu.org)
96a41987e7f8ac1a0b4a9c8695def8cbfc9ca011.1697747918.git.suhail@bayesians.ca
* gnu/packages/terminals.scm (tilda)[native-inputs]: Use updated format.
---
gnu/packages/terminals.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 0c06a42213..6d5bd8bff7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -172,10 +172,7 @@ (define-public tilda
(for-each make-file-writable (find-files "po" "."))
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake gettext-minimal pkg-config))
(inputs
(list libconfuse vte))
(synopsis "GTK+-based drop-down terminal")
--
2.42.0
S
S
Suhail wrote on 20 Oct 2023 21:54
[PATCH master 3/3] gnu: tilda: Run guix style on tilda@1.5.4
(address . 66644@debbugs.gnu.org)
f823a4816061eb3d0da5edde44d2967aa447b6de.1697747918.git.suhail@bayesians.ca
* gnu/packages/terminals.scm (tilda): Re-indent.
---
gnu/packages/terminals.scm | 38 ++++++++++++++++++--------------------
1 file changed, 18 insertions(+), 20 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 6d5bd8bff7..a0eac00571 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -154,29 +154,27 @@ (define-public tilda
(package
(name "tilda")
(version "1.5.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lanoxx/tilda")
- (commit (string-append "tilda-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0q2i9ny8sh7zjzgvkx8vcvk593wcvchjc4xq4nrlqdd377r7cg5q"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lanoxx/tilda")
+ (commit (string-append "tilda-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q2i9ny8sh7zjzgvkx8vcvk593wcvchjc4xq4nrlqdd377r7cg5q"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-po-writable
- (lambda _
- (for-each make-file-writable (find-files "po" "."))
- #t)))))
- (native-inputs
- (list autoconf automake gettext-minimal pkg-config))
- (inputs
- (list libconfuse vte))
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'make-po-writable
+ (lambda _
+ (for-each make-file-writable
+ (find-files "po" ".")) #t)))))
+ (native-inputs (list autoconf automake gettext-minimal pkg-config))
+ (inputs (list libconfuse vte))
(synopsis "GTK+-based drop-down terminal")
- (description "Tilda is a terminal emulator similar to normal terminals like
+ (description
+ "Tilda is a terminal emulator similar to normal terminals like
gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
from the edge of a screen when a certain configurable hotkey is pressed. This
is similar to the built-in consoles in some applications. Tilda is highly
--
2.42.0
L
L
Ludovic Courtès wrote on 22 Nov 2023 15:48
Re: [bug#66644] [PATCH master 0/3] Add Tilda with D-Bus support (necessary for Wayland)
(name . Suhail)(address . suhail@bayesians.ca)(address . 66644-done@debbugs.gnu.org)
87bkbllu8o.fsf@gnu.org
Hi,

Suhail <suhail@bayesians.ca> skribis:

Toggle quote (4 lines)
> gnu: tilda: Add version 1.6-alpha with D-Bus support
> gnu: tilda: Fix lint error by updating input list format for v1.5.4
> gnu: tilda: Run guix style on tilda@1.5.4

Finally applied, thanks!

Ludo’.
Closed
?