[PATCH] gnu: renpy: fix image reference paths.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jesse Gibbons
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 29 Jul 2023 02:42
(address . guix-patches@gnu.org)
768b086d-b386-1eb1-8e73-180daac92da4@gmail.com
Guix,

The current version of renpy has errors when generating a basic project
due to a substitution in the `drop-game-from-paths` phase that changes
too much. Attached is a patch that fixes this problem.

I do not know if there is a related bug report.

Thanks.

--
-Jesse Gibbons
From 60c49e320b6e3411eff834883ea0f733f75d8c2d Mon Sep 17 00:00:00 2001
From: Jesse <jessegibbons@outlook.com>
Date: Fri, 28 Jul 2023 17:50:06 -0600
Subject: [PATCH] gnu: renpy: fix image reference paths.

gnu/packages/game-development.scm: (renpy) fix image reference paths.
---
gnu/packages/game-development.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..11ecc7e52c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1458,7 +1458,7 @@ (define-public renpy
(lambda _
(substitute* (list "launcher/game/gui7.rpy"
"launcher/game/gui7/images.py")
- ((", \"game\",") ","))
+ ((", \"game\", \"gui7\",") ", \"gui7\","))
#t))
(add-before 'build 'start-xserver
(lambda* (#:key inputs native-inputs #:allow-other-keys)
@@ -3222,3 +3222,4 @@ (define-public bbcsdl
allowing you to write utilities and games, use sound and graphics, perform
calculations and create complete applications.")
(license license:zlib)))
+renpy
--
2.41.0
J
J
Jesse Gibbons wrote on 29 Jul 2023 15:37
(address . 64925@debbugs.gnu.org)
2f7ad2e8-ea79-c9a4-39c5-f5714a76b798@gmail.com
The previous patch sent has an artifact from my development. Attached is
a newer, better patch.

--
-Jesse Gibbons
From 1ffd3f720978b053efe3e76b0d5a47ca2b866a01 Mon Sep 17 00:00:00 2001
From: Jesse <jessegibbons@outlook.com>
Date: Fri, 28 Jul 2023 17:50:06 -0600
Subject: [PATCH] gnu: renpy: fix image reference paths.

gnu/packages/game-development.scm: (renpy) fix image reference paths.
---
gnu/packages/game-development.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..f4b1a1e1e3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1458,7 +1458,7 @@ (define-public renpy
(lambda _
(substitute* (list "launcher/game/gui7.rpy"
"launcher/game/gui7/images.py")
- ((", \"game\",") ","))
+ ((", \"game\", \"gui7\",") ", \"gui7\","))
#t))
(add-before 'build 'start-xserver
(lambda* (#:key inputs native-inputs #:allow-other-keys)
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Jul 2023 16:32
Re: [PATCH] gnu: renpy: fix image reference paths.
b9a3d4e76dd1742fbd64bf42c96e8bb17f45f72b.camel@gmail.com
Am Freitag, dem 28.07.2023 um 18:42 -0600 schrieb Jesse Gibbons:
Toggle quote (5 lines)
> Guix,
>
> The current version of renpy has errors when generating a basic
> project due to a substitution in the `drop-game-from-paths` phase
> that changes too much. Attached is a patch that fixes this problem.
Could you do a comparison of 'tree' when invoked on a game created with
unpatched renpy vs. patched renpy?

Cheers
J
J
Jesse Gibbons wrote on 29 Jul 2023 18:25
a235b809-ee63-247e-fb25-72669f78f8bb@gmail.com
I should probably point out that I did my research when producing this
patch and made not of it in the IRC. I would have removed the
drop-game-from-paths phase if that didn't result in a similar error to
the one reported from renpy before the patch is applied to guix.

--
-Jesse Gibbons
J
J
Jesse Gibbons wrote on 29 Jul 2023 18:39
Fwd: [PATCH] gnu: renpy: fix image reference paths.
(address . 64925@debbugs.gnu.org)
3934b1e4-2173-c416-1445-fbaa41763cd6@gmail.com
I have not been able to verify that this was sent other than that my
mail client says it was. I sent a follow-up that I can verify actually
was received and should make more sense after reading this.



-------- Forwarded Message --------
Subject: Re: [PATCH] gnu: renpy: fix image reference paths.
Date: Sat, 29 Jul 2023 10:12:11 -0600
From: Jesse Gibbons <jgibbons2357@gmail.com>
To: Liliana Marie Prikler <liliana.prikler@gmail.com>,
64925@debbugs.gnu.org




On 7/29/23 08:32, Liliana Marie Prikler wrote:
Toggle quote (9 lines)
> Am Freitag, dem 28.07.2023 um 18:42 -0600 schrieb Jesse Gibbons:
>> Guix,
>>
>> The current version of renpy has errors when generating a basic
>> project due to a substitution in the `drop-game-from-paths` phase
>> that changes too much. Attached is a patch that fixes this problem.
> Could you do a comparison of 'tree' when invoked on a game created with
> unpatched renpy vs. patched renpy?

Is this to prove that the patch fixes a problem? Ok.

`guix time-machine --commit=3bb3fddb5c6e79056172e5858cdc0ee0b6b8cfaa --
shell --pure renpy -- renpy-launcher`

The launcher window pops up. I click "create new project" and call it
"vanilla". I go with all the defaults. It reports an error in the
attached screenshot.


In a clone of the repository, I check out
3bb3fddb5c6e79056172e5858cdc0ee0b6b8cfaa and apply the most recent
patch. I also make sure the last line of
gnu/packages/game-development.scm is renpy.

`guix shell --pure -f gnu/packages/game-development.scm -- renpy-launcher`

A window pops up. I click "create new project" and call it "chocolate".
I go with all the defaults. The window does not report an error.

In the directory I set renpy to put all the projects, I run
`diff --recursive chocolate/ vanilla/ | tee generated-dir-differences.diff`

The output is attached. Is there anything else you want me to do before
you accept the patch?

--
-Jesse Gibbons
Attachment: file
Only in chocolate/game: audio
Only in chocolate/game: cache
Only in chocolate/game/gui: bar
Only in chocolate/game/gui: bubble.png
Only in chocolate/game/gui/button: check_foreground.png
Only in chocolate/game/gui/button: check_selected_foreground.png
Only in chocolate/game/gui/button: hover_background.png
Only in chocolate/game/gui/button: idle_background.png
Only in chocolate/game/gui/button: radio_foreground.png
Only in chocolate/game/gui/button: radio_selected_foreground.png
Only in chocolate/game/gui/button: slot_hover_background.png
Only in chocolate/game/gui/button: slot_idle_background.png
Only in chocolate/game/gui/phone: bar
Only in chocolate/game/gui/phone/button: check_foreground.png
Only in chocolate/game/gui/phone/button: check_selected_foreground.png
Only in chocolate/game/gui/phone/button: hover_background.png
Only in chocolate/game/gui/phone/button: idle_background.png
Only in chocolate/game/gui/phone/button: radio_foreground.png
Only in chocolate/game/gui/phone/button: radio_selected_foreground.png
Only in chocolate/game/gui/phone/button: slot_hover_background.png
Only in chocolate/game/gui/phone/button: slot_idle_background.png
Only in chocolate/game/gui/phone: scrollbar
Only in chocolate/game/gui/phone: slider
Only in chocolate/game/gui: scrollbar
Only in chocolate/game/gui: slider
Only in chocolate/game/gui: thoughtbubble.png
Only in chocolate/game: gui.rpy
Only in chocolate/game: gui.rpyc
Only in chocolate/game: images
Only in chocolate/game: log.txt
Only in chocolate/game: options.rpy
Only in chocolate/game: options.rpyc
Only in chocolate/game: saves
Only in chocolate/game: screens.rpy
Only in chocolate/game: screens.rpyc
Only in chocolate/game: script.rpy
Only in chocolate/game: script.rpyc
Only in chocolate/game: tl
L
L
Liliana Marie Prikler wrote on 30 Jul 2023 07:56
Re: [PATCH] gnu: renpy: fix image reference paths.
ff177b2229d4a7ed2547257e0b56af259fb81b95.camel@gmail.com
Am Samstag, dem 29.07.2023 um 10:12 -0600 schrieb Jesse Gibbons:
Toggle quote (1 lines)
> Is there anything else you want me to do before you accept the patch?
Nope. I've run some own checks as well, edited the commit message and
pushed it.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64925@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64925
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch