(address . guix-patches@gnu.org)
Guix,
The current version of renpy has errors when generating a basic project
due to a substitution in the `drop-game-from-paths` phase that changes
too much. Attached is a patch that fixes this problem.
I do not know if there is a related bug report.
Thanks.
--
-Jesse Gibbons
From 60c49e320b6e3411eff834883ea0f733f75d8c2d Mon Sep 17 00:00:00 2001
From: Jesse <jessegibbons@outlook.com>
Date: Fri, 28 Jul 2023 17:50:06 -0600
Subject: [PATCH] gnu: renpy: fix image reference paths.
gnu/packages/game-development.scm: (renpy) fix image reference paths.
---
gnu/packages/game-development.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (20 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..11ecc7e52c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1458,7 +1458,7 @@ (define-public renpy
(lambda _
(substitute* (list "launcher/game/gui7.rpy"
"launcher/game/gui7/images.py")
- ((", \"game\",") ","))
+ ((", \"game\", \"gui7\",") ", \"gui7\","))
#t))
(add-before 'build 'start-xserver
(lambda* (#:key inputs native-inputs #:allow-other-keys)
@@ -3222,3 +3222,4 @@ (define-public bbcsdl
allowing you to write utilities and games, use sound and graphics, perform
calculations and create complete applications.")
(license license:zlib)))
+renpy
--
2.41.0