[PATCH] Replaced Pumpa origin (https://issues.guix.gnu.org/52257)

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Sarthak Shah
  • Simon Tournier
Owner
unassigned
Submitted by
Sarthak Shah
Severity
normal
S
S
Sarthak Shah wrote on 2 Mar 2023 03:29
(address . guix-patches@gnu.org)
CADBZEVmtvbBFoOo6SuDZC15L9xm1+J7OD=3ZwMsnnbYhCWxzAg@mail.gmail.com
---
gnu/packages/pumpio.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index 2f4dd359d1..0c27041f5b 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -35,7 +35,7 @@ (define-public pumpa
(source (origin
(method git-fetch) ; no source tarballs
(uri (git-reference
- (url "git://pumpa.branchable.com/")
+ (url "https://source.pumpa.branchable.com/")
(commit (string-append "v" version))))
(sha256
(base32

base-commit: 7dc190f83ed29ca7e556700de13a3101e73ec745
--
2.39.1
Attachment: file
S
S
Simon Tournier wrote on 8 Mar 2023 18:19
86v8jbb1ow.fsf@gmail.com
Hi,

I miss a commit message which respects ChangeLog format; as documented
by the section ’(guix) Submitting Patches’ of the manual. Please take
inspiration with other commits. :-)

Cheers,
simon
S
S
Sarthak Shah wrote on 8 Mar 2023 19:19
[PATCH] Revised patch that respects changelog format
(address . 61906@debbugs.gnu.org)
CADBZEVkJQars83HDvWpHxy4HCTipQJu+KqDckALUGJr5GkMn7Q@mail.gmail.com
* gnu/packages/pumio.scm (pumpa): Replace pumpa origin
---
gnu/packages/pumpio.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index 2f4dd359d1..0c27041f5b 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -35,7 +35,7 @@ (define-public pumpa
(source (origin
(method git-fetch) ; no source tarballs
(uri (git-reference
- (url "git://pumpa.branchable.com/")
+ (url "https://source.pumpa.branchable.com/")
(commit (string-append "v" version))))
(sha256
(base32

base-commit: 7dc190f83ed29ca7e556700de13a3101e73ec745
--
Attachment: file
S
S
Simon Tournier wrote on 9 Mar 2023 10:57
[PATCH v3] gnu: pumpa: Update upsream URL.
(address . 61906@debbugs.gnu.org)(address . shahsarthakw@gmail.com)
20230309095729.30876-1-zimon.toutoune@gmail.com
From: Sarthak Shah <shahsarthakw@gmail.com>


* gnu/packages/pumio.scm (pumpa)[source]: Replace pumpa origin.
---
gnu/packages/pumpio.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index 5fb6e338e8..dc5e1ec7bb 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -35,7 +35,7 @@ (define-public pumpa
(source (origin
(method git-fetch) ; no source tarballs
(uri (git-reference
- (url "git://pumpa.branchable.com/")
+ (url "https://source.pumpa.branchable.com/")
(commit (string-append "v" version))))
(sha256
(base32

base-commit: 203578eef286f3b44cd82fd2eb965a828e21fbe7
--
2.38.1
S
S
Simon Tournier wrote on 9 Mar 2023 11:02
Re: [bug#61906] [PATCH] Revised patch that respects changelog format
86fsaensy6.fsf@gmail.com
Hi,

Please see v3 for nitpicking. :-) But since it is a more than trivial
patch, the only interesting part is the nitpicking part.


1. Since the Subject line is the Commit headline, it must also respect
the format. When modifying a package, it is:

gnu: packag-name: One line summarizing the change.

On Wed, 08 Mar 2023 at 23:49, Sarthak Shah <shahsarthakw@gmail.com> wrote:

Toggle quote (2 lines)
> * gnu/packages/pumio.scm (pumpa): Replace pumpa origin

2. The ChangeLog format ends with a period. --^


Cheers,
simon
S
S
Sarthak Shah wrote on 9 Mar 2023 12:14
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 61906@debbugs.gnu.org)
CADBZEVkNXT1SW6X1AfR9RZFU=rVNQA9WDK_=EFR8u5E-1Mjq4w@mail.gmail.com
Got it, thank you for your patience.
I guess it won't be necessary as you have already sent a corrected patch,
but should I resend my commit with the required fixes?

On Thu, Mar 9, 2023 at 3:32?PM Simon Tournier <zimon.toutoune@gmail.com>
wrote:

Toggle quote (21 lines)
> Hi,
>
> Please see v3 for nitpicking. :-) But since it is a more than trivial
> patch, the only interesting part is the nitpicking part.
>
>
> 1. Since the Subject line is the Commit headline, it must also respect
> the format. When modifying a package, it is:
>
> gnu: packag-name: One line summarizing the change.
>
> On Wed, 08 Mar 2023 at 23:49, Sarthak Shah <shahsarthakw@gmail.com> wrote:
>
> > * gnu/packages/pumio.scm (pumpa): Replace pumpa origin
>
> 2. The ChangeLog format ends with a period. --^
>
>
> Cheers,
> simon
>
Attachment: file
L
L
Ludovic Courtès wrote on 13 Mar 2023 14:49
Re: bug#61906: [PATCH] Replaced Pumpa origin (https://issues.guix.gnu.org/52257)
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
874jqo3gn4.fsf_-_@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (6 lines)
> From: Sarthak Shah <shahsarthakw@gmail.com>
>
> Fixes <http://issues.guix.gnu.org/issue/52257>.
>
> * gnu/packages/pumio.scm (pumpa)[source]: Replace pumpa origin.

Applied, thanks to the two of you!

Ludo’.
Closed
?