Broken graft on clang-toolchain

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
Merged with
G
G
Greg Hogan wrote on 5 Jan 2023 22:11
(address . bug-guix@gnu.org)
CA+3U0ZnVHqjmHL2-BBd3zhpWpdj_zMiW+2Wfnry9qN=Q3DiB0w@mail.gmail.com
The recent zlib graft (from 1.2.11 to 1.2.12) is broken when grafting
clang-toolchain. The symbolic link points to the correct directory but
the incorrect file version.

Toggle snippet (8 lines)
$ guix package -m development.scm
...
build of /gnu/store/r8088hz3i9gz5543ajdk2qv5ngblawk3-clang-toolchain-15.0.5.drv
failed
View build log at
'/var/log/guix/drvs/r8/088hz3i9gz5543ajdk2qv5ngblawk3-clang-toolchain-15.0.5.drv.gz'.

Toggle snippet (44 lines)
$ zcat /var/log/guix/drvs/r8/088hz3i9gz5543ajdk2qv5ngblawk3-clang-toolchain-15.0.5.drv.gz
grafting '/gnu/store/nzi37a18qxaxzns50dgvnb53z55rjpbv-clang-toolchain-15.0.5-debug'
-> '/gnu/store/k82qkqqi1h6z604ng00c7rv104aylv1x-clang-toolchain-15.0.5-debug'...
grafting '/gnu/store/q6qdzivkmxa4c8k6dk7z2yivsz8m26vz-clang-toolchain-15.0.5'
-> '/gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5'...
grafting '/gnu/store/bpwxrgdxr9zym16c3clbdhhnm82mrzm2-clang-toolchain-15.0.5-static'
-> '/gnu/store/ccy8jw83j11y02d74q4vs1lzsp5xn7c7-clang-toolchain-15.0.5-static'...
Backtrace:
In ice-9/boot-9.scm:
160: 13 [catch #t #<catch-closure 7ffff5ce7c00> ...]
In unknown file:
?: 12 [apply-smob/1 #<catch-closure 7ffff5ce7c00>]
In ice-9/boot-9.scm:
66: 11 [call-with-prompt prompt0 ...]
In ice-9/eval.scm:
432: 10 [eval # #]
In ice-9/boot-9.scm:
2412: 9 [save-module-excursion #<procedure 7ffff5d087c0 at
ice-9/boot-9.scm:4084:3 ()>]
4089: 8 [#<procedure 7ffff5d087c0 at ice-9/boot-9.scm:4084:3 ()>]
1734: 7 [%start-stack load-stack ...]
1739: 6 [#<procedure 7ffff5d1a6c0 ()>]
In unknown file:
?: 5 [primitive-load
"/gnu/store/qnpvxpxdc6lciqbny3pp5b3c5zl20lsh-clang-toolchain-15.0.5-builder"]
In srfi/srfi-1.scm:
616: 4 [for-each #<procedure 7ffff5665980 at
guix/build/graft.scm:445:12 (hook)> #]
In guix/build/debug-link.scm:
195: 3 [graft-debug-links (# # #) (# # #) (# # # # ...) ...]
In srfi/srfi-1.scm:
643: 2 [append-map #<procedure 7ffff5b3b780 at
guix/build/debug-link.scm:177:14 (directory)> ...]
575: 1 [map #<procedure 7ffff5b3b780 at
guix/build/debug-link.scm:177:14 (directory)> ...]
In unknown file:
?: 0 [filter #<procedure 7ffff581e1e0 at guix/build/utils.scm:278:2
(file)> #]

ERROR: In procedure filter:
ERROR: In procedure open-file: No such file or directory:
"/gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5/lib/libz.so.1.2.11"

Toggle snippet (6 lines)
$ ll /gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5/lib/libz.so.1.2.11
lrwxrwxrwx 1 guixbuilder01 guixbuild 74 Jan 5 19:19
/gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5/lib/libz.so.1.2.11
-> /gnu/store/v8d7j5i02nfz951x1szbl9xrd873vc3l-zlib-1.2.12/lib/libz.so.1.2.11

Toggle snippet (7 lines)
$ ll /gnu/store/v8d7j5i02nfz951x1szbl9xrd873vc3l-zlib-1.2.12/lib/
total 116
lrwxrwxrwx 1 root root 14 Jan 1 1970 libz.so -> libz.so.1.2.12
lrwxrwxrwx 1 root root 14 Jan 1 1970 libz.so.1 -> libz.so.1.2.12
-r-xr-xr-x 2 root root 117216 Jan 1 1970 libz.so.1.2.12
dr-xr-xr-x 2 root root 21 Jan 1 1970 pkgconfig
L
L
Leo Famulari wrote on 6 Jan 2023 02:14
(name . Greg Hogan)(address . code@greghogan.com)(address . 60584@debbugs.gnu.org)
Y7d16NdUxOupYy9P@jasmine.lan
On Thu, Jan 05, 2023 at 04:11:45PM -0500, Greg Hogan wrote:
Toggle quote (11 lines)
> The recent zlib graft (from 1.2.11 to 1.2.12) is broken when grafting
> clang-toolchain. The symbolic link points to the correct directory but
> the incorrect file version.

> --8<---------------cut here---------------start------------->8---
> $ ll /gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5/lib/libz.so.1.2.11
> lrwxrwxrwx 1 guixbuilder01 guixbuild 74 Jan 5 19:19
> /gnu/store/f1gc5894gsgc5v2b4zhmpll9yg1bmgl0-clang-toolchain-15.0.5/lib/libz.so.1.2.11
> -> /gnu/store/v8d7j5i02nfz951x1szbl9xrd873vc3l-zlib-1.2.12/lib/libz.so.1.2.11
> --8<---------------cut here---------------end--------------->8---

Huh! Any idea why?
L
L
Leo Famulari wrote on 17 Jan 2023 13:15
(no subject)
(address . control@debbugs.gnu.org)
Y8aRbx4XeKToNbVr@jasmine.lan
merge 60584 60875
L
L
Ludovic Courtès wrote on 17 Jan 2023 16:13
Re: bug#60875: Grafting breaks with clang-toolchain@13
(name . Leo Famulari)(address . leo@famulari.name)
873589gpna.fsf@gnu.org
Hi,

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (12 lines)
> On Tue, Jan 17, 2023 at 11:23:42AM +0100, Ludovic Courtès wrote:
>> The file exists but it’s a dangling symlink:
>>
>> --8<---------------cut here---------------start------------->8---
>> $ ls -l /gnu/store/12wnswvdc1mk9cr498dxflxim4qm2pyq-clang-toolchain-13.0.1/lib/libz.so.1.2.11
>> lrwxrwxrwx 1 guixbuilder01 guixbuild 74 Jan 17 10:36 /gnu/store/12wnswvdc1mk9cr498dxflxim4qm2pyq-clang-toolchain-13.0.1/lib/libz.so.1.2.11 -> /gnu/store/v8d7j5i02nfz951x1szbl9xrd873vc3l-zlib-1.2.12/lib/libz.so.1.2.11
>> $ stat -L /gnu/store/12wnswvdc1mk9cr498dxflxim4qm2pyq-clang-toolchain-13.0.1/lib/libz.so.1.2.11
>> stat: cannot statx '/gnu/store/12wnswvdc1mk9cr498dxflxim4qm2pyq-clang-toolchain-13.0.1/lib/libz.so.1.2.11': No such file or directory
>> --8<---------------cut here---------------end--------------->8---
>
> Merged with <https://issues.guix.gnu.org/issue/60584>

Fixed in c4a8762e529dc3f8af89dde5dbcbb82f2a4088a3.

Now it would be good to see why ‘clang-toolchain’ has this dangling
symlink.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60584@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60584
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch