issue with emacs-lua-mode and emacs-next
(address . bug-guix@gnu.org)
Hi,
When I launch emacs (emacs-next) with the emacs-lua-mode package, I'm
getting this error
"Error (use-package): lua-mode/:catch: Unknown rx form ‘symbol’"
It works when I let emacs download it from melpa. I tried updating
emacs-lua-mode to 20200508, which is the same version as on melpa.
Still the same issue.
Could this be an issue that it's using emacs-minimal-26.3 to byte compile
the files? Where I'm using emacs-next aka emasc-27.0. Judging by this issue
[1] the rx package has gone through some changes in 27.0.
My emacs config is here: https://github.com/plattfot/dotemacs/tree/emacs27
I've attached the backtrace and the patch for the latest emacs-lua-mode.
Thanks
--
s/Fred[re]+i[ck]+/Fredrik/g
From 1ef949ea0a9bdec2bdf42c0314b8e8e01acff72d Mon Sep 17 00:00:00 2001
From: Fredrik Salomonsson <plattfot@gmail.com>
Date: Fri, 5 Jun 2020 19:39:37 -0700
Subject: [PATCH] gnu: emacs-lua-mode: Update to 20200508-0.35b6e4c.
* gnu/packages/emacs-xyz.scm (emacs-lua-mode): Update to 20200508-0.35b6e4c.
---
gnu/packages/emacs-xyz.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6110374281..e2d91918e8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8292,11 +8292,11 @@ using package inferred style.")
(license license:gpl3+))))
(define-public emacs-lua-mode
- (let ((commit "1f596a93b3f1caadd7bba01030f8c179b029600b")
- (revision "1"))
+ (let ((commit "35b6e4c20b8b4eaf783ccc8e613d0dd06dbd165c")
+ (revision "0"))
(package
(name "emacs-lua-mode")
- (version (git-version "20191204" revision commit))
+ (version (git-version "20200508" revision commit))
(home-page "https://github.com/immerrr/lua-mode/")
(source (origin
(method git-fetch)
@@ -8306,14 +8306,14 @@ using package inferred style.")
(file-name (git-file-name name version))
(sha256
(base32
- "0i4adlaik3qjx1wkb7rwk2clvj7ci2g8pm0siyb3yk90r6z5mspi"))))
+ "1hai6rqjm5py0bp57nhggmj9qigwdj3a46ngacpnjc1qmy9kkgfk"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
- #:test-command '("buttercup" "-l" "lua-mode.el")))
+ #:test-command '("buttercup" "-l" "lua-mode.el")))
(native-inputs
`(("emacs-buttercup" ,emacs-buttercup)
- ("lua" ,lua)))
+ ("lua" ,lua)))
(synopsis "Major mode for lua")
(description
"This Emacs package provides a mode for @uref{https://www.lua.org/,
--
2.26.2