[core-updates] pdfpc-4.3.4 fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Marius Bakke
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 24 Apr 2020 21:58
(address . bug-guix@gnu.org)
alpine.DEB.2.20.2004241556180.5735@marsh.hcoop.net
Hi Guix,

Currently, pdfpc on core-updates fails to build with:

/tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/action/action_mapping.vala:51.9-51.28: error: Creation method of abstract class cannot be public.
public ActionMapping() {
^^^^^^^^^^^^^^^^^^^^
/tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/drawings/storage.vala:38.9-38.19: error: Creation method of abstract class cannot be public.
public Base(Metadata.Pdf metadata) {
^^^^^^^^^^^
/tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/renderer/cache/base.vala:40.9-40.19: error: Creation method of abstract class cannot be public.
public Base(Metadata.Pdf metadata) {
^^^^^^^^^^^
/tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/timer_label.vala:98.9-98.25: error: Creation method of abstract class cannot be public.
public TimerLabel(PresentationController controller, time_t start_time = 0) {
^^^^^^^^^^^^^^^^^
/tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/view/behaviour/base.vala:44.9-44.19: error: Creation method of abstract class cannot be public.
public Base() {
^^^^^^^^^^^

Upgrading to the latest release, 4.4.0, solves the problem. I have
prepared the following patch against core-updates that does that.

Best,
Jack
J
J
Jack Hill wrote on 24 Apr 2020 22:04
[PATCH core-updates] gnu: pdfpc: Upgrade to 4.4.0
(address . 40829@debbugs.gnu.org)(name . Jack Hill)(address . jackhill@jackhill.us)
20200424200402.4965-1-jackhill@jackhill.us
* gnu/packages/pdf.scm (pdfpc): Upgrade to 4.4.0.
---
gnu/packages/pdf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8ccb133e1f..f4ffda7462 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1232,7 +1232,7 @@ multiple files.")
(define-public pdfpc
(package
(name "pdfpc")
- (version "4.3.4")
+ (version "4.4.0")
(source
(origin
(method git-fetch)
@@ -1241,7 +1241,7 @@ multiple files.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "07aafsm4jzdgpahz83p0ajv40hry7gviyadqi13ahr8xdhhwy2sd"))))
+ (base32 "0vh2r32akvasdrghkaq7ard24r2qncp34jfiyshi3zxabm9bhfaa"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no test target
(inputs
--
2.26.2
M
M
Marius Bakke wrote on 24 Apr 2020 23:26
Re: bug#40829: [core-updates] pdfpc-4.3.4 fails to build
87blngfudi.fsf@devup.no
Jack Hill <jackhill@jackhill.us> writes:

Toggle quote (23 lines)
> Hi Guix,
>
> Currently, pdfpc on core-updates fails to build with:
>
> /tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/action/action_mapping.vala:51.9-51.28: error: Creation method of abstract class cannot be public.
> public ActionMapping() {
> ^^^^^^^^^^^^^^^^^^^^
> /tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/drawings/storage.vala:38.9-38.19: error: Creation method of abstract class cannot be public.
> public Base(Metadata.Pdf metadata) {
> ^^^^^^^^^^^
> /tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/renderer/cache/base.vala:40.9-40.19: error: Creation method of abstract class cannot be public.
> public Base(Metadata.Pdf metadata) {
> ^^^^^^^^^^^
> /tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/timer_label.vala:98.9-98.25: error: Creation method of abstract class cannot be public.
> public TimerLabel(PresentationController controller, time_t start_time = 0) {
> ^^^^^^^^^^^^^^^^^
> /tmp/guix-build-pdfpc-4.3.4.drv-0/source/src/classes/view/behaviour/base.vala:44.9-44.19: error: Creation method of abstract class cannot be public.
> public Base() {
> ^^^^^^^^^^^
>
> Upgrading to the latest release, 4.4.0, solves the problem. I have
> prepared the following patch against core-updates that does that.

Thanks! I pushed the patch to the "master" branch: it will land on
"core-updates" shortly.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6jWXkACgkQoqBt8qM6
VPpwiQf/fSPOYrx2+i3O9G0T7ynrR5ZXruuJ0shgE1704wNOfqga4/XRQsJXNj43
REDlf4qepm4wcWZzsjjijWVEeINagKIASyn7TZukfi/WlrKuSvVKPMalHjLWny79
1F3hU3fcOwP+YUYEllRkZx1NNW1szJ4fMM3HUiZo9ig8KA8d9F/H7i/da+JdsGPg
TaZXAxzK1dbmousxMhsUtIJvjtTBYbufZOnjgxbOIIPFxwMmifJ8XYlFRCCKSmbh
73vjHgf+N7C4TTT0AqraV5UbIJLLv6b+pUHFMb6Y7v1GfbN+nGVfZXA+TQv/ylte
vn+2WAf787NauLaFyzs383KC0zBhqw==
=le2n
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 40829@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 40829
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch