Allow double-click select of URL in status

  • Done
  • quality assurance status badge
Details
4 participants
  • Leo Famulari
  • Marius Bakke
  • Tom Zander
  • Vincent Legoll
Owner
unassigned
Submitted by
Tom Zander
Severity
normal
T
T
Tom Zander wrote on 14 Mar 2020 15:01
(address . guix-patches@gnu.org)
4553177.31r3eYUQgx@cherry
While I've been playing with guix today I found this rather trivial patch
to be nice. Nice enough to maybe start, even though I'm still waiting for some
compiles I'll submit this trivial patch untested.

Lets see how the social (as opposed to technical) part works.

Is this patch Ok?
--
Tom Zander
From ab690e91f177e0e3efa557fc9ac72ebbc89cb0ad Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Sat, 14 Mar 2020 14:36:28 +0100
Subject: [PATCH] Allow double-click select of URL in status

The status during an install prints download-targets.
This adds a space between the URL and the '...' string trailing it
so on a terminal you can just double click on the URL to select it.
---
guix/status.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/status.scm b/guix/status.scm
index cbea4151f2..a39d91e0dc 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -517,7 +517,7 @@ addition to build events."
(newline port)))
(('download-started item uri _ ...)
(erase-current-line*)
- (format port (info (G_ "downloading from ~a...")) uri)
+ (format port (info (G_ "downloading from ~a ...")) uri)
(newline port))
(('download-progress item uri
(= string->number size)
--
2.25.1
T
T
Tom Zander wrote on 14 Mar 2020 18:16
Version two of the patch.
(address . 40061@debbugs.gnu.org)
5416391.DvuYhMxLoT@cherry
Attached is an updated version of the patch, it fixes more of the same issues.
From 0b2a17de72825b9ca0d494ea8c4d9bf121689f4e Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Sat, 14 Mar 2020 14:36:28 +0100
Subject: [PATCH] Allow double-click select of URL in status

Various places while downloading or compiling guix
prints the source URL. This change makes the URL be easier
to be used by placing a space between the URL and the trailing
dots.
---
guix/status.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/guix/status.scm b/guix/status.scm
index cbea4151f2..866ba3bc39 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -472,8 +472,8 @@ addition to build events."
(let ((count (match (assq-ref properties 'graft)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "applying ~a graft for ~a..."
- "applying ~a grafts for ~a..."
+ (format port (info (N_ "applying ~a graft for ~a ..."
+ "applying ~a grafts for ~a ..."
count))
count drv)))
('profile-hook
@@ -484,7 +484,7 @@ addition to build events."
(format port (info (G_ "running profile hook of type '~a'..."))
hook-type))))
(_
- (format port (info (G_ "building ~a...")) drv))))
+ (format port (info (G_ "building ~a ...")) drv))))
(newline port))
(('build-succeeded drv . _)
(erase-current-line*) ;erase spinner or progress bar
@@ -517,7 +517,7 @@ addition to build events."
(newline port)))
(('download-started item uri _ ...)
(erase-current-line*)
- (format port (info (G_ "downloading from ~a...")) uri)
+ (format port (info (G_ "downloading from ~a ...")) uri)
(newline port))
(('download-progress item uri
(= string->number size)
--
2.25.1
L
L
Leo Famulari wrote on 14 Mar 2020 18:48
(name . Tom Zander via Guix-patches via)(address . guix-patches@gnu.org)(address . 40061@debbugs.gnu.org)
20200314174816.GB24608@jasmine.lan
On Sat, Mar 14, 2020 at 06:16:52PM +0100, Tom Zander via Guix-patches via wrote:
Toggle quote (12 lines)
> Attached is an updated version of the patch, it fixes more of the same issues.

> From 0b2a17de72825b9ca0d494ea8c4d9bf121689f4e Mon Sep 17 00:00:00 2001
> From: TomZ <tomz@freedommail.ch>
> Date: Sat, 14 Mar 2020 14:36:28 +0100
> Subject: [PATCH] Allow double-click select of URL in status
>
> Various places while downloading or compiling guix
> prints the source URL. This change makes the URL be easier
> to be used by placing a space between the URL and the trailing
> dots.

Thanks, this is great. I get annoyed by this constantly.

Any other feedback?
L
L
Leo Famulari wrote on 14 Mar 2020 19:45
[tomz@freedommail.ch: Re: [bug#40061] Version two of the patch.]
(address . 40061@debbugs.gnu.org)
20200314184531.GA3482@jasmine.lan
----- Forwarded message from Tom Zander <tomz@freedommail.ch> -----

Date: Sat, 14 Mar 2020 19:32:40 +0100
From: Tom Zander <tomz@freedommail.ch>
To: Leo Famulari <leo@famulari.name>
Subject: Re: [bug#40061] Version two of the patch.

On zaterdag 14 maart 2020 18:48:16 CET Leo Famulari wrote:
Toggle quote (19 lines)
> On Sat, Mar 14, 2020 at 06:16:52PM +0100, Tom Zander via Guix-patches via wrote:
> > Attached is an updated version of the patch, it fixes more of the same
> > issues.
> >
> > From 0b2a17de72825b9ca0d494ea8c4d9bf121689f4e Mon Sep 17 00:00:00 2001
> > From: TomZ <tomz@freedommail.ch>
> > Date: Sat, 14 Mar 2020 14:36:28 +0100
> > Subject: [PATCH] Allow double-click select of URL in status
> >
> > Various places while downloading or compiling guix
> > prints the source URL. This change makes the URL be easier
> > to be used by placing a space between the URL and the trailing
> > dots.
>
> Thanks, this is great. I get annoyed by this constantly.
>
> Any other feedback?


I wrote down some more silly things that I'm not sure I'll get to.

Imagine the following;

guix package -i guile-git
The following package will be upgraded:
guile-git 0.3.0 → 0.3.0 /gnu/store/h5y9c889q237a0sjzn68zflkmk3zz33f-guile-git-0.3.0

Instead of saying "upgraded" it should say "reinstalled".

then: the 'info guix' chapter 2.6.1 Locales
has this gem:
«Note that the ‘glibc-locales’ package contains data for all the
locales supported by the GNU libc and weighs in at around 110 MiB.»

If you install it you'll note its well over 200MB, though. That at minimum should
be updated in the info. Or more likely just stated that its large.


Thanks!
--
Tom Zander



----- End forwarded message -----
V
V
Vincent Legoll wrote on 30 Mar 2020 12:05
Re: Allow double-click select of URL in status
(address . 40061@debbugs.gnu.org)
CAEwRq=pff_wOtqu5w1igot+7wsya7mWpi3GNy=5DTA_Zyy0sHQ@mail.gmail.com
LGTM, except maybe the following change to the
commit msg:

This change makes the URL be easier to be used
=>
This change makes the URL easier to use

But that may not warrant a new patch submission,
though, as the committer may do it himself...

Thanks

--
Vincent Legoll
T
T
Tom Zander wrote on 7 Apr 2020 21:43
[Patch] rebase and fix wording
(address . 40061@debbugs.gnu.org)
5662160.DvuYhMxLoT@cherry
--
Tom Zander
From a9a7f4c8bf513aeac95f7d1bc87c6edddefec0d0 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Tue, 7 Apr 2020 21:39:04 +0200
Subject: [PATCH] Allow double-click select of URL in status

Various places while downloading or compiling guix prints
the source URL. This change makes the URL easier to use by
placing a space between the URL and the trailing dots.
---
guix/status.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (36 lines)
diff --git a/guix/status.scm b/guix/status.scm
index 4b2edc2f3c..45e441eac5 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -472,16 +472,16 @@ addition to build events."
(let ((count (match (assq-ref properties 'graft)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "applying ~a graft for ~a..."
- "applying ~a grafts for ~a..."
+ (format port (info (N_ "applying ~a graft for ~a ..."
+ "applying ~a grafts for ~a ..."
count))
count drv)))
('profile
(let ((count (match (assq-ref properties 'profile)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "building profile with ~a package..."
- "building profile with ~a packages..."
+ (format port (info (N_ "building profile with ~a package ..."
+ "building profile with ~a packages ..."
count))
count)))
('profile-hook
@@ -525,7 +525,7 @@ addition to build events."
(newline port)))
(('download-started item uri _ ...)
(erase-current-line*)
- (format port (info (G_ "downloading from ~a...")) uri)
+ (format port (info (G_ "downloading from ~a ...")) uri)
(newline port))
(('download-progress item uri
(= string->number size)
--
2.25.1
M
M
Marius Bakke wrote on 7 Apr 2020 22:00
Re: [bug#40061] Allow double-click select of URL in status
87r1wzkqvy.fsf@devup.no
Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (10 lines)
> LGTM, except maybe the following change to the
> commit msg:
>
> This change makes the URL be easier to be used
> =>
> This change makes the URL easier to use
>
> But that may not warrant a new patch submission,
> though, as the committer may do it himself...

Whoops, I committed this without seeing this comment, oh well!

Pushed in 9f1b787120b1b81abffaf0fa13fdbdf4cca39f2d.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6M2+EACgkQoqBt8qM6
VPpKegf+PGpakq/Fr8xHA6kSmEoEZ5T3MPNoLS5gHmtfVDF6YCtHVF5LVuPNhti+
deayTs028xbeoeect1o2Ofgz5PS+rXSsMCdVgS6cEau6XCW067++wSWlb2O+U5YB
j+jhxAaoPzX/5LglrYPTAV5R0cSSCQcxrbCw3jMrDX/Rj/1IlQkxhshddaBsMjcz
fLOSTlDB5TIDn7rzYjMFo7gaVp2epMjygXNEcUunnX6HgoOg0oyYfLbQ13nbbrJ1
MRRTWoXrrSfxEsb88673yqLqzOl2E13zUWQM1Pi7BJRieIsiYD3sNMTNuHpx/Y5k
pYiKW9GZLuFZbtiVTagv2Es65rzlAw==
=b/sP
-----END PGP SIGNATURE-----

Closed
V
V
Vincent Legoll wrote on 7 Apr 2020 22:05
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 40061-done@debbugs.gnu.org)
CAEwRq=o_EYFcOzx3QNinzuurDsRchZJ2G2d=pWCnqAax61wC0A@mail.gmail.com
Hello,

On Tue, Apr 7, 2020 at 10:00 PM Marius Bakke <mbakke@fastmail.com> wrote:
Toggle quote (13 lines)
> Vincent Legoll <vincent.legoll@gmail.com> writes:
> > LGTM, except maybe the following change to the
> > commit msg:
> >
> > This change makes the URL be easier to be used
> > =>
> > This change makes the URL easier to use
> >
> > But that may not warrant a new patch submission,
> > though, as the committer may do it himself...
>
> Whoops, I committed this without seeing this comment, oh well!

Not really a problem ;-)

It was just in case...

--
Vincent Legoll
Closed
M
M
Marius Bakke wrote on 7 Apr 2020 22:12
87lfn7kqbh.fsf@devup.no
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (2 lines)
> Pushed in 9f1b787120b1b81abffaf0fa13fdbdf4cca39f2d.

I reverted this temporarily to avoid having to request updated
translations for Guix 1.1.0.

It will have to wait until after the 1.1.0 release.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6M3sIACgkQoqBt8qM6
VPrHSggAurtyohjx8CAUcFTpHP77vxPfylAbCZbI+MUwK65CAV/kK3GM7O5gY1fj
NF2yRGQDwEqV87Dsu0sdX2Dbyel5nAIIq0GnOb5IVbTaf/G0NswTZpgSaA97pVRv
n1dSVo4xhp4eCqgV2WvVHF18sXjHSl+FiNb5vFOzqwnG0tLE1fx4JlNZu84Yda6/
glDNKVns8Z8U0j9bJvYJgMc74XIrrpvQes/L5ZryU/vkFMfWpa61270+8z7lWUx1
cgyub0WYY9gf98WMJ6rHUvB7DvDX2n8unCZ4hhsKUgMRIRiUDZtTIrQW7Lq8I7tv
EtlY5lyZAx24TwugzDkGDOs4a+lAmg==
=m9Od
-----END PGP SIGNATURE-----

T
T
Tom Zander wrote on 7 Apr 2020 22:33
11906110.O9o76ZdvQC@cherry
On dinsdag 7 april 2020 22:00:33 CEST Marius Bakke wrote:
Toggle quote (15 lines)
> Vincent Legoll <vincent.legoll@gmail.com> writes:
> > LGTM, except maybe the following change to the
> > commit msg:
> >
> > This change makes the URL be easier to be used
> > =>
> > This change makes the URL easier to use
> >
> > But that may not warrant a new patch submission,
> > though, as the committer may do it himself...
>
> Whoops, I committed this without seeing this comment, oh well!
>
> Pushed in 9f1b787120b1b81abffaf0fa13fdbdf4cca39f2d.

No worries, I actually used Vincent's suggested words in the rebase, which is
the patch you applied.

--
Tom Zander
Closed
M
M
Marius Bakke wrote on 7 Apr 2020 22:43
87d08jkox6.fsf@devup.no
Tom Zander <tomz@freedommail.ch> writes:

Toggle quote (19 lines)
> On dinsdag 7 april 2020 22:00:33 CEST Marius Bakke wrote:
>> Vincent Legoll <vincent.legoll@gmail.com> writes:
>> > LGTM, except maybe the following change to the
>> > commit msg:
>> >
>> > This change makes the URL be easier to be used
>> > =>
>> > This change makes the URL easier to use
>> >
>> > But that may not warrant a new patch submission,
>> > though, as the committer may do it himself...
>>
>> Whoops, I committed this without seeing this comment, oh well!
>>
>> Pushed in 9f1b787120b1b81abffaf0fa13fdbdf4cca39f2d.
>
> No worries, I actually used Vincent's suggested words in the rebase, which is
> the patch you applied.

Oh heh, patch overload I guess!

Note that the patch was temporarily reverted (I forgot to CC you in the
previous message to this issue):

Feel free to ping this bug once 1.1.0 is out to get it re-applied. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6M5dUACgkQoqBt8qM6
VPqWjwgAiDeyjQAWvHRwXXO1mrIL4ove+70Imch+Ua2PDfEoxtAxQA4E1RJWvR79
r6Ci50YRRCJHje1trt09EM4K1NpYf315L4JBrN8c0y7GpxrCnIgwCXF+UL94dIQc
biP/uebl+NIMeUIHcO31GyfqKYYXGC/yvmh9me+oeyeCoA3e70mkuC6YZM823Tme
mMerrrWNrgGoon3JYIZUfk85KdSo2Vk/KvWwO5xopZm7uIIvZnv20AYrZzN128ee
mpfTWgnzppQ+gsI+LOFw49c1GpaJNWx3tyvy7EZd5OxCI0zps9ikcNUki4zN6hcv
Yf1d+QlUrhb3W3Q2zIQmPW1dzMfPnA==
=0bZv
-----END PGP SIGNATURE-----

Closed
M
M
Marius Bakke wrote on 17 Apr 2020 17:28
87r1wmgmil.fsf@devup.no
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (6 lines)
> Note that the patch was temporarily reverted (I forgot to CC you in the
> previous message to this issue):
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=1c86577d624b97a03138640b4d849823b504570e
>
> Feel free to ping this bug once 1.1.0 is out to get it re-applied. :-)

Finally applied in 8fa4ac5be4d5f8a1e62635842b16486832ff49f1 after a
friendly ping on #guix:matrix.org :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6ZywIACgkQoqBt8qM6
VPpqiwf+Na4OdG5tkcymMpJFsv/mOHADFKRSjnoADfQ9O7Kcv0m68mHGV4nLLuQJ
VIfTrcOwF41eRSXJ1YiD6i7Txf/mwyBr7tibOvXKpLw0TRD1VZASi0RnJQknMzrn
JZybhWmP9vsvLN9/QGJQBwywXrn7KbctFMX7mthfVPqi3P08luuJbL45B3/Hp3op
LAFgsYM1l88Va/BUtt2B4N2kxzb0lDBEtRpZiheyzRxvUxb5LiDE6PJudYwANN5S
ZME8W+Yj0U0ncCgTj2LcbYfv5h94h2qev4zeSWwRW+4GDOxar+5xhTy5OpMjd6aY
p3MvtGJW66NA90YEpLk+RXyednR4Ug==
=L6ma
-----END PGP SIGNATURE-----

Closed
?